Windows Errors part 30

Chia sẻ: Dương Tùng Lâm | Ngày: | Loại File: PDF | Số trang:5

0
29
lượt xem
4
download

Windows Errors part 30

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tham khảo tài liệu 'windows errors part 30', công nghệ thông tin, hệ điều hành phục vụ nhu cầu học tập, nghiên cứu và làm việc hiệu quả

Chủ đề:
Lưu

Nội dung Text: Windows Errors part 30

  1. Loại bỏ chức năng File Optimizer của MS OFFICE 2000 Khi bạn cài đặt xong bộ MS Office 2000, hộp thoại File Optimizer sẽ xuất hiện ở những lần khởi động sau. Chức năng chính của công cụ này là tổ chức và sắp xếp lại các tập tin có liên quan đến bộ MS Office để có thể khởi động các ứng dụng của nó nhanh hơn. Tuy nhiên, chức năng này thường gây treo máy hoặc mất thời gian mà không có cách nào làm cho nó dừng lại được. Bạn có thể loại bỏ chức năng này vĩnh viễn bằng cách chỉnh sửa trong Registry, nhưng mất thời gian và nguy hiểm. Bạn có thể “xử” nó một cách an toàn hơn bằng cách : khi hộp thoại File Optimizer xuất hiện, hãy nhanh tay nhấp chuột bỏ dấu chọn mục Run checks in the Future và nhấn ngay vào nút Cancel (bạn chỉ có bốn giây để làm việc này thôi đấy). Bảo vệ công thức trong Microsoft Excel Một bảng tính Excel thông thường có hai phần: dữ liệu “thô” là số liệu thực tế và phần công thức để tính toán. Công thức để tính toán đôi khi khá phức tạp và đòi hỏi nhiều công sức, còn dữ liệu thô thì có thể ai nhập cũng được. Do đó, vấn đề sẽ không còn đơn giản nếu trong bảng tính có chỗ ta muốn bảo vệ mà có chỗ lại không. Cách làm của tôi trong việc bảo vệ công thức là cứ để các ô bị locked theo mặc định, không cần phải thay đổi gì. Nhưng khi người dùng thay đổi (kể cả việc xóa) các ô có công thức (bắt đầu bằng dấu = ) thì việc khóa sẽ thực hiện (giống như vào menu Tools -> Protect Sheet). Còn khi người dùng thay đổi ô không phải là công thức thì việc thay đổi sẽ được chấp nhận (tương đương với việc chọn Tools\Unprotect Sheet) Vào menu Tools - Macro - Visual Basic Editor Cửa sổ soạn thảo Visual Basic hiện ra, khung bên trái là Project Explore (nếu chưa thấy thì chọn menu View - Project Explorer). Nhấp kép chuột vào This WorkBook, gõ vào khung soạn thảo bên phải đoạn mã
  2. Private Sub WorkBook_SheetSelectionChange (ByVal Sh As Object, ByVal Target As Range) Dim rng As Range For Each rng In Target.Cells If rng.HasFormula Then ActiveSheet.Protect Exit Sub Else ActiveSheet.Unprotect End If Next rng End Sub Đóng cửa sổ Visual Basic Editor, lưu và thoát khỏi Excel. Kể từ đây, các công thức sẽ được bảo vệ. - Một số dữ liệu dù bản chất không là công thức nhưng bạn muốn nó không bị thay đổi thì có thể nhập như dưới dạng công thức với dấu bằng để có thể được bảo vệ luôn, chẳng hạn =290.000 thay vì là một con số 290.000 - Người dùng có thể “táy máy” chọn Tools\Unprotect Sheet để sửa đổi, vì vậy cần đặt thêm mật khẩu trong đoạn mã trên: Ở câu lệnh ActiveSheet.Protect ta viết thành (giả sử mật khẩu là “123456”): ActiveSheet.Protect(“123456”) Và do đó ở câu lệnh ActiveSheet.Unprotect phải sửa lại là: ActiveSheet.Unprotect(“123456”) - Nếu cẩn thận hơn, phòng người dùng vào Visual Basic Editor để “dòm” mật khẩu (giả sử tên Book của bạn là bangtinh) thì mở cửa sổ Visual Basic Editor - khung Project Explorer, nhấp phải vào VBAProject(bangtinh.xls) - Properties - thẻ Protection, chọn Lock project for viewing - gõ mật khẩu - lưu và thoát khỏi Excel. Chia sẻ máy in trong Windows XP Có thể vào một ngày đẹp trời nào đó tại nơi làm việc, bạn được trao quyền quản lý một cái máy in. Người ta khệ nệ bưng máy in đến chỗ bạn ngồi và nối nó với máy tính của bạn. Nếu máy tính của bạn đang chạy Windows XP thì việc cài đặt máy in cực kỳ đơn giản: bạn không phải làm gì cả, Windows XP tự động nhận biết máy in mới và hiển thị ở thanh tác vụ thông báo ngắn gọn Found New Hardware kèm theo
  3. tên của máy in. Từ lúc đó, bạn có thể thoải mái in ra giấy trên máy in mới bằng những công cụ quen thuộc: Word, Excel... Có điều đáng quan tâm, từ ấy bạn sẽ phải chịu áp lực: cho phép đồng nghiệp dùng máy in ấy thông qua mạng cục bộ (printer sharing). Và cũng từ ấy, bạn sẽ phải chịu tiếng ồn máy in và thường xuyên giật mình vì bất ngờ máy in bị ai đó cho chạy. Nhưng biết làm sao hơn khi sếp đã giao nó cho bạn. Chia sẻ máy in Để “se” (share) cái máy in “của nợ từ trên trời rớt xuống” ấy cho đồng nghiệp, bạn phải vào thư mục Printers and Faxes. Cụ thể, bạn làm như sau: Bấm nút Start, chọn Control Panel. Trong cửa sổ Control Panel, bạn mở Printers and Other Hardware rồi mở Printers and Faxes. Trong cửa sổ Printers and Faxes, bạn bấm-phải vào biểu tượng máy in và chọn Sharing trên trình đơn vừa hiện ra. Trong hộp thoại Properties, bạn chọn thẻ Sharing, chọn Share this printer và đặt tên cho máy in trong ô Share name. Tên máy in do bạn đặt sẽ giúp mọi người trong mạng hiểu ngay máy in đó thuộc loại gì, có ưu điểm gì (chẳng hạn, máy in màu hay “đen trắng”). Nếu thực tình... không muốn người ta dùng máy in, bạn có thể đặt tên chi đó thật “gợi hình gợi cảm” đại khái như May in LaserJet 6L ca rich ca tang (chuyện này nói nhỏ thôi nghen!). Xong xuôi, bạn bấm OK. Cần nói thêm rằng nếu trong mạng cục bộ của bạn vẫn còn những máy tính chạy Windows 95/98/ME, Windows NT 4.0 hoặc Windows 2000, bạn phải cài đặt bổ sung các trình điều khiển máy in (printer driver) thích hợp thì “người ta” mới dùng được máy in của bạn. Muốn vậy, trên hộp thoại Properties ứng với máy in đang xét, sau khi đặt tên Share name, bạn hãy... khoan bấm OK mà “chịu khó” chọn Additional Drivers. Trên hộp thoại Additional Drivers, bạn chọn trình điều khiển máy in cần thiết rồi bấm OK. Bạn sẽ được yêu cầu đưa đĩa Support trong bộ đĩa Windows XP vào ổ CD. Cài đặt máy in được chia sẻ Để cài đặt máy in nào đó đã được chia sẻ, bạn thực hiện các bước như sau: Vào thư mục Printers and Faxes. Nghĩa là phải bấm nút Start, chọn Control Panel, chọn Printers and Other Hardware rồi chọn Printers and Faxes. Trong cửa sổ Printers and Faxes, bạn chọn Add a printer trong danh sách Printers tasks. Hộp thoại Add Printer Wizard sẽ hiện ra ngay. Bấm vào Next để bỏ qua trang đầu (Welcome to the Add Printer Wizard) của hộp
  4. thoại Add Printer Wizard. Trên trang tiếp theo (Local or Network Printer), bạn chọn A network printer, or a printer attached to another computer rồi bấm Next. Trên trang Specify a Printer, bạn có thể chọn Browse for a printer và bấm Next để truy tìm máy in được chia sẻ trên mạng. Thông thường, bạn biết rõ tên của máy in được chia sẻ và tên của máy tính nối trực tiếp với máy in đó. (Quá dễ, bạn chỉ việc đi ngay đến chỗ ngồi của “khổ chủ” của máy in và cười thật... dễ thương, chắc chắn bạn sẽ được chỉ dẫn tận tình. Dù thế nào cũng phải nói với người ta một tiếng trước khi dùng máy in.) Thế thì bạn chọn Connect to this printer, gõ vào ô Name bên dưới theo dạng thức như sau: \\TênMáyTính\TênMáyInĐượcChiaSẻ rồi bấm Next. Trên trang Default Printer, bạn chọn Yes nếu muốn máy in “chùa” trở thành máy in mặc định của mình. Bạn có thể chọn No nếu có máy in riêng (nối trực tiếp với máy tính của bạn) và chỉ muốn nhờ vả người ta khi thật cần thiết (“dù trong dù đục ao nhà vẫn hơn”). Xong, bạn lại bấm Next. Trên trang cuối cùng Completing the Add Printer Wizard, bạn chỉ việc bấm Finish là xong. Từ đó, máy in mà bạn “mong mỏi” sẽ xuất hiện trong cửa sổ Printers and Faxes một cách “đàng hoàng”, bên cạnh máy in riêng của bạn (nếu có). Bạn hãy kiểm tra ngay xem có phải như vậy không. Sử dụng thanh công cụ Word Count Khi muốn thống kê xem văn bản của mình đã dài bao nhiêu ký tự, nếu nhờ vả thanh công cụ Word Count, bạn sẽ mất ít thời gian hơn thay vì phải ngồi đếm từng chữ. Để mở nó, bạn vào menu View - Toolbars - Word Count hoặc vào menu Tools - Word Count - nhấn nút Show Toolbar Bạn chỉ việc nhấn nút Recount là mọi thông tin mong muốn sẽ hiện ra. Trong trường hợp muốn thống kê thông tin của đoạn văn bản thì trước khi nhấn Recount, bạn cần đánh dấu đoạn văn bản đó trước. Thêm và thay đổi menu ngữ cảnh (context menu) của File, Thư mục và Drive Menu ngữ cảnh (context menu) là cái gì nhỉ? À, chính là cái menu bạn thấy khi nhấn chuột phải ấy mà. Ừ thì đúng là menu đấy, nhưng sao gọi là ngữ cảnh chứ? Vì tùy vào từng đối tượng bạn đang trỏ vào sẽ có một menu tương ứng với nó. Nghĩa là với các đối tượng khác nhau thì menu này sẽ khác nhau. Tùy chọn in đậm “Play” sẽ là mục chọn ngầm định khi bạn nháy đúp chuột trái. Các mục khác như “Eject”, “AutoPlay” chỉ có với ổ đĩa CD mà thôi. Một số
  5. chương trình như ACDSee, Winzip, Winrar... có thể thêm các mục chọn vào menu ngữ cảnh. Vậy chúng ta có thể làm điều đó được không vậy? Tất nhiên là được. Sau đây tôi xin hướng dẫn cách thêm một mục vào context menu của ổ đĩa cứng.
Đồng bộ tài khoản