Xử lý kết quả thí nghiệm - Ứng dụng IRRISTAT 4.0 cho Window

Chia sẻ: Minhhuy Minhhuy | Ngày: | Loại File: DOC | Số trang:78

0
1.062
lượt xem
153
download

Xử lý kết quả thí nghiệm - Ứng dụng IRRISTAT 4.0 cho Window

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Đây là cuốn sách thực hành để phân tích các kết quả thực nghiệm bằng IRRISTAT 4.0 trong Window. Rất tiện lợi cho người sử dụng vì có hình ảnh minh họa và những hướng dẫn chi tiết để người đọc có thể làm theo. Sách sẽ rất hữu ích cho sinh viên và các nhà khoa học nghiên cứu trong lĩnh vực nông nghiệp.

Chủ đề:
Lưu

Nội dung Text: Xử lý kết quả thí nghiệm - Ứng dụng IRRISTAT 4.0 cho Window

  1. Xử Lý KếT QUả THí NGHIệM ứng dụng IRRISTAT 4.0 for Windows Analysis Experimental Data Using IRRISTAT 4.0 for Windows Phạm Tiến Dũng Kasetsart University, Thailand, 2001 Thanks! Thank to the help of Thailand Government’s finances in the Faculty Staff and Student Exchaenges Program between Kasetsart University (KU) and Hanoi Agricultural University (HAU), the arrangement of the KU International Programs, HAU International Office, the Individuals such as Professor Doctor Dang Vu Binh, Associate Professor Doctor Chitapa Ketewan, Doctor Tran Duc Vien, Associate Professor Doctor Suwapong Swasdiphanich, Associate Professor Doctor Rangsarid Kaveeta, Mr Choosak Jompuk, Mr. Piya Kittipadakul and others that I had a good chance to study in Thailand and to compose this book.
  2. On this occasion I have great thanks to the institutions and individuals mentioned above. Pham Tien Dung Hanoi Agricultural University, Vietnam Cám ơn! Nhờ sự giúp đỡ về tài chính của Chính phủ Thai lan trong khuôn khổ chương trình trao đổi cán bộ và học sinh các khoa giữa Đại học Kaetsart (KU) Thai lan và Đại học Nông nghiệp Hà nội (HAU), Phòng Quan hệ Quốc tế KU, Phòng Quản lý Khoa học và Quan hệ Quốc tế HAU, Giáo sư Tiến sỹ Đặng Vũ Bình, Phó giáo sư, Tiến sỹ Chitapa Ketewan, Tiến sỹ Trần Đức Viên, Phó Giáo sư, Tiến sỹ Suwapong Swasdiphanich, Phó Giáo sư, Tiến sỹ Rangsarid Kaveeta, ông Choosak Jomput, ông Piya Kittipadakul và những người giúp việc khác mà tôi đ• có cơ hội tốt cho nghiên cứu ở Thái lan và biên soạn cuốn sách này. Nhân dịp này tôi xin cảm ơn tất cả các tổ chức và cá nhân trên đ• tạo điều kiện giúp đỡ tôi. Phạm Tiến Dũng Đại học Nông nghiệp I Hà nội Comments Considering about this book, I believe that Doctor Dung had worked very hard to have the book. This is one of the products that Doctor Dung has
  3. gained in the period of three months working at Agronomy Department, Kasetsart University in the Faculty Staff and Student Exchange Program Between Kasetsart University and Hanoi Agricultural University. Contents of the book are simple, understandable and very useful to the Agricultural Researchers using for their experimental data analysis. Like in our Department of Agronomy, the book should be put into teaching practice to your agricultural students. I wish you more successful. November 5th, 2001 Associate Professor Doctor Suwapong Swasdiphanich Head of Department of Agronomy Faculty of Agriculture, Kasetsart University, Thailand Contents
  4. Nội dung Trang Phần I: Giới thiệu ( Introduction to ) IRISTAT 4.0 I. Các cửa sổ Window 2 II. Menus 6 III. Job Specification Components 13 IV. Ngẫu nhiên hoá và tạo sơ đồ thí nghiệm ( Randomization and Layout ) 18 Phần II. Quản lý file số liệu ( Data and file Management ) 23 I. Bộ số liệu mẫu ( Sample data set ) 23 II. Tạo file số liệu ( Data creation ) 24 Phần III. Một số mẫu phân tích phương sai ( Some samples of Analysis of variance ) 47 I. Thí nghiệm một nhân tố ( Sigle factor Experiment ) 47 1.1 Mô hình kiểu hoàn toàn ngẫu nhiên 47 ( Completely Randomized Design: CRD) 1.2. Mô hình kiểu khối ngẫu nhiên đầy đủ 52 ( Randomized Complete Block Design, RCB ). 1.3. Thiết kế Ô vuông La tin ( Latin Square Design, LS ) 55 1.4. Thí nghiệm bố trí kiểu Lattice – Lattice cân đối 59 ( Lattice Design - Balanced Lattice ) II. Thí nghiệm hai nhân tố ( Two factors Experiment ) 65 2.1 Thiết kế khối ngẫu nhiên đầy đủ (Factorial experiment ) 65 2.2 Thí nghiệm thiết kế kiểu chia ô lớn, ô nhỏ (Split-plot). 70 2.3 Thí nghiệm kiểu chia băng ( Strip-Plot Design ) 76 III. Thí nghiệm 3 yếu tố bố trí kiểu chia ô lớn, ô vừa, ô nhỏ (Split- split-plot). 82 IV. Phân tích số liệu qua nhiều nơi ( Analysis over Sites ) 91 V. Phân tích số liệu qua nhiều năm ( Analysis over Yeas ) 95 Phần IV. Phân tích hồi qui ( Regreesion Analysis ) 4.1. Hồi qui tuyến tính đơn ( Simple Liner Regreesion ) 100 4.2. Hồi qui bội tuyến tính ( Multiple Liner Regreesion ) 104 Giới thiệu Đây la cuốn sách thực hành để phân tích các kết quả thực nghiệm bằng IRRISTAT 4.0 trong Window. Rất tiện lợi cho người sử dụng vì có hình
  5. ảnh minh hoạ các bước cụ thể cho người sử dụng làm theo. Đặc biệt với những người không am hiểu nhiều về máy tính cũng như kiến thức về thống kê cũng có thể sử dụng được. Nội dung cơ bản gồm 2 phần: 1. Giới thiệu khái quát những nội dung và chức năng cơ bản của IRRISTAT 4.0 trong Window. 2. Một số mẫu phân tích phương sai, hồi qui cơ bản thường được sử dụng trong nghiên cứu nông nghiệp như các thí nghiệm 1 nhân tố, nhiều nhân tố theo các kiểu thiết kế khác nhau, thí nghiệm làm nhiều năm, thí nghiệm làm ở nhiều nơi, phân tích hồi qui đường thẳng 1 biến và nhiều biến. Sách này sẽ rất hữu ích cho sinh viên và các nhà nghiên cứu trong lĩnh vực nông nghiệp. INTRODUCTIONS This is a practising book for Analysis experimental data by IRRISTAT 4.0 for Windows. It is very convinience and easy to users because it was written mainly by figures step by step. Expecially, those who do not know well about computer techniques and statistical knowledges can use. The book has two parts: 1. Some genaral introductions of the contents, funtions of IRRISTAT 4.0 for Windows. 2. Some sample models of analysing of variance and regression following different experimental designs that are often used in agricultural research such as: single-factor experiment; two factor experiment; three factor experiment; experiment by sites; experiment by years and regression analysis. This book will be very useful for students and researchers in agricultural fields.
  6. References. 1. Biometrics Unit, International Rice Research Institute. IRRISTAT 4.0 Window, Tutorial Manual. 2. KWANCHAI A. GOMEZ, ARTURO A. GOMEZ, 1984. Statistical Procedures for Agricultural Research. Copyright 1984 by John Wiley& Sons, Inc. 3. Choosak Jompuk. 1998. Computer Application in Agronomy Research. Agronomy Department, Faculty of Agriculture, Kasetsart University. 221 p. (in Thai). Phần I
  7. Giới thiệu IRRISTAT 4.0 IRRISTAT là một chương trình máy tính để quản lý số liệu và phân tích thống kê cơ bản các số liệu thí nghiệm. Nó có thể chạy trong bất kỳ hệ thống hoạt động nào của Window 32 bít. Để cài đặt chương trình vào máy tính, h•y chạy file SETUP. EXE. trên đĩa cài đặt. Khởi động chương trình, h•y chạy file IRRISTAT.EXE, hoặc nháy biểu tượng đ• được cài đặt. IRRISTAT được biên soạn chủ yếu để phân tích các số liệu thu được từ thí nghiệm đồng ruộng, nhưng có nhiều nội dung có thể sử dụng để phân tích các số liệu từ các nguồn nghiên cứu khác Các mô hình phân tích chính và các chức năng khác bao gồm: 1. Quản lý số liệu bằng spreadsheet 2. Trang ghi kết quả 3. Phân tích phương sai 4. Phân tích hồi qui 5. Phân tích ảnh hưởng của giống và môi trường 6. Phân tích di truyền số lượng 7. Phân tích riêng rẽ nơi nghiên cứu 8. Phân tích mô hình chia nhóm 9. Vẽ đồ thị 10. Ngẫu nhiên hoá sơ đồ thí nghiệm, phương sai của trung bình nhiều nhân tố, và đa thức trực giao. Môi trường làm việc của IRRISTAT Khi kết thúc chương trình, người học phải biết làm quen với các chức năng cơ bản của IRRISTAT như các cửa sổ Window, các danh mục nội dung, Các hợp phần chức năng đặc biệt và các thao tác file. I. Các cửa sổ Window Trong IRRISTAT có 4 cửa sổ chính của Window. A. Cửa sổ window chính (Main window)
  8. Cửa sổ chính window của IRRISTAT sẽ cung cấp cho người sử dụng các menu và các thanh công cụ như hình dưới đây; B. Cửa sổ quản lý số liệu (Data Editor) Data editor trình bày số liệu dưới dạng hàng và cột. Mỗi hàng là một trường hợp và mỗi cột là một biến. Bạn có thể ghi số liệu mới vào những chỗ trống trên hàng số liệu hoặc nhập số liệu từ file của trang văn bản hoặc file Excel và file dbase. Bạn có thể mở đồng thời một hoặc nhiều file số liệu. Số file được mở nhiều hay ít phụ thuộc khả năng nhớ của máy tính. Text Editor Trong Text Editor cũng có thể tạo file ASCII . File lệnh và các kết quả phân tích thống kê cũng được tóm tắt trong Text Editor.
  9. Graph Window Trong Graph Window cho phép vẽ các loại đồ thị II. Menus Mỗi cửa sổ Window trong IRRISTAT có các menu riêng của nó và có các lựa chọn thích hợp cho cửa sổ đó. A. Main Window Menus Sử dụng menu file để mở file, người ta sử dụng Data Editor hoặc Text Editor ( phụ thuộc vào kiểu file), cũng có thể save the log file, save-as the log file hoặc là in the log file từ đây. Sử dụng menu Edit để cut, copy, past hoặc xoá the Log window Sử dụng menu Analysis để chạy các phân tích thống kê, bao gồm các thống kê mô tả, phân tích phương sai phân
  10. tích hồi qui, phân tích GxE của thí nghiệm giống, phân tích quantitative trait loci, phân tích Single site, phân tích Pattern và vẽ scatter. Sử dụng menu Utilities để xây dựng thiết kế thí nghiệm, tạo các thí nghiệm tổng quát có trung bình bình phương và các hệ số tương phản đa thức trực giao. Sử dụng menu Window để thay đổi các cửa Window khác nhau trong IRRISTAT hoặc sắp xếp lại các trình bày của Window. Sử dụng menu Help để tìm hệ thống trợ giúp của IRRISTAT B. Data Editor Menus Sử dụng menu File để xây dựng, cất giữ, mở lại, và in file số liệu; để nhập số liệu từ Excel Workbook, từ Text file, và Dbase file; và đưa số liệu từ file có đuôi SYS sang Excel hoặc Text file. Sử dụng menu Edit để cut, copy, và dán các giá trị trong datasheet. Sử dụng Options để sửa chữa các đề mục, chuyển đổi số liệu, xếp hạng,
  11. tạo các mục, thêm, bớt, nhập số liệu, xoá biến và đặt độ chính xác riêng cho số liệu. Sử dụng Tools để sắp xếp trật tự số liệu, chuyển đổi d•y số liệu song song hoặc ngược lại. Sử dụng menu Window để sắp xếp lại một hoặc nhiều cửa Window khác. Sử dụng menu Help để tìm kiếm hệ thống trợ giúp của IRRISTAT. C. Text Editor Menus.
  12. Sử dụng menu File để tạo, mở, in và cất gĩư text file , để tóm tắt các kết quả thống kê và ra lệnh Sử dụng Edit để sửa chữa file văn bản Sử dụng menu Format để thay đổi đặc điểm font của file văn bản. Sử dụng menu Window để sắp xếp lạI cách trình bày của cửa Window.
  13. Sử dụng menu Help để tìm kiếm hệ thống trợ giúp của IRRISTAT. III. Job Specification Components Vi du về sử dụng các hợp phần khác trong IRRISTAT như sau: 1. Các nut điều khiển (Command Buttons). Command buttons là sự điều khiển bằng hình mà nó chỉ hành động. Người sử dụng có thể chọn nút bấm bằng cách kích chuột khi con trỏ ở trên nút. 2. Các hộp soạn thảo: Text (Edit) Boxes Text boxes được sử dụng để sửa chữa, tự vào thông tin. 3. Hộp danh sách (List Boxes). List Boxes được sử dụng để đưa ra lựa chọn cho người sử dụng.
  14. Trong IRRISTAT có 2 loạI là danh sách nguồn và danh sách mục tiêu. Danh sách mục tiêu chứa các mục cần cho phân tích. Danh sách mục tiêu được lấy ra từ danh sách nguồn Lựa chọn các biến từ danh sách nguồn cho các biến mục tiêu 1. Lựa chọn biến từ danh sách biến của file số liệu bằng cách kích chuột trên biến. 2. Kích nút Add ở phía dưới danh sách mục tiêu (analysis variate list) để nhận biến đ• được chọn 3. LoạI bỏ biến từ danh sách biến mục tiêu (trong trường hợp danh sách nhân tố) thì kích vào nút Remove. 4. Hộp kiểm soát (Check Boxes). Check Boxes điều khiển các lựa chọn riêng mà nó hoặc hiện, hoặc ẩn. Khi lựa chọn biến thì dấu check mark xuất hiện. Khi lựa chọn ẩn thì dấu check mark biến mất. Người sử dụng có thể thay đổi trạng thái của check boxes bằng cách kích chuột vào hộp hoặc ấn nút Select (Spacebar) khi dấu check boxe đ• được đặt vào. 5. Nút tuỳ chọn (Option Buttons). Một Option buttons thể hiện một lựa chọn đơn lẻ trong bộ các lựa chọn loại trừ có giới hạn. Khi sự lựa chọn của option button được lựa chọn, điểm vòng tròn được điền dấu chấm, khi không có lựa chọn thì trong vòng tròn trống. 6. Hộp tăng giảm (Spin Boxes). Spin boxes chỉ chấp nhận một bộ số có giới hạn các giá trị được đưa vào thứ tự. Người sử dụng có thể đánh một giá trị mới vào text box, kích chuột vào mũi tên lên để tăng giá trị, hoặc mũi tên xuống để giảm giá trị
  15. 7. Danh sách tuỳ chọn (Drop-down List). Một drop-down list là một danh sách có thể thay đổi trạng thái giữa đóng và mở. Một trong số lựa chọn của danh sách có thể được bôi đen và được chuyển vào text line bằng cách kích đúp chuột. IV. Ngẫu nhiên hoá và tạo sơ đồ thí nghiệm Sau khi học, người sử dụng cần biết cách ngẫu nhiên hoá và tạo một sơ đồ thí nghiệm theo một thiết kế nhất định. Ví dụ mẫu. Tạo một sơ đồ thí nghiệm theo thiết kế sau: Tên thí nghiệm: ảnh hưởng của tỷ lệ và nguồn đạm đến sản lượng lúa của 9 công thức bón phân và 3 lần nhắc lạI trong thiết kế khối hoàn toàn ngẫu nhiên (RCB). Phân chia các ô thí nghiệm như sau:
  16. 72 m chiều doc (A) Kích thước ô: 8 mx4m Ngẫu nhiên hoá và tạo sơ đồ thí nghiệm bằng IRRISTAT • Chọn Utilities Randomization and Layout từ cửa sổ chính Window • Khi Open a Randomization and Layout mở, có hộp thoại xuất hiện. Kích chuột vào hộp Look in và chọn ổ C. Sau đó kích đúp chuột vào IRRISTAT TUTORIAL từ danh sách bên dưới. Gõ ISDESIGN vào hộp File name và kích Open. • Kích vào yes ở trong hộp để khẳng định tạo file lệnh mới có tên ISDESIGN.RND. • Hộp thoại Randomization and Layout sẽ xuất hiện. Đánh dòng chữ : Effect of Nitrogen Rate and Source on Grain Yield of Rice vào hộp Design Title. • Kích chuột vào mũi tên trong hộp Design type và chọn Randomized Complete Block. • Kích chuột vào mũi tên trong Spinbox. Xong đặt số 3. • Để xác định một nhân tố, kích chuột vào hộp Factor name bên dưới Define factor group. Xong đánh chữ FERT trong hộp Factor name, có thể đánh tối đa đến 8 ký tự. Trong hộp Factor ID, đánh chữ F. Trong hộp của Number of levels đặt số 9. Kích chuột vào hai mũi tên kép >> trong Factor plot assignment. Nhắc lạI quá trình này cho đến khi vào đủ
  17. các nhân tố của công thức thí nghiệm. Trong ví dụ này chỉ cần vào 1 nhân tố, đó là fertilizer. • Chọn số 3 trong No. of plot along length of the field trong hộp Plot dimensions đế xác định số nhắc lại. Kích chuột vào OK để tạo thiết kế. Sản phẩm của ví dụ. Sản phẩm của thiết kế sẽ xuất hiện trong Text Editor. Nó được cất giữ như một file tạm thời với tên file: RNDLYT.OUT.Bạn có thể cất giữ vào một file khác để có file cố định bằng cách chọn FILE SAVE AS từ Text Editor. 1. Thiết kế và xác định nhân tố 2. Sơ đồ thí nghiệm (Experimental lay out). Ngẫu nhiên hoá và sơ đồ (RANDOMIZATION AND LAYOUT) ==================================================== ================== Experimental layout for file: "C:\PROGRAM FILES\IRRISTAT\TUTORIAL\ISDESIGN.RND" (RANDOMIZED COMPLETE BLOCK) The following field layout applies to all replications: (Note: layout is not drawn to scale) +-----+-----+-----+ | 1| 2| 3| +-----+-----+-----+ | 4| 5| 6| +-----+-----+-----+ | 7| 8| 9| +-----+-----+-----+ REPLICATION NO. 1 ------------------- PLOT NO. | TREATMENT ID 1 | F1 2 | F5
  18. 3 | F7 4 | F3 5 | F4 6 | F2 7 | F8 8 | F9 9 | F6 REPLICATION NO. 2 ------------------- PLOT NO. | TREATMENT ID 1 | F6 2 | F1 3 | F3 4 | F8 5 | F7 6 | F2 7 | F4 8 | F9 9 | F5 REPLICATION NO. 3 ------------------- PLOT NO. | TREATMENT ID 1 | F6 2 | F3 3 | F8 4 | F5 5 | F9 6 | F7 7 | F2 8 | F1 9 | F4 Phần II Quản lý FILE số liệu
  19. Cuối phần này người học phải biết cách: - Vào số liệu trực tiếp từ Data Editor - Nhập số liệu từ text file, print file, excel file, và dbase file. - Tạo biến mới bằng cách sử dụng các phép tính số học, các hàm số, các tính toán khác. - Tạo biến mới từ các biến đ• có hoặc các giá trị thiếu. - Đưa số liệu từ file có đuôI SYS sang excel hoặc text file. Bộ số liệu mẫu Một thí nghiệm phân bón được làm với 6 công thức sau: 1: Đối chứng 2: Low N-rate urea 3: Low N-rate SCU 4: Low N-rate USG 5: Low N-rate USG/urea 6: High N-rate Urea 7: High N-rate SCU 8: High N-rate USG 9: High N-rate USG/urea Số liệu đựơc thể hiện như sau: Tạo file số liệu Bước đầu tiên phân tích số liệu trong IRRISTAT là chuyển đổi số liệu vào file có đuôI SYS bằng Data Editor. Có thể lấy file số liệu từ file trong ASCII, excel, dbase hoặc vào số liệu trực tiếp cho Data Editor. Data Editor cũng giống như một workshet, trong đó các biến để ở cột và các số liệu quan sát để ở hàng. Để mở được Data Editor, từ cửa số chính window chọn Data Editor. Bắt đầu vào Data Editor, các menu có thể làm việc là File, Window, Help (biểu hiện đậm và rõ) trong khi các menu Edit, Options, Tools (biểu hiện mờ) chưa có khả năng làm việc nhưng chúng sẽ làm việc ngay sau khi mở file. Có thể lấy số liệu qua menu File bằng 4 cách khác nhau:
  20. A. New Vào số liệu trực tiếp bằng Data Editor B. Open Mở file có sẵn với đuôi SYS C.Reopen Mở những file vừa mới được làm gần nhất D.Import Nhập file từ excel, text hoặc dbase. New – Nhập số liệu qua Data Editor - Để mở New, h•y chọn File New từ cửa sổ Data Editor. - Trên màn hình thể hiện một ô đậm có nghĩa là một biến và một quan sát. Thêm hàng hoặc cột nữa bằng cách dịch chuyển mũi tên xuống hoặc sang ngang cho đến khi có đủ số hàng, cột như mong muốn. - Khi hàng và cột mới xuất hiện, IRRISTAT luôn thể hiện các ô bằng các dấu chấm. - IRRISTAT tạo ra các tên biến giả cho mỗi cột (ví dụ như VAR01, VAR02, VAR03,…). Có thể đổi tên biến bằng cách kích chuột tráI vào tên biến muốn đổi, một hộp nhỏ xuất hiện để vào tên biến. Có nghĩa là bạn có thể đặt tên và mô tả biến cho số liệu đưa vào.
Đồng bộ tài khoản