intTypePromotion=3

All In One Softs - Xây dựng và Sử dụng part 16

Chia sẻ: Dqwdqwdqwdqwd Dqwdqwdqwdw | Ngày: | Loại File: PDF | Số trang:6

0
46
lượt xem
3
download

All In One Softs - Xây dựng và Sử dụng part 16

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tham khảo tài liệu 'all in one softs - xây dựng và sử dụng part 16', công nghệ thông tin, kỹ thuật lập trình phục vụ nhu cầu học tập, nghiên cứu và làm việc hiệu quả

Chủ đề:
Lưu

Nội dung Text: All In One Softs - Xây dựng và Sử dụng part 16

  1. Kích vào phần nhập lệnh cho .Chọn trong muck lệnh về Page (Liên quan đến trang) chọn lệnh Page.Jump nhấn Next. Trong phần khai báo PageName chọn “About Cloud2342”.Nhấn OK. Lệnh Page.Jump là một lệnh dùng để nhảy từ trang làm việc này sang trang làm việc khác .Nhắc đến lệnh này thì bạn cần chú ý đến tham số PageName của đối tượng cần chuyển đến. Bạn chỉ việc nhập giá trị của của trang bạn cần chuyển đến trong phần PageName để đối tượng có thể dễ dàng chuyển đến đó.Chương trình còn hỗ trợ hiện các trang làm việc của bạn dưới dạng một danh sách thả xuống giúp cho bạn có thể lựa chọn dễ dàng.Trong trường hợp này thì bạn chỉ cần chọn “About Cloud2342” là đủ. Sau khi chọn xong giá trị “About Cloud2342” bạn nhấn Finish để có thể kết thúc tùy chọn của mình một cách nhanh chóng. Khi ban nhấn Finish xong chương trình sẽ tự động qua trở lại phần nhập mã để cho bạn có thể kiểm tra các thông số dưới dạng mã lệnh. Kéo biểu tượng của trang “Video” trong phần Project Explore thả vào đối tượng nút “Video Presentation”.Nếu chương trình có hỏi có muốn thêm một lệnh vào sự kiện On Click của đối tượng này không thì nhấn Yes. Chức năng kéo thả như bạn biết dùng để di chuyển các đối tượng trên trang làm việc . Nhưng ngoài những chức năng đó kéo thả đối tượng, nó còn gián tiếp tạo ra lệnh cho đối tượng làm việc của bạn. Trong trường hợp này khi bạn kéo thả biểu tượng trang vào trong đối tượng nút ,bạn đã đồng thời tác động để chương trình thêm và sự kiện On Click của đối tượng nút một lệnh nhảy trang.Khi đó chương trình sẽ hỏi bạn có thực sự muốn thêm lệnh vào trong đối tượng này không .Nếu đồng ý nhấn Yes Nhấn OK để có thể đóng phần nhập mã lại. Như vậy chúng ta đã bước đầu tạo các lệnh đơn giản để có thể liên kết các trang làm việc lại với nhau một các dễ dàng và rất thuận tiện cho việc sử dụng.Tiếp theo chúng ta sẽ học cách sao các đối tượng làm việc trong một trang.
  2. 9. Sao chép các đối tượng: Bạn rất muốn sử dụng các đối tượng quen thuộc trong cũ để dùng sang trang mới, nhưng vẫn giữ được các trạng thái cũng như các thuộc tính ý như đối tượng cũ.Khi đó để có thể sao chép các đối tượng trong trang cũ vào trang làm việc mới ,ta sao chép các đối tượng đó vào một Clipboard sau đó bạn có thể dễ dàng có thể chép chúng qua các trang mới. Chú ý: Bạn có thể sao chép các đối tượng bằng cách nhân đối chúng,sau đó di chuyển chúng đến nơi bạn muốn sao chép.Nhưng nếu bạn muốn giữ nguyên vị trí mặc định của đối tượng trên một trang chỉ có các copy và dáng chúng trên trang mới thôi. Bạn có thể di chuyển các đối tượng trong trang này sang trang khác bằng cách cắt dáng các đối tượng.Để cắt một đối tượng bạn nhấn Ctrl+X hoặc chọn Edit>Cut.Sau khi bạn cắt đối tượng ,việc còn lại của bạn là dáng chúng sang vị trí mới như bạn muốn. Bạn cần chắc rằng đối tượng nút “Video Presentation” được chọn,sau đó bạn nhấn Ctrl+C để copy chúng vào trong bản nhớ (Clipboard). Khi bạn nhấn Ctrl+C để sao chép đối tượng bạn đã copy đối tượng đó vào trong bảng nhớ (Bản nhớ là nơi mà bộ nhớ của máy tính làm việc dùng để lưu trữ các thông tin tạm thời của Windows dùng cho việc sao chép là chủ yếu).Bạn có thể thay cho việc nhấn Ctrl+C bằng việc chọn Edit>Copy. Chuyển đến trang “About Cloud2342”.Kích vào bề mặt trang sau đó nhấn Ctrl+V để có thể dán các đối tượng vào trang này. Bạn chuyển sang trang làm việc “About Cloud2342” bằng cách nhấn vào thẻ lệnh trang trên đầu mỗi trang làm việc. Khi bạn nhấn Ctrl+V thì đối tượng nút của bạn tự động chuyển sang trang làm việc mới này tại đúng vị trí như ở trang làm việc cũ của nó.Ngoài ra các thông số về đối tượng này vẫn giữ nguyên ,ngay cả tên của đối tượng (Button 3). Bạn cần nhớ rằng nếu trong trang mới đã có đối tượng giống tên với đối tượng bạn muốn chép sang .Thì khi bạn chép sang đối tượng gốc sẽ thay đổi tên để không
  3. trùng với đối tượng đã tồn tại trong trang làm việc mới của mình.Bạn có thể thay cho việc nhấn Ctrl+V bằng cách nhấn Edit>Paste. Kích đúp vào đối tượng nút “Video Presentation” để có thể vào phần hiệu chỉnh đối tượng nút của đối tượng này .Vào phần File chọn đường dẫn sau đó chỉ đến file nút lệnh mới có tên grey_bill.btn.Sau đó nhấn OK để có thể thay đổi cấu trúc của thư mục thành dạng khác. Có nhiều cách để có thể có thêm một nút lệnh trong trang làm việc mới của bạn .Bạn có thể sao chép từ các trang làm việc khác sau đó chỉnh sửa lại thông số cho phù hợp.Hay có thể tự tạo ra những nút lệnh mới để tiện hơn cho bạn khi muốn thiết lập lại từ đầu các thông số cho đối tượng nút đó. Đối tượng nút tạo ra từ file grey_pill.btn được dùng để thiết lập hình dạng cho nút lệnh “Video Presentation” như lại có những thông số về cấu trúc như chiều cao hay các thông số về vị trí của đối tượng cũ không thay đổi. Dùng các công cụ canh chỉnh để có thể điều chỉnh vị trí của đối tượng so với trang làm việc. Nếu bạn muốn đối tượng của bạn được canh giữa trang làm việc.Trước tiên kích vào phần chọn Align to Page để có thể chuyển sang chế độ canh chỉnh so với trang làm việc. Sau đó kích chuột phải vào đối tượng và chọn Align>Center Vertical. Bạn có thể thay đổi các thông số cho đối tượng để chuyển lệnh Page.Jump để thay cho việc nhảy đến trang “Video” ta có thể nhảy trở lại trang Page 1. Trước tiên bạn cần thiết lập lệnh Page.Jump trong sự kiện On Click .Nhưng trong sự kiện On Click của đối tượng này đã có sẵn lệnh này.Ngoài ra lệnh này còn nhảy đến trang Video.Nhưng bạn muốn thay đổi để đối tượng có lệnh quay trở lại trang làm việc Page 1 thì các bạn phải làm như sau. Vào trong phần chỉnh mã của sự kiện On Click.Khi mở phần nhập mã bạn sẽ thấy một lệnh được thiết lập sẵn . Bạn có hai cách,một là xóa các lệnh trong phần này để làm lại .Như thao tác tôi đã chỉ các bạn ở trên để thiết lập các liên kết đến trang làm việc mới cho đối tượng của bạn.Hai là các bạn có thể chỉnh các lệnh này để thay những thông số cũ bằng những thông số mới mà bạn muốn thêm vào. Cách thứ nhất tôi đã từ giới thiệu cho bạn rồi.Bây giờ tôi làm cách thứ hai,bạn kích đúp vào dòng lệnh chứa các câu lệnh trên .Chương trình sẽ chuyển đến phần hiệu chỉnh dàng riêng cho lệnh này.Bạn sẽ thấy một bản sổ xuống tại đây bạn có thể chọn các gía trị khác thay cho giá trị “Video”(tất nhiên là giá trị Page 1 rồi)
  4. Chú ý:Từ bây giờ bạn đã biết mỗi dòng lệnh của chương trình đểu có thể chuyển đến phần hiệu chỉnh riêng của chúng để có thể thay đổi các thông số cần thiêt cho đối tượng. Nhấn OK để có thể kết thúc phần nhập mã và quay trở lại với trang làm việc. Chú ý :Bạn có thể thiết lập một lệnh tương tự như lệnh trên bằng cách :Chọn lệnh Page.Navigate thiết lập trong phần JumpType giá trị JUMP_FIRST.Như vậy chương trình sẽ hiểu được,lệnh này thiết lập để có thể quay trở lại làm việc với trang làm việc trước đó (Bạn có thể thiết lập để tới trang kế tiếp hay trang chủ với lệnh này.Rất cần thiết đấy). Kích chuột phải vào đối tượng và nhấn Pin. Nhấn Pin để có thể chốt đối tượng lại để đối tượng không thể di chuyển hay thay đổi được .Lúc chốt đối tượng lại thì hộp hiệu chỉnh cũng tự động thay đổi từ màu xanh sang màu đỏ. Khi nào bạn muốn di chuyển vị trí của đối tượng này thì có thể nhấn như vậy chọn Unpin rồi trở lại di chuyển như bình thường.Bạn còn nhớ chứ phím tắc cho việc Pin hay Unpin là nhấn Ctrl+P. Sao chép đối tượng nút từ trang này sang trang Video. Để sao chép đối tượng,ta chọn vào đối tượng nhấn Ctrl+C và sau đó chuyển sang trang bạn muốn chép nhấn Ctrl+V. Một bảng sao như đúng kích thước vị trí,và các thông số như đúng như nút tại trang chủ sẽ được chương trình giũ nguyên .Ngay cả những lệnh của đối tượng cũng được sao chép như cũ. Chú ý :Bạn có thể sao chép được đối tượng cho dù bạn đã Pin chúng rồi. Trong trường hợp này thì đối tương nút “Back” vẫn giữ nguyên được giá trị vì chúng ta có lệnh Page.Jump để quay trở lại trang Page 1.
  5. 10. Chạy thử chương trình: Chúng ta cũng đã làm việc lâu với đồ án rồi nhỉ.Nếu bạn tò mò muốn biết hình thù của đề án của mình như thế nào .Sao bạn không lưu nó lại và cùng khảo sát nào. Bạn cần lưu ý khi chay chương trình .Nếu chương trình có lỗi thì bạn không thể chạy được chương trình. Lưu đề án làm việc. Bạn có thể lưu lại đề án của mình một cách tự nhiên giống như những chương trình khác bằng cách chọn File>Save hoặc nhấn Ctrl+S hay bạn có thể nhấn vào nút Save ở trên thanh công cụ để có thể lưu lại đề án của mình. Bạn sẽ không khó sử dụng chức nằng vì chúng cáo đến 3 cách phải không.Bạn nên nhớ trong chương trình này thì phân lưu lai chương trình là quan trong nhất.Vì đồng thời bạn đã xác nhấn những gì mình làm qua ổ cứng mà còn cho bạn thêm một thói quen cẩn thận và bạn có thể dễ dàng lấy ra khi bạn cần thiết. Chọn Publish>Review để có thể chạy thử chương trình. Bây giờ thì bạn có thể chay thử được chương trình rồi. Chú ý:Nếu bạn thấy bất tiện vì dùng cách mở Publish>Review hơi bất tiện và nó quá chậm .Thì bạn có thể nhấn F5 trên bàn phím bạn sẽ thấy nó chạy Khi chương trình bắt đầu chạy bạn có thể nhấn vào các nút lệnh để có thể liên kết đến các trang làm việc. Khi bạn muốn kết thúc ứng dụng chạy chương trình thử bạn nhấn Ctrl+F4 để có thể thoát. 11. Dùng để gởi thư điện tử (E-mail): Trước khi chuyển sang học bài mới chúng ta lẽ làm quen với một lệnh khác là quan trọng đó là gởi đến người nhấn một đỉa chỉ mail để có người dùng biết mà liên lạc với chúng ta. Quay trở lại trang Page 1.Và nhấn đúp vào đối tượng nhãn Email Address .Nhấn vào phần Quick Action để có thể dễ dàng chèn lệnh gởi thư đến địa chỉ “tdangnhan@yahoo.com” Quick action dùng để thiết lập một đoạn mã ngầm vào trong sự kiện On Click của đối tượng.Để chèn lệnh này bạn có thể kích đúp vào đối tượng (Trong trường hợp
  6. này thì là đối tượng nhãn Email Address).Khi cửa sổ hiệu chỉnh xuất hiện ,vào trong

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản