Các bài thí nghiệm môn học Lý thuyết điều khiển tự động phần phi tuyến khối thiết bị điện; hệ thống điện

Chia sẻ: Nguyễn Thị Ngọc Lựu | Ngày: | Loại File: PDF | Số trang:16

0
93
lượt xem
24
download

Các bài thí nghiệm môn học Lý thuyết điều khiển tự động phần phi tuyến khối thiết bị điện; hệ thống điện

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Các bài thí nghiệm môn học Lý thuyết điều khiển tự động phần phi tuyến khối thiết bị điện; hệ thống điện trình bày các nội dung: các bài thí nghiệm lý thuyết điều khiển tự động phần hệ xung số và phi tuyến, khảo sát đặc tính động học và tính ổn định của hệ xung số, khảo sát các đặc tính phi tuyến và các phương pháp mặt phẳng pha,... Đây là tài liệu tham khảo dành cho sinh viên ngành Tự động hóa.

Chủ đề:
Lưu

Nội dung Text: Các bài thí nghiệm môn học Lý thuyết điều khiển tự động phần phi tuyến khối thiết bị điện; hệ thống điện

  1. TRƯỜNG ĐẠI HỌC BÁCH KHOA HÀ NỘI KHOA ĐIỆN BỘ MÔN ĐIỀU KHIỂN TỰ ĐỘNG CÁC BÀI THÍ NGHIỆM MÔN HỌC LÝ THUYẾT ĐIỀU KHIỂN TỰ ĐỘNG PHẦN PHI TUYẾN KHỐI THIẾT BỊ ĐIỆN; HỆ THỐNG ĐIỆN ( 3 bài) HÀ NỘI 8/2008 1
  2. CÁC BÀI THÍ NGHIỆM LÝ THUYẾT ĐIỀU KHIỂN TỰ ĐỘNG PHẦN HỆ XUNG SỐ VÀ PHI TUYẾN I. MỤC ĐÍCH : SIMULINK là một công cụ rất mạnh của Matlab để xây dựng các mô hình một cách trực quan và dễ hiểu. Để mô tả hay xây dựng hệ thống ta chỉ cần liên kết các khối có sẵn trong thư viện của SIMULINK lại với nhau. Sau đó, tiến hành mô phỏng hệ thống để xem xét ảnh hưởng của bộ điều khiển đến đáp ứng quá độ của hệ thống và đánh giá chất lượng hệ thống. II. CHUẨN BỊ : Để thực hiện các yêu cầu trong bài thí nghiệm này, sinh viên cần phải chuẩn bị kỹ và hiểu rõ các khối cơ bản cần thiết trong thư viện của SIMULINK. Sau khi khởi động Matlab 6.5, ta gõ lệnh simulink hoặc nhấn vào nút simulink trên thanh công cụ thì cửa sổ SIMULINK hiện ra: 2 thư viện chính áp dụng trong bài thí nghiệm này Các thư viện con trong Chú ý: o Sinh viên phải đọc kỹ và chuẩn bị các bài thí nghiệm (Bao gồm giải đáp các vấn đề được gạch chân nêu trong bài). o Trước khi vào phòng thí nghiệm, cán bộ hướng dẫn thí nghiệm sẽ kiểm tra bài chuẩn bị của tất cả các bài thí nghiệm sẽ tiến hành trong buổi. Sinh viên không có bài chuẩn bị sẽ không được tiến hành thí nghiệm. o Phải nộp báo cáo thí nghiệm sau khi thí nghiệm tối đa 1 tuần. o Cán bộ hướng dẫn thí nghiệm: ThS. Nguyễn Việt Dũng, liên hệ: 04 38692985 KS. Đoàn Thị Thu Hà, liên hệ: 04 38692985 2
  3. II.1. Các khối được sử dụng trong bài thí nghiệm: a. Các khối nguồn – tín hiệu vào (source): Khối Step (ở thư viện Simulink \ Sources) có chức năng xuất ra tín hiệu hàm bậc thang. Double click vào khối này để cài đặt các thông số: • Step time : khoảng thời gian đầu ra chuyển sang mức Final value kể từ lúc bắt đầu mô phỏng. Cài đặt giá trị này bằng 0. • Initial value : Giá trị ban đầu. Cài đặt bằng 0. • Final value : Giá trị lúc sau. Cài đặt theo giá trị ta muốn tác động tới hệ thống. Nếu là hàm bậc thang đơn vị thì giá trị này bằng 1. • Sample time : thời gian lấy mẫu. Cài đặt bằng 0. Khối Signal Generator (ở thư viện Simulink \ Sources) là bộ phát tín hiệu xuất ra các tín hiệu sóng sin, sóng vuông, sóng răng cưa và ngẫu nhiên (cài đặt các dạng sóng này trong mục Wave form). b. Các khối tải – thiết bị khảo sát ngõ ra (sink): Khối Mux (ở thư viện Simulink \ Signals Routing) là bộ ghép kênh nhiều ngõ vào 1 ngõ ra, từ ngõ ra này ta đưa vào Scope để xem nhiều tín hiệu trên cùng một cửa sổ. Double click vào khối này để thay đổi số kênh đầu vào (trong mục Number of inputs) Khối Scope (ở thư viện Simulink \ Sinks) là cửa sổ xem các tín hiệu theo thời gian, tỉ lệ xích của các trục được điều chỉnh tự động để quan sát tín hiệu một cách đầy đủ. Khối XY Graph dùng để xem tương quan 2 tín hiệu trong hệ thống (quan sát mặt phẳng pha). c.Các khối xử lý – khối động học : Khối Sum (ở thư viện Simulink \ Math Operations) là bộ tổng (cộng hay trừ) các tín hiệu, thường dùng để lấy hiệu số của tín hiệu đặt với tín hiệu phản hồi. Double click để thay đổi dấu của bộ tổng. Khối Gain (ở thư viện Simulink \ Math Operations) là bộ tỉ lệ. Tín hiệu sau khi qua khối này sẽ được nhân với giá trị Gain. Double click để thay đổi giá trị độ lợi Gain. Khối Transfer Fcn (ở thư viện Simulink \ Continuous) là hàm truyền của hệ tuyến tính. Double click để thay đổi bậc và các hệ số của hàm truyền. Cài đặt các thông số: _ Numerator : các hệ số của đa thức tử số _ Denominator : các hệ số của đa thức mẫu soá Khối Relay (ở thư viện Simulink \ Discontinuities) là bộ điều khiển rơle 2 vị trí có trễ (còn gọi là bộ điều khiển ON-OFF). Các thông số : _ Switch on point : nếu tín hiệu đầu vào lớn hơn giá trị này thì ngõ ra của khối Relay lên mức ‘on’ _ Switch off point : nếu tín hiệu đầu vào nhỏ hơn giá trị này thì ngõ ra của khối Relay xuống mức ‘off’ _ Output when on : giá trị của ngõ ra khi ở mức ‘on’ _ Output when off : giá trị của ngõ ra khi ở mức ‘off’ Nếu tín hiệu đầu vào nằm trong khoảng (Switch on point, Switch off point) thì giá trị ngõ ra giữ nguyên không đổi. 3
  4. Khối Saturation (ở thư viện Simulink \ Discontinuities) là một khâu bão hòa. Các thông số cài đặt: _ Upper limit : giới hạn trên. Nếu giá trị đầu vào lớn hơn Upper limit thì ngõ ra luôn bằng giá trị Upper limit _ Lower limit : giới hạn dưới. Nếu giá trị đầu vào nhỏ hơn Lower limit thì ngõ ra luôn bằng giá trị Lower limit Khâu bão hoà dùng để thể hiện giới hạn biên độ của các tín hiệu trong thực tế như : áp ra cực đại của bộ điều khiển đặt vào đối tượng, áp nguồn… Khối PID controller (ở thư viện Simulink Extras \ Additional Linear) là bộ điều khiển PID với hàm truyền ( ) KP : hệ số tỉ lệ (proportional term) KI: hệ số tích phân (integral term) KD: hệ số vi phân (derivative term) II.2. Các bước tiến hành để xây dựng một ứng dụng mới trong SIMULINK: _ Sau khi khởi động Matlab, gõ lệnh simulink hoặc nhấn vào nút simulink trên thanh công cụ thì cửa sổ SIMULINK hiện ra (như ở hình vẽ Trang 1) _ Trong cửa sổ SIMULINK, vào menu File / New để mở cửa sổ cho một ứng dụng mới. Kích chuột vào các thư viện đã giới thiệu ở mục II.1 để chọn khối cần tìm. Kích chuột trái vào khối này, sau đó kéo và thả vào cửa sổ ứng dụng vừa mới tạo ra. Double click vào khối này để cài đặt và thay đổi các thông số. _ Có thể nhân số lượng các khối bằng cách dùng chức năng Copy và Paste. Kích chuột trái nối các ngõ vào / ra của các khối để hình thành sơ đồ hệ thống. _ Có thể dời một hoặc nhiều khối từ vị trí này đến vị trí khác bằng cách nhấp chuột để chọn các khối đó và kéo đến vị trí mới. Dùng phím Delete để xóa các phần không cần thiết hay bị sai khi chọn. _ Có thể viết chú thích trong cửa sổ ứng dụng bằng cách double click vào một vị trí trống và gõ câu chú thích vào. Vào menu Format / Font để thay đổi kiểu chữ. _ Như vậy, mô hình hệ thống đã xây dựng xong. Bây giờ tiến hành mô phỏng hệ thống bằng cách vào menu Simulation / Simulation Parameters để cài đặt các thông số mô phỏng. Cửa sổ Simulation Parameters hiện ra như sau: _ Start time : thời điểm bắt đầu mô phỏng. Mặc định chọn bằng 0. _ Stop time : thời điểm kết thúc mô phỏng. Giá trị này chọn theo đặc tính của hệ thống. Nếu hệ thống có thời hằng lớn thì giá trị Stop time cũng phải lớn để quan sát hết thời gian quá độ của hệ thống. _ Các thông số còn lại chọn mặc định như ở hình kế bên. _ Chạy mô phỏng bằng cách vào menu Simulation / Start. Khi thời gian mô phỏng bằng giá trị Stop time thì quá trình mô phỏng dừng lại. Trong quá trình mô phỏng, nếu ta muốn dừng nửa chừng thì vào menu Simulation / Stop. 4
  5. BÀI THÍ NGHIỆM 1 KHẢO SÁT ĐẶC TÍNH ĐỘNG HỌC VÀ TÍNH ỔN ĐỊNH CỦA HỆ XUNG SỐ 1. Khảo sát đặc tính động học của hệ xung số a. Mục đích: - Xác định hàm truyền của hệ thống điều khiển xung số - Khảo sát đặc tính động học của hệ thống điều khiển xung số b. Nội dung - Cho một hệ thống điều khiển số zoh Đối tượng X 1 − e − sT 1 Y s s ( s + 1) T=1 Thời gian lấy mẫu T=1s Phương pháp giữ mẫu bậc 0 : 'ZOH' ZERO ORDER HOLD - Xác định hàm truyền của hệ thống xung hở zoh Đối tượng X 1− e − sT 1 Y s s ( s + 1) T=1 X(z) Y(z) G1(z) - Xác định hàm truyền của hệ thống xung kín X(z) Y(z) G1(z) - Xác định hàm quá độ và hàm trọng lượng của hệ thống xung kín c. Chương trình >>G=tf(1,[1 1 0]) >>G1=c2d(G,1,'zoh') >>Gk=feedback(G1,1) >>step(Gk) >>impulse(Gk) 5
  6. 2. Khảo sát tính ổn định của hệ thống xung số a. Nội dung - Cho một hệ thống điều khiển số như sau zoh Đối tượng T=0.1 X 1 − e − sT 1 Y D(z) s s ( s + 1) Thời gian lấy mẫu T=0.1s Phương pháp giữ mẫu bậc 0 : 'zoh' ZERO ORDER HOLD Hàm truyền D(z)=K Hàm truyền 1 G(s) = s(s + 1) - Xác định hàm truyền của hệ thống xung hở H(z)=D(z)*G1(z) - Vẽ quĩ đạo nghiệm số và xác định trị số giới hạn K theo tiêu chuẩn ổn định của hệ xung số - Thay trị số Kgh vào hệ thống và kiểm tra quá trình quá độ trong hệ thống kín - Chỉnh định K để hệ thống ổn định và có quá trình quá độ đạt các chỉ tiêu chất lượng b. Chương trình >>G=tf(1,[1 1 0]) >>G1=c2d(G,0.1,'zoh') >>rlocus(G1); hold on >>x=[-1 :0.01:1]; y=sqrt(1-x.^2); >>plot(x,y,x,-y) >>[K,p]=rlocfind(G1) >>Gk=feedback(K*G1,1) >>hold off >>step(Gk,10) YÊU CẦU VIẾT BÁO CÁO - Vẽ sơ đồ của hệ thống điêu khiển số, sơ đồ của hệ thống xung hở và hệ thống xung kín - Xác định hàm truyền của hệ thống xung hở và hệ thống xung kín - Vẽ quỹ đạo nghiệm và xác định Kgh - Vẽ hàm quá độ của hệ thống kín khi K=Kgh - Chỉnh định K và vẽ hàm quá độ của hệ thống xung kín, xác định các chỉ tiêu chất lượng 6
  7. BÀI THÍ NGHIỆM SỐ 2 KHẢO SÁT CÁC ĐẶC TÍNH PHI TUYẾN VÀ PHƯƠNG PHÁP MẶT PHẲNG PHA I.KHẢO SÁT CÁC ĐẶC TÍNH PHI TUYẾN 1.Mục đích Khảo sát đặc tính của các khâu phi tuyến tính cơ bản y=F(x) ( Số liệu làm theo nhóm) a. Khâu bão hoà b.Khâu có khe hở y y a x x -b b -a c. Khâu rơle 2 vị trí lý tưởng d. Khâu rơle 2 vị trí có trễ y y a a x x -b b -a -a e.Khâu rơle 3 vị trí lý tưởng Khâu rơle 3 vị trí có trễ y y a a -b b -c -b x x b c -a -a Số liệu theo nhóm Khâu Khâu Khâu Khâu rơ le Khâu rơ le 2 Khâu rơ le Khâu rơ le 3 phi bão hoà khe hở 2 vị trí lý vị trí có trễ 3 vị trí lý vị trí có trễ tuyến tưởng tưởng a b a a b a b a b c Nhóm 1 1 0.5 1.5 1.5 0.5 1.5 0.5 1.5 0.5 1 Nhóm 2 2 1 2.5 2.5 1 2.5 1 2.5 1 2 Nhóm 3 1.5 1.5 1 1 1.5 1 1.5 1 1.5 3 Nhóm 4 2.5 2 2 2 1 2 1 2 1 2 Nhóm 5 0.5 2.5 0.5 1.5 0.5 1 1.5 1 1.5 2.5 2.Nội dung a. Thành lập mô hình của các khâu phi tuyến cơ bản b. Khảo sát quan hệ vào ra của các khâu phi tuyến và ghi lại các đặc tính phi tuyến điển hình ( có tín hiệu vào là hình sin hoặc răng cưa) 3.Báo cáo thí nghiệm - Vẽ sơ đồ khối của các khâu phi tuyến tính cơ bản - Vẽ đặc tính của các khâu phi tuyến tính cơ bản 7
  8. II. PHƯƠNG PHÁP MẶT PHẲNG PHA 1.Mục đích Áp dụng phương pháp mặt phẳng pha để phân tích các hệ thóng tuyến tính và phi tuyến. 2.Nội dung a. Khảo sát quĩ đạo pha của một hệ thống tuyến tính bậc 2 có sơ đồ như sau: Sơ kiện: x1(0)=10; x2(0)=0; Thời gian mô phỏng: 100s - Quan sát quĩ đạo pha của hệ thống tuyến tính bậc 2 có dao động - Quan sát quĩ đạo pha của hệ thống tuyến tính bậc 2 không ổn định 1 ( thay đổi hàm truyền của khâu quán tính thành khâu không ổn định: ) 10 s − 1 - Quan sát quĩ đạo pha của hệ thống tuyến tính bậc 2 ở biên giới ổn định ( thay đổi hàm 1 truyền của khâu quán tính thành khâu tích phân: ) 10s b.Khảo sát quĩ đạo pha của một hệ thống tuyến tính bậc 2 có sơ đồ như sau: Cho điều kiện ban đầu: x1(0)=2; x2(0)=0,8; Khâu phi tuyến F(x) được chọn theo các trường hợp sau: c. F(x) là khâu rơ le hai vị trí d. F(x) là khâu rơ le hai vị trí có trễ e. F(x) là khâu rơ le ba vị trí f. F(x) là khâu rơ le ba vị trí có trễ 3.Báo cáo thí nghiệm a. Vẽ sơ đồ khối và vẽ quĩ đạo pha của hệ thống tuyến tính trong các trường hợp : - Hệ thống ổn định, ở biên giới ổn định và không ổn định - Nhận xét kết quả b. Vẽ sơ đồ khối và quĩ đạo pha của hệ thống phi tuyến tính trong các trường hợp : g. F(x) là khâu rơ le hai vị trí h. F(x) là khâu rơ le hai vị trí có trễ i. F(x) là khâu rơ le ba vị trí j. F(x) là khâu rơ le ba vị trí có trễ k. Nhận xét kết quả 8
  9. BÀI THÍ NGHIỆM SỐ 3. ĐIỀU KHIỂN MỜ A. Mục đích thí nghiệm Giúp cho sinh viên hiểu và có khả năng vận dụng lý thuyết vào giải quyết một bài toán tổng hợp hệ thống thông qua ví dụ về thiết kế bộ điều khiển mờ tĩnh cho một đối tượng bậc 4 sử dụng công cụ tính toán và mô phỏng Matlab. B. Yêu cầu Sinh viên cần phải nắm vững các khái niệm về ổn định, các tiêu chuẩn xét tính ổn định của hệ thống (bao gồm các tiêu chuẩn xét tính ổn dịnh của hệ tuyến tính, hệ phi tuyến, và đặc biệt là tiêu chuẩn xét tính ổn định tuyệt đối Popov). Trước khi tiến hành thí nghiệm, sinh viên cần phải đọc tài liệu hướng dẫn thí nghiệm để nắm được các bước thao tác cơ bản với “Fuzzy logic Toolbox”. C. Bài thí nghiệm 1. Yêu cầu thí nghiệm Cho đối tượng điều khiển có hàm truyền đạt dạng 1 G (s) = s + a3 s + a2 s 2 + a1s + a0 4 3 hãy thiết kế và mô phỏng một bộ điều khiển mờ tĩnh (làm ổn định hệ kín) sử dụng công cụ tính toán – mô phỏng Matlab – Simulink (Mỗi sinh viên sử dụng bộ số liệu của mình có trong bảng kèm theo). 2. Gợi ý các bước thực hiện 2.1. Bước 1: Sử dụng tiêu chuẩn ổn định Popov để xác định góc giới hạn (sector) của đặc tính phi tuyến của bộ điều khiển. Để có thể áp dụng được tiêu chuẩn Popov, đối tượng điều khiển phải thỏa mãn một số điều kiện nhất định. Kiểm tra đối tượng đã cho có thỏa mãn các điều kiện trên hay không. Có thể kiểm tra (bằng tay) sử dụng các tiêu chuẩn xét tính ổn định của hàm truyền (VD: Routh, Hurwitz…)… hoặc sử dụng công cụ Matlab >> Gh=tf(1,[1.0000 4.2219 5.7877 2.8520 0.4424]) % Tạo hàm truyền hệ hở Transfer function: 1 ---------------------------------------------- s^4 + 4.222 s^3 + 5.788 s^2 + 2.852 s + 0.4424 >> pole(Gh) % Tính giá trị các điểm cực của hệ Gh ans = % Từ đó rút ra kết luận về tính ổn định của hệ kín -1.9098 -1.5006 -0.5069 Nếu đối tượng đã cho không thỏa mãn các điều kiện trên, có thể giải quyết bài toán bằng cách nào? Áp dụng tiêu chuẩn Popov để xác định góc giới hạn của đặc tính phi tuyến. Có thể vẽ đặc tính tần số Popov của đối tượng đã cho bằng tay, hoặc sử dụng Matlab để vẽ. Hàm Matlab thực hiện việc vẽ đặc tính tần số Popov như sau 9
  10. function [] = popovplot(sys) % PopovPlot try to draw the Popov plot % How to use: tạo một m_file mới, nhập toàn bộ các lệnh(các dòng không có ký tự % ở đầu) % sau đó save với tên popovplot.m % gọi bằng cách gõ popovplot(Gh) tại dấu nhắc của matlab. % Author: Nguyen Tien Hieu, E-mail: hieunt-ac@mail.hut.edu.vn % Update: 06-April-2006 12:11 PM % $Revision: 1.1 modified for student's experiment. [re,im,w]=nyquist(sys); re=re(:); im=im(:).*w; plot(re,im); Đặc tính tần số Popov sẽ được vẽ trong 1 cửa sổ figure. Vẽ đường thằng Popov bằng cách chọn Insert->Line, rồi kéo đường thẳng đó đến vị trí mong muốn. Từ đó xác định 1 điểm − là giao của đường thẳng Popov với trục thực của đặc tính tần số Popov. Đặc tính kmax f (e) phi tuyến cần tìm sẽ phải thỏa mãn 0 < < k với e ≠ 0 và f ( e ) = 0 khi e = 0 . e Hình 1: Đặc tính tần số Popov và đường thẳng Popov 2.2. Bước 2: Tồng hợp bộ điều khiển và mô phỏng. Trong góc giới hạn tìm được ở bước 1, tìm một đặc tính phi tuyến điều khiển gãy khúc (từng đoạn là các đoạn thằng) với tối thiểu là 3 đoạn. Sử dụng “Fuzzy logic Toolbox” để xây dựng đặc tính đó. Sau đó mô phỏng toàn hệ kín bằng Simulink. Thử với một số đặc tính phi tuyến khác nhau để tìm ra một đặc tính tốt nhất có thể. Chú ý: Trước tiên, vẽ ra giấy đặc tính phi tuyến cần tổng hợp, có thể chuẩn hóa tín hiệu vào và ra trong dải ⎡-1,1⎤ (hình 2) . Sau đó sử dụng Fuzzy logic Toolbox để tổng hợp đặc tính đó, ⎣ ⎦ sử dụng cửa sổ “Surface Viewer” để kiểm tra đặc tính phi tuyến tổng hợp được (hình 3). Sau đó, Export hệ mờ tổng hợp được ra Workspace. Tạo một mô hình Simulink mới, xây dựng mô hình hệ kín tương tự như mô hình trong hình 4. trong đó khâu “Saturation” là khâu khuyếch đại bão hòa, có nhiệm đảm bảo tín hiệu vào bộ điều khiển mờ không vượt ra khỏi dải cho phép ⎡-1,1⎤ . ⎣ ⎦ Cuối cùng, cài đặt các tham số của Simulink (thời gian mô phỏng…). Chạy mô phỏng, đánh giá chất lượng của hệ kín và điều chỉnh lại đặc tính của khâu phi tuyến cho đến khi đạt yêu cầu về chất lượng (do cán bộ hướng dẫn đánh giá). 10
  11. Hình 2: Các hàm liên thuộc vào và ra Hình 3: Đặc tính điều khiển phi tuyến do bộ điều khiển mờ tạo ra Hình 4: Mô hình mô phỏng sử dụng Simulink Bảng số liệu thí nghiệm phần điều khiển mờ STT a3 a2 a1 a0 STT a3 a2 a1 a0 1 9.2 10.4 19.9 24.5 41 8.8 4.2 9.2 5.8 2 8.7 4.2 10.9 18.7 42 1.8 11 3 3.9 3 7.6 6.8 8.7 0.5 43 2 10.7 19.1 21 4 4.8 7.7 9.8 18.6 44 3.1 10.4 0.6 2.7 5 2.4 5 13.5 20.4 45 5.3 4.9 13.8 1.2 6 2.2 3.5 2.4 6.7 46 9.5 8.2 6.6 5.8 7 1 7.3 16.7 11.4 47 4.5 12.4 12 21.6 8 7.6 1.6 19.4 2.8 48 0.1 14.9 9.4 18.8 9 6.5 2.4 13.8 2.8 49 1.8 5 0.1 3 10 7.3 6.4 13.4 13.9 50 8.6 14.9 17.7 6.6 11 6.4 11.1 10.2 0.4 51 0.1 11.1 15 3.9 12 4.4 3.9 2.1 9.1 52 0.3 10.6 13.6 13 11
  12. 13 8 10.7 19.8 13.5 53 6 1.9 11.8 23.4 14 2.6 10.1 13.9 22.2 54 2.3 3 4.1 13 15 9.6 3 18.2 21.7 55 0.7 2.7 0.3 28.3 16 6.3 10.5 6.8 19.4 56 9.1 9.5 6.8 29 17 10 8.9 12.7 23.1 57 4.9 11.6 9.5 16.8 18 1.9 6.6 14.9 22.7 58 1 2.4 14.3 28.4 19 2.5 11.8 0.9 28.3 59 3.2 0.7 18.4 21.8 20 4.4 6.2 18.8 26.4 60 4.3 9.9 2.3 6.7 21 5.2 8.4 8.8 11.1 61 1.5 11.7 2.5 1.8 22 3.8 1.9 10.7 22.5 62 7.3 12.7 14.8 28.7 23 2.3 10.7 1.2 1.9 63 8.2 10.6 13.3 13.1 24 3.9 14.3 19.5 3.7 64 7.5 11.7 13.1 20.9 25 7.9 0.7 10.8 21.8 65 5.2 3.3 19.2 13.7 26 0.8 11.2 1.4 23.7 66 4.4 2.2 7.7 0.2 27 4.9 11.7 9.9 15.2 67 9.8 2.5 4.9 18.7 28 6 10.7 9.2 29.2 68 4.3 12.7 8.5 28.8 29 0 11.5 2.3 0.4 69 0.5 14.7 6.5 29.6 30 5.2 1 2.6 11.7 70 2.5 9.6 0.2 22.9 31 3.4 0.2 8.2 1.7 71 7.1 4.1 7.8 14.3 32 2.7 3.1 8.5 26.5 72 0.4 2.5 7.4 22.6 33 4.4 11.4 16.4 2.2 73 8.9 8.2 16.4 11.3 34 1.4 3.2 9.8 6.7 74 2.5 6.2 13.5 19.7 35 6.7 6.9 9.6 24.6 75 2.4 9.3 2.4 27.7 36 4 11.1 19.6 9.3 76 3 9.7 5.3 2.8 37 1.7 3.1 5 24.4 77 0.5 9.1 11.9 18 38 3.8 14.9 14.2 4.9 78 7 4.7 1.5 20.9 39 5.8 3.1 12.2 19.4 79 3 3 9.2 18.7 40 5.3 5.7 3.5 26.6 80 8 8.7 15.8 27.8 Chú ý: Số liệu cho các hệ số của đa thức đặc tính của hàm truyền đạt đối tượng. Hàm truyền của đối tượng có dạng 1 G (s) = s + a3 s + a2 s 2 + a1s + a0 4 3 - Mỗi sinh viên sử dụng bộ số liệu tương ứng với số thứ tự của mình trong danh sách lớp. Sinh viên nào sử dụng không đúng bộ số liệu của mình sẽ không đủ điều kiện để hoàn thành thí nghiệm môn học 12
  13. H−íng dÉn sö dông c¸c bµi thÝ nghiÖm dïng simulink Bµi 1. C¸ch lËp s¬ ®å trong simulink ®Ó kh¶o s¸t c¸c ®Æc tÝnh cña c¸c kh©u phi tuyÕn ®iÓn h×nh 1.Khâu bão hoà 2. Khâu có khe hở 3. Khâu rơle 2 vị trí lý tưởng 4. Khâu rơle 2 vị trí có trễ 5. Khâu rơle 3 vị trí lý tưởng 6. Khâu rơle 3 vị trí có trễ 13
  14. Bµi 2b. Cách thành lập trong simulink để vẽ quĩ đạo pha của hệ thống phi tuyến tính trong trường hợp Trong đó khối F(x) ta lần lượt thay là các khâu rơ le 2 vị trí, rơ le 2 vị trí có trễ, rơ le 3 vị trí, rơ le 3 vị trí có trễ GIỚI THIỆU SƠ LƯỢC VỀ FUZZY LOGIC TOOLBOX TRONG MATLAB 1. Fuzzy Logic Toolbox là gì? “Fuzzy Logic Toolbox” là một tập các hàm được xây dựng trong môi trường Matlab. Nó cung cấp các công cụ để tạo và soạn thảo các hệ thống suy luận mờ trong Matlab, hoặc tích hợp vào mô phỏng với Simulink. Ngoài ra, có thể xây dựng các chương trình C độc lập để gọi hệ mờ xây dựng trong Matlab. Toolbox này chủ yếu sử dụng các công cụ với giao diện đồ họa (Graphical User Interface – GUI), hoặc cũng có thể được sử dụng từ “command line” (dòng lệnh). Hình 5: Fuzzy Logic Toolbox 14
  15. 2. Xây dựng các hệ thống mờ với Fuzzy Logic Toolbox (FLT) Phần này giới thiệu các bước cơ bản để xây dựng một hệ thống mờ sử dụng giao diện đồ họa (GUI) của FLT. Các thành phần chính của GUI được biểu diễn trong hình 2. Hình 6: Các thành phần chính của giao diện đồ họa của Fuzzy Logic Toolbox Các bước khai báo cấu hình hệ thống suy luận mờ sử dụng GUI • Mở giao diện đồ họa bằng cách gõ lệnh “fuzzy” trong “Command Window”. Mặc định, Matlab sẽ mở giao diện thiết kế hệ mờ Mamdani. Để xây dựng hệ mờ Sugeno, chọn File->New FIS->Sugeno. Cửa sổ chính (FIS Editor) có dạng như trong hình 3. • Khai báo số biến vào/ra của hệ mờ sử dụng các lệnh trong menu “Edit” Edit->Add Variable…->Input: Để thêm 1 biến đầu vào Edit->Add Variable…->Output: Để thêm 1 biến đầu ra Edit->Remove Selected Variable: Để xóa biến đang chọn • Lần lượt khai báo các hàm liên thuộc biến đầu vào và biến đầu ra sử dụng cửa sổ “Membership Function Editor” (kích hoạt bằng cách nhấn đúp vào biểu tượng vào/ra tương ứng trong cửa sổ thiết kế chính). Cách thêm bớt các hàm liên thuộc cũng sử dụng các lệnh trong menu Edit. • Khai báo các luật hợp thành sử dụng cửa sổ “Rule Editor” (Kích hoạt bằng cách nhấn đúp vào biểu tượng hệ mờ). 15
  16. • Có thể kiểm tra đặc tính vào ra của hệ mờ vừa xây dựng bằng cách sử dụng các cửa sổ View->Rules: Cửa sổ “Rule Viewer”. View->Surface: Cửa sổ “Surface Viewer”. • Nếu đặc tính vào ra của hệ mờ thỏa mãn yêu cầu thiết kế thì để có thể sử dụng trong mô phỏng, cần phải “lưu” cấu hình vừa khai báo. Có 2 cách để lưu cấu hình hệ mờ File->Export->To WorkSpace… Lưu cấu hình hệ mờ trong “không gian làm việc” của Matlab. Khi đó hệ mờ đã sẵn sàng để sử dụng trong mô phỏng (sử dụng Simulink). Tuy nhiên, cấu hình của hệ sẽ bị mất khi thoát khỏi môi trường Matlab. File->Export->To Disk… Cấu hình hệ mờ sẽ được cất trong đĩa cứng. Ấn đúp vào biểu tượng Ấn đúp để soạn luật Ấn đúp vào biểu tượng tín hiệu vào để khai báo tín hiệu ra để khai báo hàm liên thuộc vào hàm liên thuộc ra Tên của hệ mờ Có thể thay đổi bằng cách chọn Save as Lựa chọn các hàm sử dụng trong hệ, VD như phương pháp giải mờ Hình 7: Cửa sổ thiết kế chính “FIS Editor” 16

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản