Link xem tivi trực tuyến nhanh nhất xem tivi trực tuyến nhanh nhất xem phim mới 2023 hay nhất xem phim chiếu rạp mới nhất phim chiếu rạp mới xem phim chiếu rạp xem phim lẻ hay 2022, 2023 xem phim lẻ hay xem phim hay nhất trang xem phim hay xem phim hay nhất phim mới hay xem phim mới link phim mới

Link xem tivi trực tuyến nhanh nhất xem tivi trực tuyến nhanh nhất xem phim mới 2023 hay nhất xem phim chiếu rạp mới nhất phim chiếu rạp mới xem phim chiếu rạp xem phim lẻ hay 2022, 2023 xem phim lẻ hay xem phim hay nhất trang xem phim hay xem phim hay nhất phim mới hay xem phim mới link phim mới

intTypePromotion=1
ADSENSE

Giáo trình Thực tập mạch in - Trường CĐ Kinh tế - Kỹ thuật Vinatex TP. HCM

Chia sẻ: _ _ | Ngày: | Loại File: PDF | Số trang:112

7
lượt xem
3
download
 
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Giáo trình Thực tập mạch in được biên soạn cho sinh viên cao đẳng ngành Công nghệ Kỹ thuật Điện – Điện tử và ngành Công nghệ Kỹ thuật Cơ điện tử. Giáo trình trang bị các kiến thức lý thuyết, thực hành cơ bản để sinh viên nghiên cứu thiết kế, vẽ sơ đồ nguyên lý, mạch in và thi công bản mạch in hoàn chỉnh phục vụ nhu cầu học tập và sản xuất sản phẩm điện tử. Giáo trình gồm 3 chương, mời các bạn cùng tham khảo để biết thêm nội dung chi tiết.

Chủ đề:
Lưu

Nội dung Text: Giáo trình Thực tập mạch in - Trường CĐ Kinh tế - Kỹ thuật Vinatex TP. HCM

  1. BỘ CÔNG THƯƠNG TẬP ĐOÀN DỆT MAY VIỆT NAM TRƯỜNG CAO ĐẲNG KINH TẾ - KỸ THUẬT VINATEX TP. HCM Giáo trình THỰC TẬP MẠCH IN TP. HỒ CHÍ MINH, THÁNG 01 NĂM 2020
  2. BỘ CÔNG THƯƠNG TẬP ĐOÀN DỆT MAY VIỆT NAM TRƯỜNG CAO ĐẲNG KINH TẾ - KỸ THUẬT VINATEX TP. HCM KHOA CƠ ĐIỆN Giáo trình THỰC TẬP MẠCH IN TP. HỒ CHÍ MINH, THÁNG 01 NĂM 2020 LƯU HÀNH NỘI BỘ
  3. i MỤC LỤC Trang Mục lục i Lời nói đầu iii Chương 1. Phần mềm thiết kế mạch in I. Giới thiệu phần mềm vẽ mạch 1 II. Thiết kế mạch nguyên lý 1 1. Giao diện, thanh công cụ 1 2. Thư viện linh kiện 5 3. Thực hành vẽ mạch nguyên lý 17 4. Chạy mô phỏng 23 III. Thiết kế mạch in 32 1. Thanh công cụ 32 2. Thư viện linh kiện 37 3. Vẽ mạch in 46 Chương 2. Quy trình thi công mạch in I. Chuẩn bị nguyên phụ liệu 63 1. Chì hàn, kem chì và dung dịch hàn 63 2. Panh gắp, que hút và băng dính linh kiện 64 3. Tấm đồng bakelit 65 4. Một số nguyên phụ liệu khác 66 5. Linh kiện 66 II. In bản mạch 66 1. In sơ đồ mạch in 66 2. Chuẩn bị bản mạch đồng 67 3. Gia công sơ đồ mạch in lên tấm đồng bakelit 67 III. Gia công phay, rửa mạch 68 1. Rửa mạch 69 2. Phay mạch 69 3. Chiếu tia UV 70 IV. Khoan mạch, gắn và hàn linh kiện 70 1. Khoan mạch 70 2. Gắn linh kiện lên bo mạch 72 3. Hàn linh kiện 72 V. Kiểm tra và xử lý bề mặt mạch in 79 1. Kiểm tra bản mạch 79 2. Xử lý bề mặt mạch in 79
  4. ii 3. Cắt mạch 81 4. Vệ sinh và đóng gói sản phẩm 81 Chương 3. Thi công các mạch điện tử ứng dụng I. Thi công mạch nguồn 85 1. Mạch nguyên lý 86 2. Mạch in 87 3. Kiểm tra, hiệu chỉnh 88 II. Thi công mạch bảo vệ quá áp 88 1. Mạch nguyên lý 89 2. Mạch in 90 3. Kiểm tra, hiệu chỉnh 91 III. Thi công mạch sạc điện thoại 92 1. Mạch nguyên lý 96 2. Mạch in 98 3. Kiểm tra, hiệu chỉnh 99 IV. Thi công mạch micro không dây 100 1. Mạch nguyên lý 100 2. Mạch in 101 3. Kiểm tra, hiệu chỉnh 102 V. Thi công mạch báo trộm bằng hồng ngoại 103 1. Mạch nguyên lý 103 2. Mạch in 105 3. Kiểm tra, hiệu chỉnh 106 Phụ lục. Danh sách các hình 108 Tài liệu tham khảo 113
  5. iii LỜI NÓI ĐẦU Giáo trình Thực tập mạch in được biên soạn cho sinh viên cao đẳng ngành Công nghệ Kỹ thuật Điện – Điện tử và ngành Công nghệ Kỹ thuật Cơ điện tử. Giáo trình trang bị các kiến thức lý thuyết, thực hành cơ bản để sinh viên nghiên cứu thiết kế, vẽ sơ đồ nguyên lý, mạch in và thi công bản mạch in hoàn chỉnh phục vụ nhu cầu học tập và sản xuất sản phẩm điện tử. Giáo trình gồm 3 chương: Chương 1. Phần mềm thiết kế mạch in Chương 2. Quy trình thi công mạch in Chương 3. Thi công các mạch điện tử ứng dụng Rất mong được sự phản hồi quý báu từ bạn đọc để giáo trình ngày càng được hoàn thiện hơn.
  6. Chương 1.Phần mềm thiết kế mạch in 1 Chương I PHẦN MỀM THIẾT KẾ MẠCH IN Chương một giới thiệu khái quát về phần mềm thiết kế mạch in và trình bày về giao diện, các thanh công cụ, thư viện linh kiện và phương pháp thiết kế mạch nguyên lý, mạch in sử dụng phần mềm Orcad. Các nội dung chính được minh họa bằng những ví dụ với các bước hướng dẫn thao tác cụ thể. I. Giới thiệu phần mềm vẽ mạch Orcad là phần mềm vẽ thiết kế mạch điện tử của công ty Cadence. Orcad gồm ba phần mềm chính: Orcad Capture được dùng để vẽ sơ đồ mạch nguyên lý; Orcad Pspice được dùng để mô phỏng (giả lập) mạch nguyên lý đã vẽ; Orcad Layout được dùng để vẽ mạch in. So với các phần mềm khác thì Orcad được sử dụng phổ biến và chuyên giành cho công việc thiết kế mạch in. Phần mềm này được đánh giá là công cụ mạnh với khả năng thiết kế mạch in nhiều lớp, hỗ trợ bộ thư viện lớn (cho phép người dùng tạo thêm sơ đồ chân linh kiện) và nét vẽ đẹp. II. Thiết kế mạch nguyên lý Mục này sẽ giới thiệu phần mềm Orcad Capture, đây là bộ công cụ để vẽ sơ đồ mạch nguyên lý. 1. Giao diện, thanh công cụ 1.1. Cửa sổ Session Log Mở phần mềm Orcad Capture, xuất hiện giao diện Session Log ở hình 1.1. Lưu ý: Orcad Capture và Orcad Capture CIS là hai phần mềm tương đồng, Capture CIS có thêm cơ sở dữ liệu về một số linh kiện (phần tra cứu linh kiện). Hình 1.1. Giao diện Session Log của phần mềm Orcad Capture
  7. Chương 1.Phần mềm thiết kế mạch in 2 - Trên cùng là thanh menu chính: + Menu File chứa các công cụ quản lý dự án (Project), trang vẽ (page schematics), thư viện linh kiện và trang tài liệu liên quan (page documents): mở, lưu, in ấn, xuất tệp (export file) và chèn tệp (import file). + Menu View dùng chọn kiểu quan sát trang, hiển thị thanh công cụ. + Menu Edit chứa các công cụ xử lý trang tài liệu hiện hành (trang vẽ, trang thư viện): sao chép, dán, cắt, tìm kiếm, xóa trang hiển thị lỗi (clear session log). + Menu Options chứa các công cụ tạo hiệu ứng và thiết lập khuôn mẫu cho trang vẽ: kích cỡ trang, chọn màu nền trang vẽ và các lớp, chọn kiểu lưới, thời gian tự động sao lưu trang, màu và font chữ. + Menu Window chứa các công cụ sắp xếp lại các cửa sổ trong giao diện. + Menu Help chứa các công cụ trợ giúp: thông tin phần mềm, xử lý lỗi, chu kỳ thực hiện các tác vụ, học sử dụng phần mềm, các thông tin hỗ trợ khác như bảng phím tắt. - Kế đến là thanh menu phụ với các tiêu hình quen dùng (hình 1.2). Hình 1.2. Thanh menu phụ với các tiêu hình quen dùng - Sau cùng là cửa sổ Session Log (hình 1.3). Hình 1.3. Cửa sổ Session Log Session log là khung cửa sổ hiển thị thông tin về bản vẽ sơ đồ nguyên lý: số linh kiện, loại linh kiện, thuộc tính linh kiện và lưu thông tin về lỗi (chân linh kiện, kết nối đường dây, nhãn, giá trị), ... Người thao tác có thể mở hoặc tạo một thiết kế, thư viện từ khung này.
  8. Chương 1.Phần mềm thiết kế mạch in 3 1.2. Cửa sổ New Project Từ cửa sổ giao diện Session Log, chọn File → New → Project. Giao diện New Project xuất hiện (hình 1.4), cửa sổ này cho phép tạo mới một Project. Người thao tác nhập tên Project trong mục Name và chọn đường dẫn đến vị trí lưu ở mục Location. Hình 1.4. Cửa sổ New Project + Mục Analog or Mixed A/D: mục này cho phép vẽ mạch điện trong trang Capture CIS, sau đó liên thông với trình PSpice để mô phỏng tính toán các tham số. + Mục PC Board Wizard: mục này cho phép vẽ mạch điện trong trang Capture CIS, sau đó liên thông trực tiếp với trình Layout Plus để vẽ bản mạch in. + Mục Programmable Logic Wizard: mục này cho phép vẽ mạch điện trong trang Capture CIS, sau đó liên thông với trình PLD dùng cho việc viết các chương trình nạp EPROM. + Mục Schematic: mục này cho phép vẽ sơ đồ mạch điện nguyên lý, liên thông với trình Layout Plus thông qua file có đuôi “.MNL”. 1.3. Cửa sổ Orcad Capture Trong cửa sổ New Project, sau khi đặt tên và chọn đường dẫn lưu Project, chọn mục Schematic để vẽ sơ đồ mạch nguyên lý thì xuất hiện cửa sổ Orcad Capture (hình 1.5). - Menu File: công cụ xử lý các tập tin và kết quả trang vẽ. - Menu Design: công cụ tạo mới các thành phần cho trang vẽ. - Menu Edit: công cụ cắt, dán, biên soạn lại các thành phần trang vẽ. - Menu View: chọn hoặc bỏ chọn hiển thị thanh công cụ vẽ mạch. - Menu Tools: các lệnh xử lý bản vẽ
  9. Chương 1.Phần mềm thiết kế mạch in 4 Hình 1.5. Cửa sổ Orcad Capture - Menu Accessories: công cụ phụ trợ dùng hiệu chỉnh sơ đồ mô tả chân linh kiện, sơ đồ mô tả thư viện đính kèm. - Menu Report: công cụ bảng biểu thông báo. - Menu Options: công cụ chọn khuôn mẫu định trước cho trang vẽ. - Menu Window: công cụ sắp xếp lại các cửa sổ trong giao diện. Thanh công cụ vẽ mạch: Con trỏ di chuyển, xoay,...linh kiện Tạo một cổng Lấy linh kiện từ thư viện Nối trang này sang trang khác Nối dây Đặt vị trí ngắt trang (Place off-page) Nối dây thành mạng Chỉ ra chân linh kiện không nối Tạo đường bus Vẽ tùy ý Tạo điểm nối Vẽ Zigzac Nối dây vào bus Vẽ hình vuông, chữ nhật Nguồn Vẽ hình Oval Mass Vẽ cung tròn Đánh dấu bao khối vùng mạch Tạo văn bản Các phím tắt được sử dụng nhiều trong Orcad Capture: R: Xoay linh kiện T: Thêm văn bản cho bản vẽ W: Nối các đường mạch X: Đánh dấu chân linh kiện không sử I: Phóng to màn hình dụng O: Thu nhỏ màn hình F: Lấy các khối nguồn
  10. Chương 1.Phần mềm thiết kế mạch in 5 P: Lấy linh kiện G: Lấy các khối mass N: Đánh nhãn Y: Vẽ khối chữ nhật J: Tạo điểm nối ESC: Thoát chế độ đang chọn B: Vẽ đường Bus * Lưu ý: Tắt các trình gõ tiếng Việt để sử dụng được các phím tắt. Các từ khóa được sử dụng nhiều trong Orcad Capture: R: Điện trở Diode Zener : Diode ổn áp Resistor Var: Biến trở NPN : Transistor ngược Cap: Tụ điện PNP : Transistor thuận Cap NP: Tụ không phân cực Crystal: Thạch anh Relay: Rờ - le Bridge: Cầu diode Led: Đèn led đơn SW: công tắc Fuse: Cầu chì Headr: Chân cắm Diode: Diode Connector: Đầu nối 2. Thư viện linh kiện 2.1. Tìm kiếm và chọn linh kiện Trong cửa sổ Schematic (vùng vẽ sơ đồ mạch nguyên lý), nhấn phím P (hoặc Shift + P hoặc chọn Place Part trên thanh công cụ vẽ mạch), khi đó cửa sổ Place Part xuất hiện (hình 1.6). Hình 1.6. Cửa sổ Place Part
  11. Chương 1.Phần mềm thiết kế mạch in 6 - Mục Part: nhập tên linh kiện cần tìm. - Mục Part List: danh sách các linh kiện thuộc thư viện có tên nằm trong mục Libraries. - Mục Libraries: chứa các thư viện linh kiện. Lưu ý: phần mềm Orcad sau khi cài đặt xong (chưa có bản vẽ nào) thì mục Part List trong cửa sổ Place Part không có danh sách linh kiện vì mục Libraries chưa được gọi thư viện, để lấy danh sách thư viện ta làm như sau: Chọn Add Library xuất hiện cửa sổ Browse File: Hình 1.7. Cửa sổ Browse File để lấy thư viện linh kiện Chọn Ctrl+A → Open để lấy tất cả các thư viện linh kiện hoặc click chọn từng thư viện mong muốn sau đó nhấn Open để lấy thư viện vào danh mục Libraries. Việc chọn từng thư viện giúp người sử dụng quản lý dễ dàng các nhóm thư viện: thư viện vẽ mạch nguyên lý, thư viện mô phỏng mạch hoặc thư viện liên kết với phần mềm vẽ mạch in. Sau khi lấy các thư viện mong muốn, mục Libraries trong cửa sổ Place Part xuất hiện danh mục thư viện và mục Part List hiện danh sách linh kiện có trong các thư viện đó (hình 1.8). Mỗi thư viện có tên khác nhau và nằm riêng lẻ thành từng file hoặc nằm trong một thư mục lớn (thư mục có nhiều thư viện). Việc chọn linh kiện ở thư viện nào thì tùy thuộc mục đích sử dụng của người thiết kế.
  12. Chương 1.Phần mềm thiết kế mạch in 7 Hình 1.8. Cửa sổ Place Part sau khi lấy danh mục thư viện linh kiện Ví dụ: linh kiện R (điện trở) trong thư viện Discrete được sử dụng để vẽ mạch nguyên lý và liên thông dễ dàng đến phần mềm vẽ mạch in; trong khi đó linh kiện R (điện trở) trong thư viện Device (Oldlibs\Device) chỉ dùng để vẽ mạch nguyên lý. Phần nhận biết dấu hiệu khác biệt và hiệu chỉnh sao cho tương thích giữa linh kiện mạch nguyên lý với sơ đồ chân linh kiện mạch in sẽ được trình bày sau. Bảng 1.1. Nội dung và ý nghĩa một số thư viện linh kiện: Tên thư viện Nội dung và ý nghĩa fpga Field programmable gate array - fpga Thư viện linh kiện mạch tích hợp mảng logic cỡ lớn iec International Electrotechnical Commission - IEC: Ủy ban Kỹ thuật Điện Quốc tế. Thư viện tiêu chuẩn IEC gồm các linh kiện điện, điện tử cơ bản theo tiêu chuẩn IEC: công tắc, nút nhấn, biến thế, đầu nối, điện trở, tụ điện, diode, led, cầu diode, transistor, triac,... ieee Institute of Electrical and Electronics Engineers - IEEE: Viện kỹ nghệ Điện và Điện tử. Thư viện linh kiện tiêu chuẩn IEEE gồm các IC chứa cổng logic, IC đếm, IC chốt, thanh ghi dịch, bộ hợp kênh, bộ phân kênh,
  13. Chương 1.Phần mềm thiết kế mạch in 8 SRAM. oldlibs Thư viện linh kiện tùy chọn của các hãng: Atmel, Analog Devices, Dalas, Micron, Motorola, Samsung, Panasonics, Zilog,...Nhóm thư viện này gồm các linh kiện chuyên dụng và một số linh kiện cơ bản đã liệt kê ở trên. pspice Thư viện mô phỏng mạch nguyên lý. Amplifier Thư viện các linh kiện khuếch đại: IC tương tự (Opamp), IC số Arithmetic Thư viện linh kiện xử lý số học Atod Thư viện linh kiện phục vụ công tác chuyển đổi tương tự sang số Connector Thư viện đầu nối DRAM Thư viện IC bộ nhớ động SRAM Thư viện IC bộ nhớ tĩnh ShiftRegister Thư viện thanh ghi dịch Regulator Thư viện IC ổn áp ElectroMechanical Thư viện: CB, còi, micro, động cơ ac, động cơ servo, động cơ bước, loa. MicroController Thư viện IC vi điều khiển MicroProcessor Thư viện IC vi xử lý FIFO Thư viện IC đệm dữ liệu kiểu “Firt In Fist Out” (vào trước ra trước), loại IC số LineDriverReceiver Thư viện IC đệm dữ liệu tuyến tính, loại IC tương tự. Trong mục Part List, click chọn tên linh kiện mong muốn hoặc chọn tên thư viện phù hợp trong mục Libraries, sau đó điền tên linh kiện cần tìm vào trong mục Part (nên sử dụng các từ khóa được sử dụng nhiều trong Orcad capture). Khi đó xuất hiện hình linh kiện phía dưới góc phải cửa sổ Place Part. Chọn OK, lúc này cửa sổ đóng lại và linh kiện “dính” vào chuột (rê chuột thì linh kiện di chuyển theo). Chọn vị trí thích hợp trên vùng vẽ sơ đồ mạch nguyên lý và click chuột trái để đặt linh kiện, nếu có nhiều linh kiện cùng loại thì click tiếp chuột trái; sau đó bấm phím E hoặc ESC hoặc click chuột phải chọn End Mode để kết thúc việc đặt linh kiện. Thực hiện tương tự cho các linh kiện tiếp theo. Bấm phím R (Rotate) để xoay linh kiện, bấm phím V (Vertical) để lật linh kiện theo chiều dọc và bấm phím H (Horizontal) để lật linh kiện theo chiều ngang. Như vậy, mục 2.2.1 vừa trình bày thao tác tìm kiếm và chọn linh kiện có sẵn đưa vào bản vẽ. Tuy nhiên, một số linh kiện không có sẵn trong thư viện của Orcad Capture, người sử dụng có thể tìm và tải miễn phí các bộ thư viện trên các trang mạng liên quan, sau đó Add thư viện đó vào trong Libraries của phần mềm trên máy như đã hướng dẫn. Cách khác là người sử dụng có thể tự tạo riêng cho mình các linh kiện đó. Mục 2.2.2 sẽ hướng dẫn tạo thư viện linh kiện mới trong Orcad Capture.
  14. Chương 1.Phần mềm thiết kế mạch in 9 2.2. Tạo thư viện linh kiện mới trong Orcad Capture Việc tạo mới linh kiện giúp người thiết kế dễ dàng quản lý và thao tác nhanh hơn trong việc tìm kiếm linh kiện. Các bước tạo mới một linh kiện gồm: tra cứu datasheet của linh kiện, tạo linh kiện, vẽ đường bao và lưu linh kiện. Công việc tra cứu datasheet (trang tài liệu về linh kiện) nhằm cung cấp thông tin linh kiện để người sử dụng biết sơ đồ bố trí chân linh kiện, tên các chân, số lượng chân. Tạo mới thư viện để làm nơi lưu trữ linh kiện giúp người sử dụng quản lý chặt chẽ các danh mục thư viện với tên gọi phù hợp với dự án (Project) hay bản vẽ của mình (Schematic). Trong mục này sẽ hướng dẫn người thiết kế tạo mới IC555. Bước 1. Tra cứu datasheet Tra cứu datasheet của IC555 thông qua trang web https://google.com hoặc tìm trực tiếp từ các trang: www.alldatasheet.com; www.datasheetcataloge.com . Hình IC555 trong datasheet được biểu diễn ở hình 1.9. Hình 1.9. Sơ đồ chân IC555 Bước 2. Tạo linh kiện - Trong cửa sổ Orcad Capture hoặc Capture CIS, chọn File → New → Library Hình 1.10. Tạo linh kiện_bước 2(a)
  15. Chương 1.Phần mềm thiết kế mạch in 10 Hình 1.11. Tạo linh kiện_bước 2(b) - Trong cửa sổ quản lý, tại thư mục Library click chuột phải vào library.olb, chọn New Part để tạo linh kiện mới. - Trong cửa sổ New Part Properties, điền tên linh kiện vào mục Name, chọn kiểu linh kiện trong mục Part Reference Prefix (IC chọn là U), click OK để vào trang thiết kế. Hình 1.12. Tạo linh kiện_bước 2(c) - Trang thiết kế linh kiện xuất hiện (hình 1.13): + Tạo nhóm chân linh kiện bên trái (chân có số thứ tự từ 1 đến 4): chọn Place Pin Array trên thanh công cụ, cửa sổ cùng tên xuất hiện (hình 1.14). ˃ Mục Starting Name (tên chân): 1 ˃ Mục Starting Number (chân bắt đầu): 1 ˃ Mục Numbers of Pins (số chân tạo trong nhóm): 4 ˃ Mục Increment (đơn vị tăng): 1 ˃ Mục Shape (kiểu chân: dài, ngắn, điểm...): Short ˃ Mục Type (hiển thị, không hiển thị chân): Passive
  16. Chương 1.Phần mềm thiết kế mạch in 11 Hình 1.13. Trang thiết kế linh kiện Hình 1.14. Cửa sổ Place Pin Array_bước 2(d) Hình 1.15. Kết quả_bước 2(d) ˃ Click OK, chuột tạo thành 1 dãy 4 chân kiện khối U vuông, click chuột đặt khối này vào bên trái IC (hình vuông trên trang thiết kế). Kết quả biểu diễn ở hình 1.15. + Tạo nhóm chân linh kiện bên phải (chân có số thứ tự từ 5 đến 8): chọn Place Pin Array trên thanh công cụ, cửa sổ cùng tên xuất hiện (hình 1.16). ˃ Mục Starting Name (tên chân): 8 ˃ Mục Starting Number (chân bắt đầu): 8 ˃ Mục Numbers of Pins (số chân tạo trong nhóm): 4
  17. Chương 1.Phần mềm thiết kế mạch in 12 Hình 1.16. Cửa sổ Place Pin Array_bước 2(e) Hình 1.17. Kết quả_bước 2(e) ˃ Mục Increment (đơn vị tăng): -1 ˃ Mục Shape (kiểu chân: dài, ngắn, điểm...): Short ˃ Mục Type (hiển thị, không hiển thị chân): Passive ˃ Click OK, chuột tạo thành 1 dãy 4 chân kiện khối U vuông, click chuột đặt khối này vào bên phải IC (hình vuông trên trang thiết kế). Kết quả biểu diễn ở hình 1.17. - Đặt tên chân, kiểu chân linh kiện: double click chuột vào vị trí chân linh kiện, cửa sổ Pin Properties hiện ra: đặt tên trong mục Name và kiểu chân trong mục Shape. Hình 1.18 mô tả đặt tên chân số 1 của IC555 là “Gnd”, kiểu chân là “Short”. Thực hiện tương tự cho các chân khác của IC. Kết quả sơ đồ chân IC555 được biểu diễn ở hình 1.19. Hình 1.18. Đặt tên chân số 1 là “Gnd” - Đặt lại vị trí các chân theo ý muốn: trường hợp người thao tác muốn đổi vị trí các chân để quá trình vẽ mạch nguyên lý được thuận tiện; ví dụ IC555 cần đổi vị trí các chân để khi vẽ mạch nguyên lý dao động đa hài được thuận tiện thì tiến hành như sau. Trong trang thiết kế, click và giữ chuột vào chân muốn di chuyển, sau đó rê chuột đến vị trí mong muốn và click chuột để đặt chân linh kiện.
  18. Chương 1.Phần mềm thiết kế mạch in 13 Hình 1.19. Kết quả bước_2(f) Hình 1.20. Kết quả bước_3 Bước 3. Vẽ đường bao và lưu linh kiện Trong trang thiết kế, chọn Place rectangle trên thanh công cụ để tạo đường bao, vẽ hình vuông vừa khít trên hình. Chọn Place Text để nhập tên cho linh kiện. Sau đó nhấn nút Save để lưu linh kiện. Kết quả được mô tả ở hình 1.20. Nên lưu linh kiện vào trong Libraries của Orcad Capture vào trong thư mục riêng để dễ quản lý. 2.3. Chỉnh sửa sơ đồ chân linh kiện Công việc chỉnh sửa sơ đồ chân linh kiện nhằm mục đích sử dụng đầy đủ chân nguồn, mass trong mạch (IC có hai chân nguồn và mass bị ẩn khi ta gọi linh kiện ra trang vẽ) hoặc liên kết đúng đến chân linh kiện hàn (PCP Footprints) của mạch in (Layout), hoặc tạo sự thuận lợi trong quá trình nối dây trên bản vẽ. Trong mục này, giáo trình hướng dẫn thao tác chỉnh sửa sơ đồ chân linh kiện trên hai linh kiện là IC ổn áp nguồn 7805 và cầu Diode vì hai linh kiện tiêu biểu này được sử dụng trong các minh họa ở các mục sau và bài tập chương ba. IC 7805 được lấy ra từ thư viện Regulator (Regulator\L7805\TO220); cầu Diode được lấy ra từ thư viện Discrete (Discrete\Bridge). Chỉnh sửa sơ đồ chân IC 7805: Sau khi lấy IC 7805 ra trang vẽ ta so sánh giữa ký hiệu và sơ đồ chân IC họ 78XX (họ ổn áp nguồn dương). Sự khác biệt ở hai điểm: chân 2 trên sơ đồ chân là chân mass (GND), chân 3 là chân OUT khác với ký hiệu trên bản vẽ là chân 2: chân OUT và chân 3: không hiển thị. Nhiệm vụ người thiết kế lúc này là chỉnh sửa chân linh kiện phù hợp với sơ đồ chân thực tế: chân 2: GND và chân 3: OUT.
  19. Chương 1.Phần mềm thiết kế mạch in 14 Hình 1.21. Ký hiệu và sơ đồ chân IC 7805 - Trên trang vẽ, click chuột vào ký hiệu IC 7805, sau đó click phải chuột và chọn Edit Part, trang hiệu chỉnh xuất hiện (hình 1.22). Hình 1.22. IC 7805 trên trang hiệu chỉnh - Click chuột vào ô tròn màu hồng, click phải chọn Edit Properties, cửa sổ Pin Properties xuất hiện (hình 1.23). Ở vị trí này là chân số 2 có tên là GND. Hình 1.23. Cửa sổ Pin Properties, hiệu chỉnh chân 2 + Mục Name (tên chân): GND + Mục Number (số thứ tự chân): 2 + Mục Shape (kiểu chân): Short + Mục Pin: (hiển thị, không hiển thị): click chọn + Click OK - Click chuột chân 2, click phải chọn Edit Properties, cửa sổ Pin Properties xuất hiện (hình 1.24). Ở vị trí này là chân số 3 có tên là VOUT.
  20. Chương 1.Phần mềm thiết kế mạch in 15 Hình 1.24. Cửa sổ Pin Properties, hiệu chỉnh chân 3 + Mục Name (tên chân): VOUT + Mục Number (số thứ tự chân): 3 + Mục Shape (kiểu chân): Short + Click OK - Tương tự click chọn chân 1 và chỉnh sửa kiểu chân: Short. Kết quả chỉnh sửa trên trang hiệu chỉnh như sau: Hình 1.25. Kết quả chỉnh sửa chân IC 7805 Kết quả cho thấy ký hiệu trên bản vẽ và sơ đồ chân IC 7805 là trùng khớp nhau. - Click vào Close trên trang hiệu chỉnh để đóng cửa sổ này, xuất hiện hộp thoại: Hình 1.26. Hộp thoại sau hiệu chỉnh chân linh kiện
ADSENSE

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản
2=>2