intTypePromotion=1

Căn bản hướng dẫn MicroStation SE

Chia sẻ: Dinh Tran Linh | Ngày: | Loại File: PDF | Số trang:34

1
722
lượt xem
191
download

Căn bản hướng dẫn MicroStation SE

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Bài này cung cấp một số khái niệm cơ bản trong Microstation và hướng dẫn các bạn thực hành một số thao tác cơ bản khi làm việc với MicroStation , bao gồm Làm việc với các design file, cấu trúc của một desing file, đối tường đồ họa, thao tác điều khiển màn hình, các sử dụng các phím chuột, các chế độ bắt điểm

Chủ đề:
Lưu

Nội dung Text: Căn bản hướng dẫn MicroStation SE

  1. Căn b n hư ng d n s d ng MicroStation SE
  2. CĂN B N V PH N M M MICROSTATION Bài h c này cung c p m t s khái ni m cơ b n trong MicroStation và hư ng d n các b n th c hành m t s thao tác cơ b n khi làm vi c v i MicroStation, bao g m: - Làm vi c v i các design file. - C u trúc c a m t design file. i tư ng - ho . - Thao tác i u khi n màn hình. - Cách s d ng các phím chu t. - Các ch b t i m. 1. LÀM VI C V I CÁC DESIGN FILE File d li u c a MicroStation g i là design file. MicroStation ch cho phép ngư i s d ng m và làm vi c v i m t design file t i m t th i i m. File này g i là Active Design file. N u b n m m t design file khi b n ã có m t Design file khác ang m s n, MicroStation s t ng óng file u tiên l i. Tuy nhiên b n có th xem (tham kh o) n i dung c a các design file khác b ng các tác ng n các file dư i d ng các file tham kh o (Reference File). M t design file trong MicroStation ư c t o b ng cách copy m t file chu n g i là Seed File. Cách t o Design File 1. Kh i ng MicroStation → xu t hi n h p tho i MicroStation Manager. 2. T File → ch n New→ xu t hi n h p h i tho i Create Design file. 3. ánh tên file vào h p text Files: ví d Study.dgn. 4. Ch n Seed file b ng cách b m vào nút select... → xu t hi n h p h i tho i Select seed file. 5. Ch n ư ng d n n tên thư m c và tên seed file cho b n c a mình. Ví d file gauss-108.dgn s là seed file ư c ch n cho b n Study.dgn. 6. B m phím OK xoá h p h i tho i Select seed file. 7. Ch n thư m c ch a file b ng cách nh p ôi vào các h p thư m c bên h p danh sách các thư m c. 8. B m phím OK xoá h p h i tho i Create Design file 2
  3. Cách th hai t o m t file m i khi ang làm vi c v i m t design file b ng cách t File menu c a c a s l nh ch n New→ xu t hi n h p h i tho i Create Design File. Ti p t c làm t bư c 3 tr i. Cách m m t Design file dư i d ng Active design File Cách 1: Ch n thư m c ch a file và tên file t h p h i tho i MicroStation Manager → b m OK. Cách 2: 1. T thanh Menu ch n File → ch n Open → xu t hi n h p h i tho i Open design File. 2. T List file of Type ch n (*.dgn) n u chưa có s n. Khí ó t t c các file có uôi 3
  4. (.dgn) s xu t hi n trên h p danh sách tên file. 3. Ch n thư m c ch a file b ng cách nh p ôi vào các h p thư m c bên h p danh sách các thư m c. 4. Ch n tên File. 5. B m nút OK. Cách m m t Design file dư i d ng m t Reference File. 1. T thanh Menu ch n File → ch n Reference→ xu t hi n h p h i tho i Reference Files. 2. T thanh menu c a h p h i tho i Reference file ch n Tools→ ch n Attach... → xu t hi n h p h i tho i Attach Reference File. 3. Ch n thư m c ch a file b ng cách nh p ôi vào các h p thư m c bên h p danh sách các thư m c. 4. Ch n tên file. 5. B m phím OK xoá h p h i tho i Attach Reference files. Khi ó ch n h p h i tho i Reference Files s xu t hi n tên file v a ch n. 6. Phím Display ư c ánh d u khi mu n hi n th file. 7. Phím Snap ư c ánh d u khi mu n s d ng ch bt im i v i Reference file. 8. Phím Locate ư c ánh d u khi mu n xem thông tin c a i tư ng ho c copy i tư ng trong Reference file. Cách óng m t Reference file Trong h p h i tho i Reference file ch n tên file c n óng ch n Tools → ch n Detach. 4
  5. Cách nén file (Compress Design file) Khi xoá i tư ng trong Dessign file, i tư ng ó không b xoá h n mà ch ư c ánh d u là ã xoá i tư ng. Ch sau khi nén file thì các i tư ng ư c xoá m i ư c lo i b h n kh i b nh . Quá trình nén file s làm cho b nh c a file b gi m xu ng. T thanh menu c a MicroStation ch n File→ ch n Compress Design. Cách lưu tr dư i d ng m t file d phòng (save as, back up). ng ghi l i d li u sau m i l n thay i file active. Vì v y ngư i MicroStation t s d ng không c n ghi l i d li u sau m i l n óng file active ho c thoát kh i phòng các trư ng h p b t tr c, ngư i s d ng nên ghi l i MicroStation. Tuy nhiên file d li u ó dư i d ng m t File d phòng b ng cách thay i tên file ho c ph n m r ng c a file. Cách 1: T thanh Menu c a MicroStation ch n File → ch n Save as. i tên file nhưng gi nguyên ph n m r ng là 1. Ghi l i file ó b ng cách thay DGN. 2. Ch n thư m c ch a file (có th c t trong thư m c cũ) b ng cách nh p ôi vào các h p thư m c bên h p danh sách các thư m c. Cách 2: T c a s l nh c a MicroStation ánh l nh Backup sau ó b m Enter trên bàn phím. MicroStation s ghi l i file active ó thành m t file có ph n m r ng là (.bak), Tên file và thư m c ch a file gi nguyên. 2. C U TRÚC FILE (.DGN), KHÁI NI M LEVEL D li u trong file DGN ư c tách riêng thành t ng l p d li u. M i m t l p d li u ư c g i là m t level. M t file DGN nhi u nh t có 63 level. Các level này ư c qu n lý theo mã s t 1á63 ho c theo tên c a level do ngư i s d ng t. Các level d li u có th hi n th (b t) ho c không hi n th (t t) trên màn hình. Khi a d li u ư c b t màn hình s hi n th t t c các level ch y n i dung c a b n v . Ta cũng có th t t t t c các level tr level ang ho t ng g i là Active level. Active i tư ng s ư c v trên ó. level là level các Cách t tên level. 1. T thanh menu c a MicroStation ch n Settings → ch n Level → ch n Name → xu t hi n h p h i tho i Level Names. 2. B m vào nút Add → xu t hi n h p h i tho i Level name. 3. Number: mã s level 4. Name: tên level (nh hơn ho c b ng 6 ký t ) 5
  6. 5. Comment: gi i thích thêm v tên, có th có ho c không (nh hơn ho c b ng 32 ký t ). 6. B m nút OK. Cách t tên level thành active level Cách 1: T c a s l nh c a MicroStation ánh l nh lv = sau ó b m phím ENTER trên bàn phím. Cách 2: Ch n mã s level t phím level trên thanh Primary. T thanh Menu c a MicroStation ch n Tools → ch n Primery → xu t hi n thanh Primary. B m vào phím Active level (phím th hai t trái sang ph i) → xu t hi n b ng 63 level → kéo chu t n mã s level c n ch n. Cách b t, t t level. Cách 1: T c a s l nh c a MicroStation ánh l nh on= b t level c n hi n th . Trong trư ng h p sau ó b m phím ENTER trên bàn phím mu n b t nhi u level m t lúc thì mã s ho c tên c a level cách nhau m t d u ",". Mu n t t các level thay "on" b ng "of". Cách 2: T bàn phím b m li n hai phím < Ctrl_E → xu t hi n h p View levels Các level b t là các ô vuông ư c bôi en, các level t t là các ô vuông có màu xám. M i l n b m con tr vào m t ô vuông nào ó, ô vuông ó s i ch t xám sang en ho c t en sang xám. Sau khi ã ch n xong level c n t t, b t → b m phím Apply. 3. I TƯ NG HO (ELEMENT) i tư ng (element) Khái ni m M i m t i tư ng ho xây d ng lên Design file ư c g i là m t element. Element có th là m t i m, ư ng, vùng ho c m t ch chú thích. M i m t element ư c nh nghĩa b i các thu c tính ho sau: + Color: (0-254) + Level: (1-63) + Line Weight: (1-31) + Line Style: (0-7, custom style) i tư ng óng vùng tô màu). + Fill color: (cho các 6
  7. Các ki u i tư ng (element type) s d ng cho các b n s. 1. Ki u Element th hi n các i tư ng d ng i m: - Là 1 Point = Line ( o n th ng) có dài b ng 0. - Là 1 cell (m t kí hi u nh ) ư c v trong MicroStation. M i m t cell ư c nh nghĩa b i m t tên riêng và ư c lưu tr trong m t thư vi n cell (Cell library). 2. Ki u Element th hi n các i tư ng d ng ư ng: - Line: o n th ng n i gi a hai i m. - LineString: ư ng g m m t chu i các o n th ng n i li n v i nhau. (s on th ng < 100) - Chain: là m t ư ng t o b i 100 o n th ng n i li n nhau. o n th ng t o nên ư ng > 100. - Complex String: s Chú ý: các element có ki u là Chain và Complex String, MicroStation không cho phép chèn thêm i m vào ư ng. 3. Ki u Element th hi n các i tư ng d ng vùng: o n th ng t o lên ư ng bao c a vùng l n nh t b ng - Shape: là m t vùng có s 100. - Complex Shape: là m t vùng có s o n th ng t o nên ư ng bao c a vùng l n hơn 100 ho c là m t vùng ư c t o t nh ng line ho c linestring r i nhau. 4. Ki u Element th hi n các i tư ng d ng ch vi t: i tư ng - Text: ho d ng ch vi t. i tư ng text ư c nhóm l i thành m t Element. - Text Node: nhi u H p công c Primary Tools H p công c Primary Tools bao g m m t s các công c thư ng dùng và cho phép thay i các thu c tính c a i tư ng khi thao tác v i i tư ng. Thông thư ng chúng ư c t lên phía trên c a c a s hi n th i. N u chưa có thanh công c này thì ta có th ch n Tools -> Primary. Thanh công c có d ng: Primary Tools tool box 7
  8. N i dung c a thanh công c Primary toosl là: N i dung Cách dùng t màu hi n th i (Active Color) Color t l p hi n th i (Active Level) Level t ki u ư ng hi n th i (Active Line Style) Line Style t ki u ư ng custom Line Style > Custom Thay i ki u ư ng Line Style > Edit r ng ư ng (Line Weight) t Line Weight i tư ng Xem và thay i các thông tin v Analyze Element Color Ch n màu hi n th i (Active Color) trong b ng màu ho c thay i màu c a các i tư ng ư c ch n. Màu c a m t i tư ng ư c xác nh trong kho ng giá tr t 0 - 254. Màu hi n th i có th ư c t b ng m t trong hai cách: - Kéo rê con chu t trong bi u tư ng màu trong h p Primary tool và th t i màu c n ch n - Nh p l nh: Co= -> nh n ENTER trong c a s l nh c a MicroStation. i thành ph n c a các màu trong b ng màu b ng vi c ch n Setting -> Ta có th thay Color Table Level t level hi n th i (Active Level) trong kho ng t 1 - 63 mà khi v m t d i tư ng ho c thay i các i tư ng ư c ch n vào level ó. t level hi n th i: 8
  9. - Trong nút level c a thanh Primary tool, kéo rê con chu t t i m t trong 63 level r i nh ra t i level c n t Ho c có th dùng: - Nh p l nh: lv= -> nh n ENTER trong c a s l nh c a MicroStation - Nh p úp vào s level trong h p h i tho i Level Display (nh n Ctrl + E b th p tho i này) Line Style Khi m t ki u ư ng chu n ư c ch n, các i tư ng s ư c v ho c các i tư ng ư c ch n s nh n ki u ư ng hi n th i (Active Line Style). Các ki u ư ng chu n bao g m 8 ki u (t 0 - 7), m t i tư ng có th nh n m t trong các ki u ư ng chu n ho c ki u ư ng custom. Ki u ư ng hi n th i cũng ư c ch n b ng cách kéo chu t và nh vào ki u ư ng c n ch n trên thanh Primary tools. Nh p l nh: ACTIVE STYLE [line_style] 9
  10. Line Style > Custom ch n các ki u ư ng và thay i các M h p h i tho i line styles, h p này dùng ki u ư ng trong MicroStation. H p h i tho i này li t kê t t c các ki u ư ng trong thư vi n c a MicroStation. Khi tích vào tùy ch n Show Details, h p h i tho i có thêm các ph n i u khi n Origin, End, Scale Factor, Shift, and Click to Activate Mu n t m t line style thành hi n th i, ch n tên line style trong m c names, tt l trong tuỳ ch n Scale factor n u c n. Nh p úp vào nơi hi n th ki u ư ng ki u ư ng tr thành hi n th i. Line Weight Dùng ch n m t lo i l c nét làm l c nét hi n hành (the Active Line Weight). i tư ng ư c ch n. Thay i lo i l c nét cho 10
  11. Nh p l nh: ACTIVE WEIGHT CSELECT ACTIVE WEIGHT line_weight ho c Nh p giá tr line_weight 0 - 15. lưu l i l c nét hi n hành. Ngư c l i, l c nét hi n Ch n Save Settings t menu File hành s tr l i giá tr m c nh. 4. CÁC THAO TÁC I U KHI N MÀN HÌNH phóng to, thu nh ho c d ch chuy n màn hình ư c b trí Các công c s d ng góc dư i bên trái c a m i m t c a s (window). 1. Uplate: v l i n i dung c a c a s màn hình ó. 2. Zoom in: phóng to n i dung. 3. Zoom out: thu nh n i dung. 4. Window area: phóng to n i dung trong m t vùng. 5. Fit view: thu toàn b n i dung c a b n v vào trong màn hình. 6. Pan: d ch chuy n n i dung theo m t hư ng nh t nh. màn hình lúc trư c. 7. View previous: quay l i ch màn hình lúc trư c khi s d ng l nh View previous. 8. View next: quay l i ch Chú ý: S d ng các l nh i u khi n màn hình không làm dán o n các l nh ang s d ng trư c ó. 5. CÁCH S D NG CÁC PHÍM CHU T Do ph i thao tác v i các i tư ng h a có v trí chính xác nên vi c s d ng chu t thành th o tr nên r t quan tr ng i v i ngư i dùng. Khi thao tác v i các i tư ng, ta thư ng ph i s d ng m t trong ba ch ư c nh nghĩa trên chu t sau: Data, Reset, Tentative. Data (thư ng là phím trái), khi b m phím này tương ương v i vi c th c hi n m t trong các tác v sau: i tư ng ho c ch n - Xác nh m t i m trên file DGN (ví d : khi v i tư ng) 11
  12. ư c ch n (ví d : khi s d ng l nh fit - Xác nh c a s màn hình nào s view ho c update màn hình) i tư ng) - Ch p nh n m t thao tác nào ó (ví d : xoá Reset (thư ng là phím ph i), khi b m phím này tương ương v i vi c th c hi n m t trong các tác v sau: - B d ho c k t thúc m t l nh,m t thao tác nào ó - Tr l i bư c trư c ó trong nh ng l nh ho c nh ng thao tác gi ng nhau - Khi ang th c hi n d m t thao tác c n k t h p v i các thao tác i u khi n màn hình, thì m t (ho c hai) l n b m phím Reset s k t thúc thao tác i u khi n màn hình và quay tr l i thao tác ang th c hi n. Tentative (thư ng là b m ng th i c phím trái và phím ph i), th c hi n ch b t i m (snap) Cách t quy nh cho các phím chu t. Thông thư ng, khi cài t ph n m m MicroStation, các ch c năng c a các phím chu t luôn ư c quy nh theo m c nh: Data (phím trái), Reset (phím ph i), ch c năng Tentative (b m ng th i c phím trái và phím ph i). Tuy nhiên, ta có th quy nh l i ch c năng c a các phím chu t cho phù h p v i thói quen d thao tác b ng cách: T thanh menu c a MicroStation ta ch n Workspace → ch n Button Assignments → xu t hi n h p h i tho i Button Assignments. 1. Ch n m t phím ch c năng (ví d ch n phím Data). 2. D ch chuy n con tr xu ng ph n Button Definition area. 3. B m phím chu t (ví d phím trái) mu n s d ng làm phím ã ch n (data). N u chu t ch có hai phím thì m t trong ba phím ch c năng (thư ng là phím Tentative) s ph i dùng cùng lúc hai phím chu t. 4. B m nút OK. 12
  13. 6. CÁC CH B T I M (SNAP MODE) tăng chính xác cho quá trình s hoá trong nh ng trư ng h p mu n t i m Data vào úng v trí c n ch n, phím Tentative s ư c dùng ưa con tr vào úng v trí trư c. Thao tác ó ư c g i là b t i m (Snap to Element). Các ch ch n l a cho thao tác b t i m g m: Nearest: con tr s b t vào v trí g n nh t trên element. Keypoint: con tr s b t vào i m nút g n nh t element. Midpoin: con tr s b t vào i m gi a c a element. i tư ng. Center: con tr s b t vào tâm i m c a Origin: con tr s b t vào i m g c c a cell. Intersection: con tr s b t vào i m c t nhau gi a hai ư ng giao nhau. Cách b t i m Ch n Snap mode b ng m t trong hai cách sau: 1. T thanh menu c a MicroStation ch n Settings → ch n Snap → ch n m t trong nh ng ch trên. 2. T thanh menu c a MicroStation ch n Settings → ch n Snap → ch n Button Bar → xu t hi n thanh Snap Mode → ch n m t trong nh ng bi u tư ng tương ng v i các ch ch n trên. 13
  14. S D NG CÁC CÔNG C C A MICROSTATION d dàng, thu n ti n trong thao tác, MicroStation cung c p r t nhi u các công c (drawing tools) tương ương như các l nh. Các công c này th hi n trên màn hình dư i d ng các bi u tư ng v (icon) và ư c nhóm theo các ch c năng có liên quan thành nh ng thanh công c (tool box). Tài li u này hư ng d n s d ng m t s công c trong MicroStation, bao g m: - H p công c Main. - Công c Element Selection - Công c Fence - Công c Points - Công c Linear Elements - Công c Polygons 1. H P CÔNG C MAIN Các thanh công c thư ng dùng nh t trong MicroStation ư c t trong m t H p công c chính (Main tool box) và ư c rút g n d ng các bi u tư ng. Thanh công c chính ư c t ng m m i khi ta b t MicroStation và ta có th th y t t c các ch c năng c a MicroStation trong ó. T menu c a MicroStation ch n Tools -> ch n Main ->ch n Main i v i nh ng bi u tư ng có d u tam giác màu en nh góc dư i bên ph i (m t nhóm các công c có ch c năng liên quan v i nhau), có th dùng chu t kéo ra kh i thanh Main thành m t Tool box hoàn ch nh, ho c ch n t ng icon trong tool ó thao tác. Khi ta s d ng m t công c nào ó thì tool s d ng s là hi n th i và chuy n m u thành màu s m. Ngoài ra i kèm v i m i công c ư c ch n là h p Tool setting, h p này hi n th tên c a công c và các ph n t thông s i kèm (n u có). Ví d khi ta ch n công c t text thì h p tool setting có d ng: 14
  15. Ngoài vi c ch n các công c trên thanh main, ta còn có th nh p các l nh trong c a s l nh (Command window) c a MicroStation. Ví d : N u chưa có c a s l nh, ta có th ch n style trong MicroStation manager là command window khi kh i ng MicroStation M t s các l nh Key-in thông d ng: Ch c năng Cú pháp M các ng d ng trong MicroStation như: IRASB, MDL L < ng d ng> GEOVEC, MRFCLEAN, MRFFLAG, FAMIS... i tư ng: v , di Nh p t a m t i m khi thao tác v i các xy=, chuy n, copy,... dx=, D ch chuy n i m t kho ng theo giá tr delta theo tr c t a Nén file d li u nh m làm gi m kích thư c c a file com 15
  16. H p công c chính (Main tool frame) dùng l a ch n h u h t các công c h a trong MicroStation B ng li t kê các h p công c (tool box) trong Main tool frame: C t trái C t ph i i tư ng) Element Selection tool box (Ch n Fence tool box (Công c Fence) ư ng) Points tool box (Công c v i m Point) Linear Elements tool box (Công c v Patterns tool box (Công c Patten) Polygons tool box (Công c v vùng) ư ng trũn và Ellip) Arcs tool box (Công c v cung tròn) Ellipses tool box (Công c v Tags tool box (M Tags) Text tool box (Công c Text) i tư ng) Groups tool box (Công c thao tác v i 1 nhóm Cells tool box (Công c Cell) Measure tool box (Công c o) Dimension tool box (Công c Dimension) i tư ng) Change Attributes tool box (Thao tác v i thu c tính Manipulate tool box (Copy) i tư ng) i tư ng) Delete Element (Xóa Modify tool box (S a i ng MicroStation, n u chưa có thanh này ta có th ch n Tool > Main > Main Thanh Công c chính ư c b t lên ngay sau khi kh i hi n th trên màn hình. Nh p l nh: DIALOG TOOLBOX MAIN [OFF | ON | TOGGLE] 16
  17. i tư ng d ng ư ng, tuy n (Linear Element Tools). Thanh công c v i tư ng d ng i m Thanh công c v i tư ng d ng vùng (polygons Tools) Thanh công c v ư ng tròn, ellipses. Thanh công c v i tư ng d ng ch . Thanh công c v và s a các Thanh công c v các ký hi u d ng cell. i tư ng d ng vùng. Thanh công c trái kí hi u cho các copy, d ch chuy n tăng t l ho c quay i tư ng. Thanh công c dùng i tư ng. Thanh công c s a ch a i tư ng riêng l thành m t i tư ng ho c Thanh công c dùng liên k t các phá b liên k t ó. 17
  18. i tư ng. Thanh công c tính toán các giá tr v kho ng cách ho c l nc a i tư ng. Thanh công c ch n i tư ng Công c xoá 18
  19. 2. CÔNG C ELEMENT SELECTION thao tác và s a i i tư ng Khi không òi h i s chính xác, cách nhanh nh t là s d ng công c Element Selection trong thanh Công c ch n i tư ng Element Selection Công c Element Selection công c Power Selector S d ng công c Element Selection ta có th : Move i tư ng • • Thay i t l (Scalling) ng th i v i m t nhóm i tư ng ư c ch n • Thao tác Dùng công c Element Selection, ta có th ch n th ng vào i tư ng c n thay i. ch n nhi u i tư ng, ta è phím Control trong khi ch n các i tư ng ho c kéo rê chu t ch n các i tư ng n m trong hình ch nh t xác nh b i hai i m ã ch n. Công c Power Selector l a ch n ho c lo i b nhi u i tư ng cùng lúc tuỳ theo các ch ưc Dùng ch n. Khi ch n công c này, thanh tool setting s có d ng: Các ch s d ng là: Tool Tùy ch n setting i tư ng m t Individual — Ch n t ng • i tư ng trong vùng kéo chu t Block Inside — Ch n t t c các • Method i tư ng n m trên ư ng th ng c t qua chúng Line — Ch n các • Add — Ch n thêm vào • Subtract — B ch n (deselect) • Mode i tư ng Invert — o l i tr ng thái ch n ho c b ch n (ch n các • ang không ư c ch n và b các i tư ng ang ư c ch n) 19
  20. 3. CÔNG C FENCE Thanh công c Fence bao g m các công c dùng t, thay i, d ch chuy n và xóa n i dung c a fence (m t vùng cho phép thao tác ng th i v i nhi u i tư ng tùy theo n i dung c a fence. Thanh công c fence có d ng: Trong ó Ch c năng Công c t fence Place Fence D ch chuy n các i m trên fence Modify Fence i tư ng ư c fence Thao tác v i các Manipulate Fence Contents Xóa n i dung c a fence Delete Fence Contents i tư ng trong fence Drop các Drop Complex Status of Fence Contents t fence Tool Setting Ch c năng Khi Fence Type là: Block, Shape, ho c Circle — V fence như v các i tư ng ha • Fence Type (from) Element, From View, ho c From Design File — • ư c ch n t fence theo các ch i tư ng ư c fence (n i dung fence). t các ch thao tác i v i các Fence Mode i tư ng s ư c thao tác v i fence Xem: xác nh các Block Shape 20

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản