intTypePromotion=1

Giáo trình Autodesk Inventor toàn tập

Chia sẻ: Trần Đức Tài | Ngày: | Loại File: DOC | Số trang:118

0
955
lượt xem
276
download

Giáo trình Autodesk Inventor toàn tập

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Autodesk Inventor là một trong những bộ phần mềm chuyên dùng của hãng Autodesk. Là phần mềm được xây dựng với công nghệ thích nghi (adaptive technology) cùng với các khả năng mô hình hóa solid, sử dụng chủ yếu trong lĩnh vực thiết kế cơ khí và kỹ thuật. Giáo trình Autodesk Inventor toàn tập sẽ giúp người đọc có những hiểu biết về phần mềm hữu ích này và sử dụng nó thuần thục.

Chủ đề:
Lưu

Nội dung Text: Giáo trình Autodesk Inventor toàn tập

  1. LỜI NÓI ĐẦU Trong lĩnh vực máy tính hỗ trợ thiết kế (CAD – Computer Aided Design), phần mền được sử dụng phổ biến để thiết kế trong các lĩnh vực cơ khí, kiến trúc xây dựng, công trình, kỹ thuật giao thông, trang trí nội thất …ở Việt Nam cũng như trên thế giới là AutoCAD của hãng Autodesk, AutoCAD đã trở thành công cụ không thể thiếu được trong thiết kế và sản xuất tại số cơ quan, doanh nghiệp. Cùng với AutoCAD, hàng loạt phần mềm CAD khác của Autodesk đã ra đời, cập nhật nhanh chóng các kỹ thuật hiện đại đồng thời đáp ứng rất kịp thời nhu cầu đa dạng và không ngừng phát triển của công tác thiết kế. Ta có thể thiết kế mô hình ba chiều trên các hệ thống CAD/ CAM khác nhau, trong những năm gần đây phần mềm Autodesk Inventor (AI) được sử dụng rộng rãi trên thế giới và Việt Nam. Ngoài các công nghệ dùng trong MDT, chúng ta còn gặp kỹ thuật mới duy nhất có trong AI, là công nghệ thiết kế thích nghi (Adaptive Technology). Với công nghệ này và hàng loạt giải pháp độc đáo trong mô hình hóa hình học, AI đặc biệt có thế mạnh về tạo lập và quản lý các mô hình lắp ráp lớn. Các mô hình ba chiều thể hiện các ý tưởng thiết kế, là mối giao tiếp giữa các thành viên trong nhóm thiết kế và giữa người tiêu dùng với ý tưởng thiết kế. Autodesk Inventor là công cụ hỗ trợ đắc lực cho quá trình đào tạo kỹ sư cơ khí: tạo mô hình thật, tính toán chi tiết máy, hình ảnh thật, phân tích động học, động lực học, phân tích phần tử hữu hạn… Tài liệu biên soạn cho việc sử dụng phiên bản Autodesk Inventor 9.0 gồm 10 chương, giới thiệu hầu như toàn bộ các lệnh liên quan đến mô hình hoá chi tiết. Tác giả xin chân thành cảm ơn các ý kiến đóng góp, phê bình những thiếu xót của tài liệu nhằm giúp cho việc nâng cao chất lượng tài liệu. 1
  2. MỤC LỤC Lời nói đầu Chương 1. Giới thiệu chung về Autodesk Inventor 1.1. Tổng quan về Autodesk Inventor 1.2. Các tiện ích. 1.3. Giao diện người dùng 1.4. Hệ thống file đề án (Projects) 1.5. Xuất nhập dữ liệu. Chương 2. Công cụ vẽ phác trong không gian 2 chiều 2.1. Đối tượng sử dụng Autodesk Inventer 2.2. Các khái niệm ban đầu 2.3. Giao diện của Autodesk Inventer 2.4. Hệ thống file Projects 2.5. Trao đổi dữ liệu với AutoCAD và Mechanical Desktop 2.6. Hệ thống trợ giúp Chương 3. vẽ phác trong không gian 3 chiều 3.1. Khái niệm về phác thảo 3D 3.2. Các tiện ích 3.3. Trình tự làm việc. 3.4. Phác thảo các đường dẫn 3D 3.5. Tạo uốn cong trong các đường dẫn 3D 3.6. Định vị trí cho các đường dẫn 3D 3.7. Các công cụ 3D Sketch Chương 4. Thiết kế mô hình chi tiết 4.1. Giới thiệu chung 4.2. Các tiện ích 4.3. Tạo lập các chi tiết mới 4.4. Tạo các Feature cơ sở 4.5. Quan sát các chi tiết 4.6. Chỉnh sửa các Feature 4.7. Các công cụ tạo mô hình chi tiết Chương 5. Chỉnh sửa Base Solids 5.1. Giới thiệu chung 5.2. Các tiện ích 2
  3. 5.3. Thao tác với Base solids 5.4. Các công cụ chỉnh sửa Base Solid Chương 6. Thiết kế chi tiết kim loại tấm 6.1. Giới thiệu chung 6.2. Các tiện ích 6.3. Môi trường thiết kế kim loại tấm 6.4. Thiết lập kiểu kim loại tấm Sheet Metal Styles 6.5. Các lệnh hỗ trợ thiết kế kim loại tấm 6.6. Các công cụ thiết kế kim loại tấm Chương 7. Lắp ráp các chi tiết 7.1. Giới thiệu chung 7.2. Các tiện ích 7.3. Các lệnh hỗ trợ lắp ráp Chương 8: Quan sát trình diễn 8.1. Giới thiệu chung 8.2. Các tiện ích 8.3. Các công quan sát trình diễn 8.4. Các công cụ trình diễn quá trình tháo lắp Chương 9: Xây dựng bản vẽ hai chiều 9.1. Giới thiệu chung 9.2. Các tiện ích 9.3. Trình tự thực hiện 9.3. Trình tự thực hiện Kết Luận CHƯƠNG 1. GIỚI THIỆU CHUNG VỀ AUTODESK INVENTOR 3
  4. Autodesk Inventor là một trong những bộ phần mềm chuyên dùng của hãng Autodesk. Là phần mềm được xây dựng với công nghệ thích nghi (adaptive technology) cùng với các khả năng mô hình hóa solid, sử dụng chủ yếu trong lĩnh vực thiết kế cơ khí và kỹ thuật. Autodesk Inventor trang bị những công cụ mạnh, thông minh, quản lý các đối tượng thông minh, trợ giúp quá trình thiết kế, làm tăng năng suất và chất lượng thiết kế. Autodesk Inventor cung cấp các công cụ cần thiết để thực hiện các bản vẽ thiết kế, từ việc vẽ phác ban đầu cho đến việc hình thành các bản vẽ kỹ thuật cuỗi cùng. 1.1. Tổng quan về Autodesk Inventor. Autodesk Inventor có các công cụ tạo mô hình 3D, quản lý thông tin, làm việc nhóm và các hỗ trợ kỹ thuật. Ta có thể sử dụng Autodesk Inventor để thưc hiện các công việc sau: - Xây dựng các mô hình 3D và các bản vẽ 2D. - Xây dựng các chi tiết thích nghi, các chi tiết và các bản vẽ lắp. - Quán lý các chi tiết và mô hình lắp ghép với số lượng lớn các chi tiết. - Nhập các file SAT, STEP, AutoCad, Autodesk Mechanical Desktop và các file IGES. - Làm việc nhóm với nhiều thành viên trong quá trình xây dựng mô hình. 1.2. Các tiện ích. Dưới đây là tổng quan về một số tiện ích dùng trong tạo mô hình, quản lý tài liệu, công cụ hỗ trợ và học tập. 1.2.1. Tiện ích tạo mô hình. Không giống như các công cụ tạo mô hình solid truyền thống khác, Autodesk Inventor được phát triển chuyên cho thiết kế cơ khí. Nó cung cấp những công cụ thuận tiện cho thiết kế mô hình chi tiết. - Derived Parts: Tạo một chi tiết dẫn xuất từ một chi tiết khác. Dùng Derived Parts để khảo sát các bản thiết kế hay các quá trình sản xuất khác nhau. - Solid modeling: Tạo các đối tượng hình học phức hợp bằng khả năng tạo mô hình lai, tích hợp các bề mặt với các Solid. Autodesk Inventor sử dụng công cụ mô hình hóa hình học mới nhất ACIS. - Sheet Metal: Tạo các đối tượng và chi tiết từ kim loại tấm bằng cách sử dụng các công cụ tạo mô hình chi tiết và các công cụ chuyên cho thiết kế chi tiết từ kim loại tấm, như uốn (Bend), viền mép (Hem), gờ (Flange), mẫu phẳng (flat pattern). - Adaptive Layout: Dùng các Work Feature (mặt, trục, điểm) để lắp các "chi tiết" 2D với nhau. Nó có thể được dùng để khảo sát và hợp lý hóa cụm lắp trước khi chính thức chuyển thành mô hình 3D. 4
  5. - Adaptive parts and assemblies: Tạo các chi tiết và các mối lắp thích nghi. Chi tiết thích nghi có thể thay đổi theo chi tiết khác. Ta có thể chỉnh sửa các chi tiết ở bất kỳ vị trí nào trên mô hình và theo bất kỳ thứ tự nào chứ không nhất thiết phải theo thứ tự tạo lập ban đầu. - Design Elements: Truy cập và lưu trữ các đối tượng trong một Catalog điện tử để có thể sử dụng lại được. Có thể định vị, chỉnh sửa chúng. - Collaborative engineering: Môi trường cho nhóm có nhiều người cùng làm việc với một cụm lắp. Nó cho phép giảm thời gian thiết kế mà không cần hạn chế năng lực làm việc của mỗi cá nhân. 1.2.2. Tiện ích quản lý thông tin. Tạo mô hình mới chỉ là bắt đầu quá trình thiết kế. Autodesk Inventor còn cung cấp các công cụ giao tiếp hiệu quả. - Projects: Duy trì sự liên kết giữa các files. Tổ chức các files trước khi thiết kế, sao cho Autodesk Inventor xác định đường dẫn của các files và có thể tham chiếu đến các file đó và các file mà chúng tham chiếu đến. - Quản lý bản vẽ: Cho phép tạo các bản vẽ nhờ các công cụ đơn giản hóa quá trình. Các bản vẽ được tạo và quản lý theo các tiêu chuẩn ANSI, BSI, DIN, GB, ISO, JIS , kể cả các tiêu chuẩn riêng của hãng. - Design Assistant: Tìm kiếm chi tiết theo các thuộc tính như: mã số chi tiết, vật liệu,… Tạo báo biểu trong và ngoài môi trường Autodesk Inventor. - Engineer's Notebook: Truy cập, ghi chú thông tin thiết kế và gắn với các đối tượng, cho phép lưu giữ thông tin về quá trình thiết kế. 5
  6. 1.2.3. Hệ thống hỗ trợ thiết kế. Autodesk Inventor có một hệ thống hỗ trợ thiết kế (Design Support System - DSS) hợp nhất, tiện lợi và hiệu quả. Hệ thống hỗ trợ thiết kế là sự kết hợp giữa các thông tin và giữa các công cụ hỗ trợ giao tiếp. Hệ thống hỗ trợ thiết kế bao gồm: Help Topics, What’s New, Tutorials, Design Doctor, Visual Syllabus và Autodesk Online. 1.2.3.1. Help Topics Cho phép ta tra cứu các lệnh trong Autodesk Inventor bằng cách nhập từ khóa vào ô Type in the keyword to find của trang Index. Hình 1.1. Hộp thoại Help Topics 1.2.3.2. What’s New Xác định chủ đề và học các phần mớitrong phiên bản này. Hình 1.2. Hộp thoại What’s New 6
  7. 1.2.3.3. Tutorials Hướng dẫn từng bước cụ thể với các mô hình mẫu, mô hình lắp ráp hoặc các bản vẽ kỹ thuật. Dựa vào đây người vẽ hình dung được công việc của từng lệnh. Hình 1.3. Hộp thoại Tutorials 1.2.3.4. Design Doctor Khảo sát và sửa chữa các lỗi mắc phải khi xây dựng mô hình. Các lỗi đ ược gạch đỏ trong của sổ màn hình. Hình 1.4. Hộp thoại Design Doctor 1.2.3.5. Visual Syllabus Chọn đối tượng và xem quá trình hình thành các đối tượng bằng hình ảnh rất cụ thể. Từ việc tạo mô hình solid, tạo kim loại tấm, các chi tiết lắp ghép, phần diễn hoạt và tạo các bản vẽ kỹ thuật đều được chỉ dẫn, minh họa bằng hình ảnh. Hình 1.5. Hộp thoại Visual Syllabus 7
  8. 1.2.3.6. Autodesk Online Ta có thể truy cập vào trang Web của hãng Autodesk để tìm hiểu thông tin về phần mềm và các thông tin của hãng. Hình 1.6. Hộp thoại Autodesk Online 8
  9. 1.3. Giao diện người dùng. Giao diện với người sử dụng trong Autodesk Inventor gồm hai phần chính: - Application Window: cửa sổ ứng dụng xuất hiện khi Autodesk Inventor được mở ra. - Graphics Window: cửa sổ đồ hoạ hiển thị khi một file được mở. Nếu có nhiều file cùng được mở thì file đang làm việc sẽ nằm trên cửa sổ hiện hành. 2D Precise Standard Menu Sketch Input Toolbar Toolbar Toolbar Browser bar Graphic Window Status bar Hình 1.7. Giao diện người dùng của Inventor 9.0 1.3.1. Cửa sổ duyệt (Browser). Browser hiển thị kết cấu dạng nhánh cây của các chi tiết, các cụm lắp và các bản vẽ trong file đang hoạt động. Mỗi môi trường có Browser riêng của mình. Hình bên minh họa Browser trong môi trường lắp ráp và thanh công cụ của nó. Hình 1.8. Cửa sổ Browser 9
  10. 1.3.2. Các lệnh và các công cụ. Autodesk Inventor sử dụng các thanh công cụ (Toolbar) kiểu Windows và Panel của Autodesk Inventor. Các Toolbar có thể kéo đến các vị trí khác nhau. Autodesk Inventor chỉ cho hiện các Toolbar thích hợp với môi trường đang hoạt động. Các môi trường dùng chung một số phím hay công cụ chung, như New hoặc Help, nhưng cũng có bộ công cụ riêng của mình. Autodesk Inventor sử dụng panel bar để gọi lệnh tư ơng ứng với môi trường và cửa sổ đồ hoạ hiện hành. Dưới đây là thanh công cụ 2D Sketch Panel và Features, được hiển thị trong môi trường thiết kế 2D và mô hình chi tiết. Hình 1.9. Thanh công cụ 2D Sketch Panel và Features Để định vị thanh công cụ, kéo nó lên đỉnh, xuống đáy hay sang cạnh của cửa sổ ứng dụng. Để bật hoặc tắt thanh công cụ, chọn View -> Toolbar hoặc chọn Tool- >Customize-> Toolbars. Các công cụ chỉ mở các hộp thoại khi cần thiết. Ví dụ: Khi kích chuột vào một công cụ Sketch, ta có thể vẽ ngay. Nhưng khi kích vào một công cụ trong Feature thì sẽ hiện ra hộp hội thoại. Kích công cụ sketch ... Kích công cụ Feature và điền thông tin ... và bắt đầu vẽ Hình 1.10. Công cụ và hộp thoại 10
  11. Khi làm việc với Autodesk Inventor ta có thể chọn đối tượng trước sau đó kích chuột để chọn công cụ cần tác động lên đối tượng chọn hoặc chọn công cụ trước, sau đó chọn đối tượng. Chọn công cụ trước ... Hoặc Chọn đối tượng trước ... ... rồi chọn đối tượng ... rồi chọn công cụ Hình 1.11. Lựa chọn mặt chi tiết trong cửa sổ đồ hoạ 1.3.3. Menu ngữ cảnh. Hiển thị khi kích chuột phải. Tùy thuộc vào kích chuột ở đâu và vào lúc nào mà ta có thể thấy các tuỳ chọn, xác định công việc đang thực hiện. Hình bên là một ví dụ về menu ngữ cảnh trong môi trường sketch. Hình 1.12. Menu ngữ cảnh trên màn hình đồ hoạ 1.3.4. Sketch và các chế độ lựa chọn. Ta sử dụng chế độ Select hay chế độ Sketch để thông báo cho Autodesk Inventor biết, ta muốn chọn đối tượng hay muốn tạo biên dạng phác thảo. Khi mở file chi tiết lần đầu Autodesk Inventor tự động kích hoạt chế độ Select và chế độ tạo phác thảo 2D. Ta có thể điều khiển chế độ Sketch và các chế độ Select bằng các nút trên thanh nút lệnh. Nút chế độ sketch mở rộng Nút chế độ select mở rộng Hình 1.13. Các chế độ lựa chọn và Sketch 11
  12. 1.3.5. Các biểu tượng con trỏ. Khi chúng ta dùng Autodesk Inventor các biểu tượng nhỏ thường hiển thị bên cạnh con trỏ. Những biểu tượng này nói lên các thao tác hoặc chức năng trong quá trình thực hiện. 1.3.6. Các file mẫu (Templates). Autodesk Inventor cung cấp các mẫu cho 4 kiểu file trong Autodesk Inventor: Part, Assembly, Presentation và Drawing. Các file Part cũng có thể được sử dụng cho các Catalog và các chi tiết từ kim loại tấm (Sheet Metal). Phần mở rộng và biểu tượng của của các file này được mô tả như dưới đây. Hình 1.143. Các file mẫu Các thẻ Default, English và Metric chứa đựng các mẫu file với đơn vị đo và tiêu chuẩn vẽ tương ứng. Đơn vị đo và tiêu chuẩn dùng trong mẫu Default được chọn khi cài đặt Autodesk Inventor. 1.4. Hệ thống file đề án (Projects). Trong Autodesk Inventor ta dùng Projects để quản lý các File. Một Project bao gồm một Folder xác định, một hoặc vài Project Home Folder, vị trí vùng làm việc (Workspace Loaction) và các Folder chứa các File được liên kết tới Project. - Projects Folder: Chứa các Shortcut tới các file trong Project Home Folder. Ta chỉ có một Projects Folder duy nhất. - Project Home Folder: Chứa đựng một file (.ipj), xác định đường dẫn tới các Folder chứa đựng tất cả các file liên kết tới Project. Ta có một Project Home Folder cho mỗi Project được Setup. Các Shortcut tới các Project Home Folder này chứa đựng trong Projects Folder. - Workspace: Xác định vị trí đầu tiên ta làm việc với Project. Mỗi một Project có một Workspace. Ta thường ghi các File mới vào trong Workspace. - Các file liên kết tới Project: Có thể là các File cục bộ hoặc trên mạng, được liên kết tới hoặc đựơc tham chiếu tới Project. Các đường dẫn tới các File này được chứa đựng trong file .ipj trong Project Home Folder. Khi sử dụng các Project, Autodesk Inventor luôn luôn có thể tìm tất cả các file và các file tham chiếu đến. Sử dụng Project ta có thể: - Thiết đặt Project bất kỳ khi nào. - Thiết đặt chế độ đa Project. - Làm việc với các bộ phận khác nhau của một cụm lắp trong cùng một thời điểm. 12
  13. - Chia sẻ thư viện chuẩn và thư viện người dùng. - Chia sẻ các file với một nhóm làm việc. 1.4.1. Thiết đặt Projects Folder Mặc dù ta có thể tạo các File mà không thiết đặt Project Folder, tuy nhiên ta nên thiết đặt Project trước. Trước khi tạo một nhóm các File ta cần tổ chức chúng vào trong một Project và tạo các Folder cần thiết. Để thiết đặt một Project Folder: kích chuột vào Tools -> Application Options. Trong General Tab của hộp thoại Projects Folder, chọn một vị trí. Vị trí này, sau khi thiết đặt ta thường không thay đổi. 1.4.2. Tạo Project mới Có 2 phương pháp mở một cửa sổ Projects trong hộp thoại Startup của Autodesk Inventor. Khi mở một môi trường làm việc của Autodesk Inventor, hộp thoại Startup đưa ra các tùy chọn cho Project. Khi kích vào mục Projects, cửa sổ Projects được mở. Ta cũng có thể chọn menu File -> Projects để cửa sổ Projects. Ta dùng hộp thoại New Project Wizard để tạo một Project mới. Để tạo một Project mới: Trong hộp thoại Startup, kích chuột vào Projects hoặc chọn menu File -> Projects. Kích phải vào cửa sổ Project, chọn New hoặc kích phím New. Sau đó thực hiện các bước do hộp thoại New Project Wizard hướng dẫn, như xác định: - Đó là Project mới hay một Workspace riêng của nhóm project có trước? - Project sẽ sử dụng các File của Autodesk Inventor sẵn có hay các File mới? Ta còn phải xác định: - Tên Project - Vị trí cuả Project Home Folder. - Vị trí của File cho Workspace. - Vị trí File của nhóm Projects nếu đó là một nhóm các Project. - Các thư viện tiêu chuẩn và các thư viện người dùng chứa trong Project. FIle Shortcut dẫn đến Project (.ipj) sẽ được tự động ghi vào Ptoject Home Folder. 1.4.3. Mở Project có sẵn Dùng cửa sổ Select a project file để mở một project có sẵn. Khi mở hộp thoại StartUp sẽ cung cấp các tuỳ chọn Project cần mở và chọn file project trong cửa sổ. Vùng phía trên của cửa sổ Project liệt kê các Folder Project có sẵn. Các folder Project chứa các đường dẫn tới tất cả các file của Project. Vùng thấp hơn của cửa sổ chứa đựng các thông tin về định vị của Project đã được lựa chọn trong phần phía trên của cửa sổ. ở đây ta có thể chọn một kiểu định vị sau đó kích đúp chuột vào đường dẫn của định vị đó để tìm file Project. Hiển thị các Project - Chọn một file Project trong cửa sổ: 13
  14. Trong hộp thoại StartUp kích đúp chuột vào Projects hoặc chọn File > Projects. Mở một file Project có sẵn: Chọn một project trong vùng phía trên của cửa sổ Project sau đó chọn một đường dẫn trong vùng phía dưới của cửa sổ. Kích đúp vào một đường dẫn file project. Các file trong vùng định vị này sẽ được liệt kê trong hộp thoại Open, kích đúp vào tên file cần mở. Thay đổi các project: Trong cửa sổ Select a project file chọn một project khác và kích chuột vào nút Apply. Khi thay đổi từ một Project tới một Project khác ta cũng có thể thay đổi nơi mà Autodesk Inventor tìm các file. Ta không thể thay đ ổi project khi file đang mở. Xác định các kiểu đường dẫn: Autodesk Inventor sử dụng các đường dẫn tắt trong các Project Folder để định vị và kích hoạt các file Project khác nhau, theo một giao thức nhất định. Khi mở một file Project (.ipj), Autodesk Inventor sử dụng các đường dẫn xác định file Project hiện hành để tìm các file thành phần. Đối với mỗi file thành phần hệ thống sẽ dựa trên đường dẫn để tìm kiếm cho đến khi tìm thấy nó. Ta có thể ưu tiên các đường dẫn tìm kiếm để tăng nhanh quá trình tìm kiếm các file. Một Project có thể được chỉ rõ qua 4 kiểu đường dẫn tìm kiếm: Work space, Local, Workgroup và Library. Một file Project nhất thiết phải có đường dẫn tìm kiếm Workspace và có thể có một vài đường dẫn tìm kiếm khác trong số các đường dẫn tìm kiếm còn lại. Hình 1.15. Quản l ý dự án 14
  15. Một Project có thể được chỉ rõ qua 4 kiểu đường dẫn tìm kiếm: Work space, Local, Workgroup và Library. Một file Project nhất thiết phải có đường dẫn tìm kiếm Workspace và có thể có một vài đường dẫn tìm kiếm khác trong số các đường dẫn tìm kiếm còn lại. + Workspace: Định vị mặc định cho các file. Nếu tất cả các file của Project đã được định vị trong một vị trí, vị trí này chỉ có thể là đường vào của file Project. Nếu ta làm việc trong một nhóm thiết kế, Workspace nhận ra vùng làm việc riêng của từng người. + Local: Vùng file bổ sung. Các vùng này có thể ở trên máy tính cá nhân hoặc trên một Network. + Workgroup: Dùng chung các vùng trên mạng để tham chiếu các file. Các vùng Workgroup được dùng chủ yếu khi ta làm việc trong các nhóm thiết kế. + Library: Các vùng cho các chi tiết chuẩn hoặc các thư viện được đặt tên khác. Đường dẫn này sẽ được Autodesk Inventor tìm trước tiên. Các chi tiết tiêu chuẩn như đinh ốc hoặc các chi tiết đòn bẩy có thể chiếm 50-60% của một lắp ráp. Khi các chi tiết này không thay đổi một cách thường xuyên thì chúng nên đặt trong các thư viện. Chỉ có một yếu tố để nhận ra một chi tiết trong thư viện hay một chi tiết khác đó là vùng mà file đó đ ược xác đ ịnh là đường dẫn tới thư viện. File lắp ráp nhận ra khi chèn một chi tiết lấy từ trong thư viện và kiểm tra cho lần mở file tiếp theo. Nếu hệ thống không tìm thấy file thì nó sẽ hiển thị hộp thoại Resolve Link khi đó ta có thể chỉ dẫn tới file đó. Từ đó hệ thống sẽ kiểm tra vùng thư viện trước tiên, có thể tăng nhanh quá trình mở file bằng cách chuyển các chi tiết tiêu chuẩn đến đường dẫn thư viện. Đối với những chi tiết khác, trước tiên hệ thống sẽ kiểm tra Workspace sau đó đến các đường dẫn tới vùng các file khác (Local path), tiếp đến các đường dẫn workgroup. Nếu file không được tìm thấy thì Autodesk Inventor sẽ tìm những folder mà chứa file Project sau đó hiển thị hộp thoại Resolve Link khi đó ta có thể tìm file này. - Tìm các file: Hộp thoại Resolve Link có một trường để xác định đường dẫn tìm kiếm. Khi tìm một file đơn giản ta chỉ cần kích chuột vào Path name sau đó đường dẫn tới file được nhập vào trường Look in. Nếu không tìm thấy file kích chuột vào Skip để tiếp tục nạp các ràng buộc. Nếu kích chuột vào Skip All h ệ thống sẽ không nạp những ràng buộc với các file bị lỗi. 1.5. Xuất nhập dữ liệu. Có thể nhập các file dạng SAT, STEP và các file AutoCAD, Mechanical Desktop để dùng trong Autodesk Inventor. Ta cũng có thể ghi các file Part và file Assembly trong Autodesk Inventor thành một vài dạng file khác. Có thể ghi các file 15
  16. bản vẽ của Autodesk Inventor như là các file DXF hoặc các file(DWG) của AutoCAD. Ghi chú: Các file Mechanical Desktop có thể được liên kết tới các cụm lắp mà không cần nhập vào môi trường Autodesk Inventor. 1.5.1. Các file AutoCAD: Có thể nhập một bản vẽ AutoCAD (.dwg) thành một phác thảo của chi tiết, một bản vẽ, hoặc một bản vẽ phác thảo. Ta cũng có thể xuất một bản v ẽ của Autodesk Inventor thành một bản vẽ của AutoCAD và có thể chỉnh sửa được. - Nhập bản vẽ AutoCAD (.dwg) thành một sketch: Mở Autodesk Inventor part file hoặc drawing file và kích hoạt chế độ sketch. Kích chuột vào File->Open sau đó chọn file bản vẽ AutoCAD (*. dwg) từ danh sách các kiểu file (Files of Type list). Duyệt và chọn file sau đó kích chuột vào Open. Trong hộp thoại chọn AutoCAD Drawing Data sau đó chọn đơn vị đo thích hợp. Kích chuột vào nút >> để chọn thêm các tuỳ chọn cho nhập file và kích chuột vào OK. Công cụ chuyển đổi sẽ thực hiện chuyển các đối tượng (entity) từ mặt phẳng XY của không gian mô hình và đặt chúng trong môi trường sketch. Một vài đối tượng như splines không thể chuyển đổi được. - Nhập bản vẽ AutoCAD (*.dwg) thành một bản vẽ trong Autodesk Inventor : Mở Autodesk Inventor Drawing file. Chọn File->Open sau đó chọn file bản vẽ AutoCAD Drawing (*. dwg) từ danh sách các kiểu file (Files of Type list). Duyệt và chọn file cần nhập, sau đó kích chuột vào Open. - Xuất dữ liệu ra môi trường AutoCAD: Chọn File -> Save Copy As sau đó chọn AutoCAD Drawing (*. dwg) từ Save as Type list (danh sách các dạng file ghi ra).. Nhập tên file và kích chuột vào Option để chọn các tuỳ chọn thích hợp khi ghi sau đó kích chuột vào Save. Công cụ chuyển đổi sẽ tạo ra một bản vẽ AutoCAD mới và chuyển toàn bộ vào chế độ paper space của file DWG. Nếu trong bản vẽ của Autodesk Inventor có nhiều Sheet thì mỗi sheet được ghi thành một file Dwg riêng. Các đối tượng được xuất ra dwg trở thành các đối tượng của AutoCAD, bao gồm cả các kích thước. 1.5.2. Các file Mechanical Desktop: Autodesk Inventor có thể hiểu các chi tiết hoặc các cụm lắp trong Mechanical Desktop. Ta có thể nhập một file Mechanical Desktop dưới dạng một ACIS body hoặc là chuyển đổi hoàn toàn. Các feature mà được hỗ trợ trong Autodesk Inventor thì sẽ được nhận dạng. Các feature không được hỗ trợ trong Autodesk Inventor thì sẽ không được nhận dạng. Nếu Autodesk Inventor không thể nhận ra một feature thì nó sẽ bỏ qua feature đó đồng thời đưa ra thông báo trong Browser và hoàn thành việc nhận dạng. - Nhập một file Mechanical Desktop: Chọn File->Open sau đó chọn AutoCAD Drawing(*.dwg) từ danh sách các kiểu file. Duyệt và chọn file sau đó kích chuột 16
  17. vào Open. Trong hộp thoại Open DWG File chọn tuỳ chọn Mechanical Desktop Part/assembly sau đó chọn đơn vị đo thích hợp. Kích chuột vào nút >> để lựa chọn thêm các tuỳ chọn khác cho việc nhập file. Kích chuột vào OK Autodesk Inventor sẽ chuyển đổi và mở một file Autodesk Inventor. Ghi chú: Để nhập dữ liệu mô hình từ các chi tiết hoặc các cụm lắp trong Mechanical Desktop thì Mechanical Desktop phải được cài đặt và đang chạy trên hệ thống. 1.5.3. Các file SAT: Các file SAT chứa các solid không tham số. Chúng có thể là các Boolean solid hoặc những solid tham số với các mối quan hệ đã bị loại bỏ. Một SAT file có thể được dùng trong một cụm lắp. Có thể bỏ sung các feature tham số tới solid cơ sở. - Nhập một file SAT (*.sat): Chọn File -> Open sau đó chọn các SAT file từ danh sách dạng file ( File of Type list). Duyệt và chọn file sau đó kích chuột vào nút Option để đặt đơn vị đo cho file đó. Kích chuột vào Open, Autodesk Inventor sẽ chuyển đổi và mở file mới. Nếu một file SAT chứa một thực thể đơn thì nó sẽ xuất ra một file chi tiết Autodesk Inventor với một chi tiết đơn. Nếu file chứa đựng nhiều thực thể nó sẽ xuất ra một file lắp ráp có cụm lắp với nhiều chi tiết. - Để xuất ra một file SAT: Chọn File->Save Copy As sau đó chọn SAT file từ danh sách các kiểu file (Save as Type list). 1.5.4. Các file STEP: Các file STEP là một định dạng chuẩn quốc tế được phát triển và khắc phục một vài hạn chế của các chuẩn chuyển đổi dữ liệu. Những cố gắng trong việc phát triển các chuẩn đã mang lại kết quả trong việc phân chia các định dạng như IGES (Mỹ), VDAFS (Đức) hoặc IDF ( cho các bảng mạch). Những chuẩn đó không thích ứng với nhiều sự phát triên trong các hệ thống CAD. Công cụ chuyển đổi STEP cho Autodesk Inventor được thiết kế cho việc giao tiếp, chuyển đổi một cách tin cậy cho các hệ thống CAD khác. - Để nhập một file STEP (*.stp,*.ste,*.step): Chọn File-> Open sau đó chọn file STEP trong danh sách các dạng file (File of Type). Chọn file cần nhập sau đó kích chuột vào Open. Autodesk Inventor sẽ chuyển đổi và mở file mới. Công cụ chuyển đổi STEP chỉ chuyển đổi các solid 3D, Part và các cụm lắp. Các bản vẽ, text, wireframe và các dữ liệu bề mặt không được xử lý bằng công cụ chuyển đổi STEP. Nếu một file STEP chứa một part nó sẽ xuất sang Autodesk Inventor một file part. Nếu nó chứa cụm lắp nó sẽ xuất ra một file Assembly có nhiều chi tiết. - Để xuất một file STEP: Chọn File->Save Copy As và sau đó chọn STEP file từ danh sách các dạng file (Save as Type list). Chi tiết và cụm lắp sẽ đ ược chuy ển đổi thành dạng STEP. Bản vẽ và các thuộc tính như vật liệu sẽ không được xử lý qua công cụ chuyển đổi STEP. 17
  18. 1.5.5. Các file IGES: Các file IGES là chuẩn của Mỹ. Rất nhiều bộ phần mềm NC/CAM yêu cầu định dạng file theo chuẩn IGES. Vì IGES không thân thuộc trong định dạng cho các dữ liệu mô hình solid, Autodesk Inventor chỉ hỗ trợ cho việc xuất ra các file IGES. - Để xuất ra file IGES (*.igs,*.ige,*.iges): Chọn File -> Save Copy As sau đó chọn dạng file IGES từ danh sách các dạng file (Save as Type list). Kích chuột vào Option sau đó chọn Solid or Surface data. Định vị trí cho file và nhập vào tên file sau đó kích chuột vào Save. 18
  19. CHƯƠNG 2. CÔNG CỤ VẼ PHÁC TRONG KHÔNG GIAN 2 CHIỀU Sketch (phác phảo) là bước đầu tiên để tạo dựng chi tiết. Sketch là biên dạng của Feature và các đối tượng hình học khác như việc đường dẫn hoặc đường tâm quay, cần thiết để tạo Feature. Ta tạo mô hình 3D từ Sketch bằng cách kéo một biên dạng theo một đường dẫn hoặc quay một biên dạng quanh đường tâm nào đó. 2.1. Các hình dạng trong vẽ phác 2.1.1. Tạo môi trường Sketch Để bắt đầu một bản vẽ phác, mở một file chi tiết mới và chọn công cụ từ thanh công cụ 2D Sketch Panel. Sau đó thực hiện vẽ phác trong cửa sổ đồ họa. Khi một file chi tiết đã mở, có thể kích hoạt Sketch trong Browser (cửa sổ duyệt) để kích hoạt các công cụ trong môi trường Sketch. Trong quá trình vẽ phác các ký hiệu song song, vuông góc… được hiển thị khi các ràng buộc được áp đặt. Đ ể khép kín biên dạng nhấp chuột ta chọn điểm bắt đầu của biên dạng. Sau khi tạo mô hình từ Sketch ta có thể trở lại môi trường Sketch để chỉnh sửa hoặc bổ sung thêm Sketch mới cho Feature. Hình 2.1. Tạo phác thảo 2D Sau khi Sketch được tạo ra, biểu tượng Sketch xuất hiện trong Browser. Khi tạo Feature từ Sketch, biểu tượng Feature xuất hiện trong Browser, bên trên biểu tượng Sketch tương ứng. Khi trỏ vào biểu tượng Sketch trong Browser, Sketch tương ứng trong cửa sổ đồ hoạ sẽ đổi màu. Để chỉnh sửa Sketch, kích đúp vào biểu tượng của nó trong Browser. 2.1.2. Các loại hình học trong vẽ phác Có hai loại hình học vẽ phác: Normal và Construction Khi bắt đầu tạo đối tượng hình học mới, nên chọn loại hình học cho đối tượng này bằng danh sách Style nằm trên thanh công cụ Inventor Standard hoặc thanh công cụ Drawing Standard. Normal: là loại hình mặc định trong Autodesk Inventor, dùng để tạo các đối tượng hình học cho các lệnh EXTRUDE, REVOLVE, SWEEP,…. Construction: đối tượng được dựng hình được dùng để trợ giúp quá trình xây dựng các biên dạng vật thể. 19
  20. 2.2. Các tiện ích tạo Sketch Dynamic Autodesk Inventor tìm kiếm, hiển thị và tự động gán inference những ràng buộc khi tạo Sketch. Shared Ta có thể sử dụng một Sketch để tạo nhiều Feature Sketch hoặc nhiều biên dạng (Profile) trong một mô hình chi tiết. Constrained Ta có thể gán các ràng buộc, thay đổi kích thước của Drag Sketch và tạo các ràng buộc mới bằng cách kéo các đối tượng hình học. General Ta có thể tạo các kích thước một cách nhanh chóng và Dimension trực quan bằng nút trong thanh công cụ. Ta có thể đồng thời ghi nhiều kích thước, tạo các Auto ràng buộc cho các Sketch trong cùng một bước với số thao Dimension tác ít nhất. Hatching Ta có thể gạch mặt cắt cho các vùng trong bản vẽ. Direct Edge Ta có thể chiếu các cạnh của chi tiết lên mặt phẳng Referencing. Sketch để tạo ra Sketch mới. 2.3. Trình tự thực hiện Phần này giới thiệu tổng quan về cách tạo các Sketch. Trong trợ giúp trực tuyến (onLine) Help và Tutorials sẽ cung cấp đầy đủ thông tin, thí dụ trình diễn và các bước cụ thể. 2.3.1. Phác thảo biên dạng Mỗi một chi tiết đều được khởi tạo từ một Sketch. Môi trường Sketch được thiết lập để có thể vẽ, chỉnh sửa và hoàn thiện các Sketch một cách dễ dàng. Để tạo Sketch cho chi tiết mới ta cần thực hiện các bước sau: 1. Mở file chi tiết mới (Part). 2. Chọn công cụ (lệnh vẽ) trên thanh công cụ Sketch. 2. Kích vào cửa sổ đồ hoạ để phác thảo biên dạng. Chú ý rằng các biểu tượng (như căn vuông góc hay căn thẳng đứng) sẽ xuất hiện để gợi ý các ràng buộc có thể được gán. 4. Đóng kín đối tượng hình học bằng cách chọn điểm đầu. Khi di chuy ển chuột đến gần điểm có thể truy bắt (Snap) thì con trỏ tương ứng sẽ đổi màu. 5. Nhấn phím ESC hoặc kích SELECT để kết thúc lệnh. 20
ADSENSE
ADSENSE

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản
2=>2