intTypePromotion=3
Array
(
    [0] => Array
        (
            [banner_id] => 140
            [banner_name] => KM1 - nhân đôi thời gian
            [banner_picture] => 964_1568020473.jpg
            [banner_picture2] => 839_1568020473.jpg
            [banner_picture3] => 620_1568020473.jpg
            [banner_picture4] => 994_1568779877.jpg
            [banner_picture5] => 
            [banner_type] => 8
            [banner_link] => https://tailieu.vn/nang-cap-tai-khoan-vip.html
            [banner_status] => 1
            [banner_priority] => 0
            [banner_lastmodify] => 2019-09-18 11:11:47
            [banner_startdate] => 2019-09-11 00:00:00
            [banner_enddate] => 2019-09-11 23:59:59
            [banner_isauto_active] => 0
            [banner_timeautoactive] => 
            [user_username] => sonpham
        )

)

ứng dụng phân tích dầu bôi trơn và hạt mài mòn trong chẩn đoán kỹ thuật máy, chương 12

Chia sẻ: Tran Van Duong | Ngày: | Loại File: PDF | Số trang:15

0
87
lượt xem
25
download

ứng dụng phân tích dầu bôi trơn và hạt mài mòn trong chẩn đoán kỹ thuật máy, chương 12

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Cơ sở dữ liệu của Omnimet Image Hệ thống phân tích ảnh Omnimet bao gồm một cơ sở dữ liệu đầy đủ cho các ảnh trong kho và dữ liệu ảnh được kết nối. Ảnh và dữ liệu đã được kết nối có thể xuất vào trình soạn thảo văn bản để tạo một báo cáo chuyên nghiệp. Cơ sở dữ liệu ảnh Omnimet được sắp xếp có trật tự trong một cấu trúc hợp lô gíc. Ảnh được lưu trong một Specimen Record và Specimen được lưu trong một Project Record. Mỗi bản ghi có số đề mục và mỗi...

Chủ đề:
Lưu

Nội dung Text: ứng dụng phân tích dầu bôi trơn và hạt mài mòn trong chẩn đoán kỹ thuật máy, chương 12

  1. Chương 12 : Cơ sở dữ liệu của Omnimet Image Hệ thống phân tích ảnh Omnimet bao gồm một cơ sở dữ liệu đầy đủ cho các ảnh trong kho và dữ liệu ảnh được kết nối. Ảnh và dữ liệu đã được kết nối có thể xuất vào trình soạn thảo văn bản để tạo một báo cáo chuyên nghiệp. Cơ sở dữ liệu ảnh Omnimet được sắp xếp có trật tự trong một cấu trúc hợp lô gíc. Ảnh được lưu trong một Specimen Record và Specimen được lưu trong một Project Record. Mỗi bản ghi có số đề mục và mỗi ô số luôn sẵn sàng để thêm vào các thông tin cho việc nhận dạng ảnh. Có 6 tab trong Omnimet database là: Projects, Specimens, Images, Analyses, Fields, và Gallery a. Projects Tab
  2. Hình 3.35: Projects Tab Projects Tab tự động cho một số Project tới kho specimen, image và thông tin phân tích. Các chức năng trong Projects Tab - Jump to Record Để nhẩy tới một bản ghi project được chọn nhập giá trị vào trong ô kết nối. Giá trị của bản ghi nhập vào được hiển thị trên góc trái bên dưới của cửa sổ cơ sở dữ liệu. 1. Nhập một giá trị bản ghi vào ô kết nối trên Jump to Record 2. Nhấn nút Go - Quick Search Quick Search tìm kiếm cơ sở dữ liệu cho bất kỳ bản ghi nào để tìm một specified tiêu chuẩn nhập vào ô liên kết trên Quick Search. 1. Trên thực đơn xổ xuống, chọn Any hoặc All. 2. Nhập giá trị hoặc đặt thông số trong ô liên kết 3. Nhấn nút Off để bỏ Quick Search khỏi cơ sở dữ liệu. - Thanh cuốn Project Records Nút cuốn sẽ cuốn từng project trong cơ sở dữ liệu. - Thêm một bản ghi Project mới - Soạn thảo một Project Record
  3. - Xoá một Project Record - Copy một Project Record - Pasting a Project Record - Lưu bản ghi - Bỏ một bản ghi -Backing up Projects (sao lưu một Project hoặc chuỗi các project) -Khôi phục một Project -Tìm kiếm Project Record Using Filters Nút Filter for current table sẽ mở hộp thoại Filter cho Project Tab. -Bỏ một Project Filter Để bỏ một filter nhấn nút Remove a filter. -Report Queue Nút Open the Report Queue sẽ mở hộp thoại Report Queue Contents. -Thêm ảnh vào Report Queue Nút Add Report Queue sẽ thêm tất cả các ảnh trong project hiện hành vào Report Queue. b. Specimens Tab
  4. Hình 3.36: Specimens Tab Specimens Tab thêm specimen vào bản ghi Project. Nhiều Specimens có thể được thêm vào trong một Project. Các chức năng của Specimens Tab - Vào một bản ghi. Vào đến một bản ghi specimen được chọn nhập vào ô liên kết. Số bản ghi được hiển thị trên góc trái phía dưới của cửa sổ cơ sở dữ liệu. 1. Nhập một số bản ghi vào ô liên kết Jump To Record 2. Nhấn nút Go .
  5. - Quick Search Quick Search tìm kiếm cơ sở dữ liệu cho bất kỳ một bản ghi nào để đáp ứng một tiêu chuẩn specified nhập vào ô liên kết của Quick Search. 1. Trong thực đơn xổ xuống, chọn Any hoặc All. 2. Nhập một giá trị hoặc đặt thông số trong vùng liên kết. 3. Nhấn nút Off để bỏ Quick Search từ cơ sở dữ liệu. - Thanh cuốn Specimen Record Nút cuốn sẽ cuốn mỗi specimen trên project hiện hành. - Thêm một bản ghi Specimen mới - Soạn thảo một bản ghi Specimen - Xoá một bản ghi Specimen - Copying a Specimen Record -Pasting a Specimen Record - Tìm kiếm Specimen Record Using Filters Nút Filters for Current table sẽ mở hộp thoại Filter cho Specimen Tab. -Bỏ một Specimen Filter Để bỏ một filter nhấn nút Remove a filter - Report Queue Nút Open the Report Queue sẽ mở hộp thoại Report Queue Content. - Thêm Specimen Images vào Report Queue
  6. Nút Add to Report Queue sẽ thêm toàn bộ các ảnh của specimen hiện hành vào Report Queue. c. Image Tab Hình 3.37: Image Tab Image Tab thêm ảnh vào cửa sổ ảnh để chọn Project và Specimen trong cơ sở dữ liệu Omnimet. Các chức năng của Images Tab - Vào một bản ghi Vào một bản ghi ảnh đã lựa chọn nhập vào ô liên kết. Số bản ghi được hiển thị trên góc trái phía dưới cửa sổ cơ sở dữ liệu. 1. Nhập số bản ghi trên ô liên kết Jump To Record
  7. 2. Nhấn nút Go - Quick Search Quick Search tìm kiếm cơ sở dữ liệu cho bất kỳ bản ghi nào để nhận được một tiêu chuẩn theo danh nghĩa nhập vào vùng liên kết Quick Search 1. Trong thực đơn xổ xuống, chọn Any hoặc All. 2. Nhập một giá trị hoặc đặt thông số trong vùng liên kết. 3. Nhấn nút Off để bỏ Quick Search từ cơ sở dữ liệu. - Thanh cuốn Image Record Nút cuốn sẽ cuốn từ bản ghi ảnh trong specimen hiện hành . - Thêm ảnh và dữ liệu vào Image Tab Một ảnh có thể được thêm vào bằng cách nhấn vào nút Add Record. Nhập dữ liệu vào vùng khả nhập (vùng không bị phủ xám) và nhấn nút OK khi đã hoàn tất. Một hình ảnh nhỏ được đặt ở góc tay phải phía dưới của Image Tab. Để lưu một ảnh mới nhấn nút OK hoặc nhấn lại nút Add Record. Để huỷ bỏ toàn bộ thay đổi nhấn nút Cancel. - Soạn thảo một Image Record Để xoạn thảo một bản ghi trong Image Tab nhấn nút Record Editing hoặc chọn Edit Record từ thực đơn Database. Nhập dữ liệu vào vùng khả nhập và nhấn nút OK khi đã hoàn tất hoặc nhấn lại nút Edit. - Xoá một Image Record
  8. Để xoá một ảnh nhấn nút Delete Record hoặc chọn Delete Record từ thực đơn Database. Sẽ có hộp thoại xác nhận và phải nhấn Yes - Copy một Image Record Để copy một bản ghi ảnh nhấn nút Copy Record hoặc chọn Copy Record từ thực đơn Database. Chỉ dữ liệu nhập vào được copy. - Pasting một Image Record Để dán một Image Record nhấn nút Paste Record hoặc chọn Paste Record từ thực đơn Database. Sau khi thêm một bản ghi mới. ảnh mong muốn phải được mở trong cửa sổ ảnh trước khi thêm vào bản ghi. - Lấy lại một Image Record Để mở một ảnh nhấn nút Open Record. ảnh sẽ xuất hiện trên cửa sổ ảnh. - Search Image Records Using Filter Nút Filter for current table sẽ mở hộp thoại Filter cho Image Tab - Bỏ một Image Filter Để bỏ một filter nhấn vào nút Remove a filter - Report Queue Nút Open the Report Queue sẽ mở hộp thoại Repord Queue Contents - Thêm ảnh vào Report Queue Nút Add to Report Queue sẽ thêm ảnh hiện thời vào Report Queue. d. Analyses Tab
  9. Hình 3.38 : Analyses Tab Analyses Tab chứa dữ liệu phân tích từ tuyến, các phép đo bằng tay và kiểm tra độ cứng và tự động xuất ra file Excel. Các chức năng của Analyses Tab - Nhảy tới một Record Nhảy tới một bản ghi phân tích được lựa chọn nhập vào vùng liên kết. Số bản ghi được hiển thị trên góc trái của cửa sổ cơ sở dữ liệu. 1. Nhập số bản ghi trên ô liên kết Jump To Record 2. Nhấn nút Go . - Quick Search
  10. Quick Search dùng để tìm kiếm cơ sở dữ liêu cho bất kỳ một bản ghi nào để đáp ứng tiêu chuẩn lý thuyết, nhập vào vùng liên kết của Quick Search 1. Trong thực đơn xổ xuống, chọn Any hoặc All. 2. Nhập một giá trị hoặc đặt thông số trong vùng liên kết. 3. Nhấn nút Off để bỏ Quick Search từ cơ sở dữ liệu. - Thanh cuốn Analysis Records Nút cuốn sẽ cuốn từng analysis trong specimen hiện thời. - Thêm thông tin cho Analysis Chạy các tương tác bằng tay, đo độ cứng hoặc các thủ tục để sinh ra dữ liệu. Thêm một phân tích bằng cách nhấn nút Add Record. Nhập dữ liệu vào vùng khả nhập và nhấn nút OK khi đã hoàn tất. Để ghi một analysis nhấn nút OK hoặc nhấn lại nút Add Record. Để huỷ toàn bộ thay đổi nhấn nút Cancel. - Soạn thảo một bản ghi phân tích Để xoạn thảo một bản ghi vào Analysis Tab nhấn nút Record Editing hoặc chọn Edit Record từ thực đơn Database. Nhập dữ liệu vào vùng khả nhập (vùng không bị phủ xám) và nhấn nút OK khi đã hoàn tất hoặc nhấn lại nút Edit. - Mở lại một Analysis Image Record Để mở một bản ghi phân tích nhấn nút Open Record. - Xoá một Analysis Record
  11. Để xoá ảnh và thông tin của bản ghi đã liên kết với một Analysis nhấn nút Delete Record hoặc chọn Delete Record từ thực đơn Database. Hộp thoại xác nhận sẽ xuất hiện, phai nhấn Yes. - Search Analysis Records Using Filters Nút Filter for current table sẽ mở hộp thoại Filter cho Analysis Tab. - Bỏ một Analysis Filter Để bỏ một filter, nhấn nút Remove a Filter. - Repord Queue Contents Nút Open the Report Queue sẽ mở hộp thoại Report Queue Contents. e. Fields Tab Hình 3.39. Fields Tab Fields Tab chỉ sẵn sàng khi một giá tự động được sử dụng và giữ các thông tin về vị trí khi một phân tích được xác nhận. Fields Tab không có khả năng xoạn thảo.
  12. Các chức năng của Fields Tab: - Nhẩy đến một bản ghi Nhẩy đến một bản ghi field được chọn nhập vào ô liên kết . Số bản ghi được hiển thị trên góc trái phía dưới của cửa sổ cơ sở dữ liệu. 1. Nhập số bản ghi trên ô liên kết Jump To Record 2. Nhấn nút Go . - Quick Search Quick Search tìm kiếm cơ sở dữ liệu cho bất kỳ bản ghi nào để đáp ứng tiêu chuẩn lý thuyết, nhập vào ô liên kết của Quick Search 1. Trong thực đơn xổ xuống, chọn Any hoặc All. 2. Nhập một giá trị hoặc đặt thông số trong vùng liên kết. 3. Nhấn nút Off để bỏ Quick Search từ cơ sở dữ liệu. - Thanh cuốn Field Record Nút cuốn sẽ cuốn từng thông tin vùng phân tích trong phân tích hiện thời. - Search Field Records Using Filter Nút Filter for current table sẽ mở hộp thoại Filter cho Fields Tab. - Bỏ một Field Filter Để bỏ một filter nhấn nút Remove a filter. - Report Queue Contents Nút Open the Report Queue sẽ mở hộp thoại Report Queue Contents.
  13. f. Gallery Tab Hình 3.40. Gallery Tab Gallery Tab hiển thị các ảnh kích thước nhỏ của các ảnh trong cơ sở dữ liệu của Omnimet. Số lượng các ảnh được hiển thị trong Gallery Tab được xác định bởi các lựa chọn trong Gallery Tab của hộp thoại Users Preference bao gồm: - Kích cỡ ảnh nhỏ (100% hoặc 200%) - Lọc được ứng dụng cho cơ sở dữ liệu. Các chức năng của Gallery Tab - Nhẩy tới một bản ghi Nhẩy tới một bản ghi được chọn nhập vào ô liên kết. Số của bản ghi được hiển thị trên góc trái phía dưới của cửa sổ cơ sở dữ liệu. 1. Nhập số bản ghi trên ô liên kết Jump To Record
  14. 2. Nhấn nút Go . - Quick Search Quick Search tìm kiếm cơ sở dữ liệu cho bất kỳ bản báo cáo nào để đáp ứng tiêu chuẩn lý thuyết, nhập vào ô liên kết của Quick Search 1. Trong thực đơn xổ xuống, chọn Any hoặc All. 2. Nhập một giá trị hoặc đặt thông số trong vùng liên kết. 3. Nhấn nút Off để bỏ Quick Search từ cơ sở dữ liệu. - Thanh cuốn Gallery Images Nút cuốn sẽ cuốn từng trang ảnh trong cơ sở dữ liệu. Nhấn nút để mở hộp thoại Gallery Page List. 1. Chọn một trang. 2. Nhấn nút OK Hình 3.41. Hộp thoại Imge Gallery Page List - Xoá một ảnh trong Gallery Để xoá một ảnh nhấn nút Delete Record hoặc chọn Delete Record từ thực đơn Database. Hộp thoại xác nhận xuất hiện, phải nhấn Yes. - Xem lại một bản ghi ảnh trong Gallery Để mở một bản ghi ảnh nhấn nút Open Record. - Report Queue
  15. Nút Open the Report Queue sẽ mở hộp thoại Report Queue Contents. - Thêm ảnh vào Report Queue Nút Add to Report Queue sẽ thêm ảnh hiện thời vào Report Queue. - Thông tin của bản ghi ảnh Gallery Tab sẽ hiển thị dữ liệu về một ảnh được chọn trong hộp Image Information. Một ảnh được chọn được đánh dấu sáng bằng một viền đỏ quanh ảnh. Giống như một ảnh được chọn, hộp thông tin ảnh được cập nhật để hiển thị dữ liệu cho ảnh đó. (xem hình 6- 6). Sáu điểm của dữ liệu được hiển thị là: - Số Project - Specimen ID - Số ảnh - Vật kính của ảnh. - Nguồn ảnh - Ngày, giờ lưu ảnh

CÓ THỂ BẠN MUỐN DOWNLOAD

AMBIENT
Đồng bộ tài khoản