intTypePromotion=1

Sử dụng Metastock

Chia sẻ: Nguyen Quoc Khanh | Ngày: | Loại File: DOC | Số trang:23

0
203
lượt xem
68
download

Sử dụng Metastock

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Với mục tiêu chia sẻ kiến thức cùng mọi người, được sự khích lệ và giúp đỡ của các anh chị, tôi sẽ viết các bài hướng dẫn sử dụng MetaStock để có thể giúp những ai yêu thích phân tích kỹ thuật tiếp cận nhanh và hiệu quả phần mềm phân tích chứng khóan rất mạnh này.

Chủ đề:
Lưu

Nội dung Text: Sử dụng Metastock

  1. Sử dụng Metastock \ Hướng dẫn sử dụng Metastock cơ bản (phần 1) Với mục tiêu chia sẻ kiến thức cùng mọi người, đ ược sự khích l ệ và giúp đ ỡ c ủa các anh ch ị, tôi s ẽ vi ết các bài hướng dẫn sử dụng MetaStock để có thể giúp những ai yêu thích phân tích k ỹ thu ật ti ếp c ận nhanh và hi ệu qu ả phần mềm phân tích chứng khóan rất mạnh này. Các thông tin phục vụ cho bài viết này được l ấy chủ yếu t ừ MetaStock Help, MetaStock Manual và các trang web nước ngoài có liên quan. Vì có nhiều thuật ng ữ b ằng tiếng Anh khó nên vi ệc chuyển sang nghĩa tiếng Việt tương đương chưa sát nghĩa (do trình độ có hạn), mong các b ạn góp ý thêm. 1/. Cấu trúc dữ liệu và cách thức cập nhật dữ liệu cho MetaStock 1.1. Cấu trúc dữ liệu của MetaStock: Để có thể vẽ biểu đồ và thiết lập các chỉ báo phân tích, d ự đoán cho ch ứng khoán b ạn ph ải có d ữ li ệu. D ữ liệu cho MetaStock được lưu trữ theo t ừng ngày và t ừng loại ch ứng khoán bao g ồm các thông tin sau: Ticker, Date, Open, High, Low, Close, Volume, … (Mã chứng khoán, Ngày, Giá mở cửa, Giá khớp lệnh cao nh ất , Giá khớp lệnh thấp nhất, Giá đóng cửa, Khối lượng giao dịch, …) MetaStock có thể sử dụng nguồn dữ liệu được lưu trữ trong máy tính cá nhân c ủa b ạn (Local Data) ho ặc d ữ liệu RealTime Online được cung cấp qua Internet. Cách thông thường có th ể áp d ụng đ ược ở Vi ệt Nam là dùng Local Data. Để có dữ liệu, bạn sẽ phải tự cập nhật-convert thông tin theo k ết qu ả giao d ịch hàng ngày c ủa các trung tâm giao dịch chứng khoán hoặc DownLoad dữ liệu đã đ ược convert s ẵn t ừ các website: www.bsc.com.vn, phantichcophieu.com, … Dữ liệu cho MetaStock thường được cập nhật vào file dạng ASCII Text hoặc Excel. Sau đó s ẽ đ ược convert vào MetaStock bằng The DownLoader. Về cơ bản, dữ liệu cho MetaStock chỉ cần 2 thông tin là DATE và CLOSE. Tuy nhiên để có đầy đủ thông tin phục vụ cho vi ệc l ập bi ểu đ ồ, th ống kê, phân tích và d ự báo thì nên cập nhật đủ các nội dung sau: Ticker, Date, Open, High, Low, Close, Volume. Dữ liệu dạng file ASCII Text có thể được tổ chức theo 2 cách: - Có mô tả tên các trường ( field name) dữ liệu: Dòng đầu tiên của file sẽ chứa tên các trường dữ liệu, từ dòng thứ 2 trở đi m ới là d ữ li ệu ch ứng khoán. B ạn có th ể không c ần c ập nhật hết các thông tin nhưng bắt buộc phải có ít nh ất 3 thông tin: Ticker, Date và Close. Ví d ụ: ,,,,,,,,, ACB,D,20061121,000000,120.0000,150.0000,119.0000,135.0000,56500,0 BBS,D,20061121,000000,27.5000,28.3000,27.5000,28.3000,13300,0 Mỗi dòng sẽ là dữ liệu của 1 chứng khoán, các cột số liệu phải được phân cách b ằng d ấu “,”. - Không mô tả tên các trường ( field name) dữ liệu. Nếu không mô tả tên trường thì bạn phải nhập dữ liệu theo đúng thứ tự và đủ các thông tin nh ư ví d ụ nêu trên. Dữ liệu dạng file Excel bắt buộc phải có mô tả tên các trường dữ li ệu. Ví dụ: TICKER DATE OPEN HIGH LOW CLOSE VOLUME ACB 5/25/2007 166 168 165 167.5 56300 BBS 5/25/2007 27.5 28.3 27.5 28.3 13300 Tên các trường dữ liệu phải được mô t ả t ại dòng đầu tiên và vi ết đúng chính t ả nh ư ví d ụ trên. D ữ li ệu ph ải được sắp xếp theo thứ tự tăng dần của ngày (trường h ợp d ữ li ệu nhi ều ngày). C ột DATE ph ải là text và có d ạng mm/dd/yyyy (tháng/ngày/năm). Các trường dữ liệu tương ứng với kết quả giao dịch của các sàn giao dịch nh ư sau OPEN HIGH LOW CLOSE VOLUME Giá đợt 1 Giá cao nhất 3 đợt Giá thấp nhất 3 đợt Giá đợt 3 Lượng GD Sài Gòn Hà Nội Giá mở cửa Giá cao nhất Giá thấp nhất Giá đóng cửa Lượng GD
  2. - Trường hợp tự cập nhật kết quả giao dịch hàng ngày vào file Excel : + Đối với sàn Hà nội thì lấy kết quả giao dịch t ừ trang web www.hse.org.vn copy vào Excel sau đó xử lý các cột giá có giá trị là “--” (tức không có giao dịch) bằng công thức IF(cột X=“--”, Cột giá tham chiếu, cột X); Khối lượng giao dịch bằng công thức IF(cột KL=“--”, 0, cột KL x 100) do sàn Hà Nội sử dụng lô khớp lệnh là 100. + Đối với sàn Sài Gòn, bạn nên lấy kết quả t ừ b ảng giá tr ực tuyến ở trang web www.vse.org.vn; Lập một số công thức: Cột HIGH=MAX(giá khớp lệnh đợt 1, giá KL đ ợt 2, giá KL đ ợt 3); C ột LOW=MIN(giá đ ợt 1, giá đ ợt 2, giá đợt 3) nhưng lưu ý phải xử lý thêm trường hợp có giá trong 1 đ ợt nào đó b ằng 0/ho ặc không có giá; T ương tự cũng phải xử lý giá OPEN, CLOSE nếu trong ngày có 1 ch ứng khoán nào đó không có giao d ịch thì ph ải l ấy bằng giá tham chiếu để khi vẽ đồ thị đường biểu diễn giá không bị t ụt về 0; Kh ối lượng giao d ịch x 10. - Trường hợp sử dụng dữ liệu có sẵn từ các website : Dữ liệu convert của bsc.com được chứa trong file [.dat] có tên là StockDay hoặc MarketDay; hoặc được g ộp nhi ều ngày đến m ột ngày nào đó có tên là StockData hoặc MarketData (khác nhau chữ Day hoặc Data trong tên file). StockDay/StockData ch ứa d ữ li ệu ch ứng khoán; MarketDay và MarketData chứa dữ liệu của chỉ số VNINDEX. Dữ liệu phantichcophieu.com thường được để trong file nén [.zip/.rar] gồm có 4 file dạng text (.txt) hoặc excel (.xls) g ồm: HoSTC (dữ liệu cổ phiếu sàn Sài Gòn), HaSTC (cổ phiếu sàn Hà Nội), Fund (chứng chỉ quỹ) và Index (ch ỉ s ố Ha-Index và chỉ s ố VN-Index). Hiện tại ở website [http://vietcurrency.com] có công cụ lấy dữ liệu hàng ngày của cả 2 sàn t ự đ ộng bằng cách sử dụng Excel do bạn Strade cung cấp miễn phí. Các bạn có thể download về s ử dụng ở địa chỉ sau: + Sàn Sài Gòn GetHostc1.2_.rar: http://vietcurrency.com/Forum/index.php?topic=470.0 + Sàn Hà Nội GetHastc1.1.rar: http://vietcurrency.com/Forum/index.php?topic=440.15 1.2. Cách thức cập nhật dữ liệu cho MetaStock: Copy dữ liệu nguồn (do bạn tự cập nhật hoặc DownLoad từ các website nêu ở ph ần trên, trong tr ường h ợp lấy từ phantichcophieu.com phải được xả nén) vào 1 thư mục bất kỳ trên máy tính của bạn. Để l ưu d ữ li ệu cho MetaStock, bạn nên tạo các thư mục chứa dữ liệu cho MetaStock (thông thường nên t ạo luôn các th ư m ục con trong trong thư mục mẹ \Metastock Data do MetaStock tạo ra trong quá trình cài đặt phần mềm). - Khởi động MetaStock - Chọn The DownLoader… từ menu Tools hoặc chọn biểu tượng từ toolbars (các chỗ có khoanh đỏ trong hình sau) - Chờ The DownLoader khởi động xong, bạn chọn Convert… từ menu Tools hoặc chọn biểu tượng từ Toolbars (các chỗ có khoanh đỏ trong hình sau).
  3. - Hộp thoại Convert Securities sẽ xuất hiện. Bạn phải nhập và khai báo các thông số: Phần thông số của dữ liệu nguồn (Source), bạn thực hiện tuần tự các bước sau: a. File type (Kiểu dữ liệu nguồn): Bạn bấm vào mũi tên sẽ xuất hiện các kiểu file mà MetaStock có thể nh ận d ữ - liệu. Bạn chọn Excel hoặc ASCII Text cho phù hợp với kiểu file đã DownLoad về. Folder: Thư mục chứa các file dữ liệu mà bạn muốn convert. - File Name: Là tên file có chứa dữ liệu bạn muốn convert. Bạn có thể tìm và chọn file d ữ li ệu t ừ h ộp tho ại - Choose Source Files bằng cách bấm nút chọn Browse… như hình dưới đây.
  4. Phần thông số của dữ liệu đích (Destination) b. File type (Kiểu dữ liệu đích): Chọn MetaStock khi convert dữ liệu. - Folder: Thư mục chứa các file dữ liệu của MetaStock. Tương tự như phần trên. - File name: Bạn để trống (không cần khai báo gì cả). -
  5. Phần các thông số tùy chọn khác (Options…). Bạn chọn nút Options trong hộp thoại Convert Securities, hộp thoại c. Conversion Options sẽ xuất hiện. Trong Conversion Options có 2 TAB chứa các tham số tùy chọn tương ứng cho 2 phần dữ liệu nguồn (Source) và đích (Destination). Các thông số trong tab Source (thường để mặc định theo MetaStock mà không cần khai báo lại trừ trường hợp - cần thiết): + Date Range: Bạn có thể nhập vào khoảng thời gian muốn convert dữ liệu (First date và Last date). Nếu chọn Use today’s date thì Last date sẽ có giá trị là ngày hiện hành của máy tính. + Periodicity: Thông thường bạn chọn là Daily (nếu chọn Intraday thì phải khai báo thêm thông số Minutes per bar). +Traverse source folders: Đánh dấu chọn mục này nếu bạn muốn convert tất cả dữ liệu ở các thư mục con khác nhau trong một thư mục chính. Ví dụ: Nếu bạn đánh dấu check vào mục chọn này và nhập nội dung ô Folder là C:MetaStock thì dữ liệu ở các thư mục con C:MetaStockA, C:MetaStockB, … đều được convert. Lựa chọn này thường được sử dụng trong trường hợp convert dữ liệu Source File type là TC2000. Nếu File type là MetaStock thì không thể chọn. Các thông số trong tab Destination gồm: - + If file exists: Chọn lựa các cách cập nhật nếu file dữ liệu đã được t ạo trước đó. Chọn “Append data to end of file” nếu bạn muốn dữ liệu từ file nguồn được nối tiếp vào cuối file đích. Chọn “Replace matching dates” nếu mu ốn thay thế các dữ liệu cùng ngày từ file nguồn vào file đích. Chọn “Replace existing file” nếu muốn thay thế toàn b ộ d ữ li ệu file đích bằng file nguồn.
  6. + Include Open & Open Interest: Nếu chọn, dữ liệu được convert sẽ bao gồm cả 2 fields Open và OI. + Create new files: Nếu chọn mục này, khi convert dữ liệu có phát sinh mã chứng khoán mới thì file đích tương ứng s ẽ được tạo ra trong Destination Folder. + Traverse Destination folders: Đánh dấu chọn mục này nếu bạn muốn dữ liệu được convert lưu trữ ở các thư mục con khác nhau trong một thư mục chính. Ví dụ: Nếu bạn đánh dấu check vào mục chọn này và nhập nội dung ô Folder là C:MetaStock thì các chứng khoán có ký tự đầu là A sẽ được lưu trữ ở thư mục con C:MetaStockA, ký t ự đ ầu là B được lưu ở C:MetaStockB, … Bạn nên bỏ chọn mục này để tất cả chứng khoán được lưu trữ ở chung 1 thư mục được chỉ định. Ví dụ: Các chứng khoán sàn Sài gòn sẽ được lưu ở thư mục HoSTC thay vì HoSTCA, HoSTCB, … + Fields to out put: Chọn/Không chọn mục nào thì khi convert dữ liệu sẽ có/hay không có tr ường (field) dữ li ệu t ương ứng. Sau khi convert xong, MetaStock sẽ đưa ra bảng thông báo k ết quả Conversion Report. Dấu X màu đỏ biểu thị các records bị lỗi (ví dụ: High
  7. 2.1. Một số khái niệm chung: MetaStock cung cấp 3 cách quản lý biểu đồ l� Charts, Smart Charts v� Layouts. “Chart” l� sự biểu diễn bằng đồ thị của chứng khoán trong một cửa s ổ đ ơn l ẻ (single window). Cửa sổ n� y có thể sẽ chứa một hoặc nhiều cửa sổ con bi ểu di ễn các đối t ượng khác nhau như: Các đồ thị về giá, các chỉ báo (RSI, MCD, …), di ễn gi ải, ghi chú, … T ạo chart mới bằng cách chọn New Chart từ menu File. Để lưu trữ lại, chọn Save As trong menu File. Phần mở rộng của một file chart s ẽ l� [ .mvc]. “Smart Chart” l� chart được Save với tên chứng khoán cụ thể. Tất cả những thay đ ổi trong quá trình l� m việc trên Smart chart sẽ được save lại 1 cách t ự động khi b ạn đóng Smart chart. Để mở 1 Smart chart, chọn Open từ menu File. Lần đầu tiên bạn mở Smart chart thì 1 mẫu đặc biệt sẽ luôn được sử dụng có tên l� Default.MWT. “Layout” l� sự biểu diễn bằng đồ thị của một hoặc nhiều chứng khoán trong 1 hoặc nhi ều cửa sổ kết hợp. Với layout, bạn có thể tạo 1 nhóm các chart c ủa các ch ứng khoán gi ống hoặc khác nhau. Bạn có thể lưu layout cho lần s ử d ụng sau v ới ph ần tên file m ở r ộng đ ược quy định l� [.mvl]. 2.2. Tùy biến một số thông số v� các thao tác chủ yếu khi sử dụng biểu đồ (chart): - Xem lướt qua đồ thị của từng chứng khoán (scanning charts): Có 4 cách xem + Chọn lệnh Change Security từ menu File (cách n� y dở lắm). + Sử dụng nút cuộn của chuột máy tính (Rotate Wheel) kết h ợp nh ấn v� gi ữ phím ALT. + Nhấn kết hợp phím ALT+Mũi tên phải hoặc Mũi tên trái để ch ọn Next ho ặc Previous tu ần tự từng chứng khoán theo thứ tự đã sắp xếp. + Chọn nút Change Security Buttons ở góc phải dưới của m� n hình l� m việc. Các nút mũi tên l� để chọn Next hoặc Previous tuần tự t ừng chứng khoán theo th ứ t ự đã s ắp x ếp; Nút còn lại để chọn nhanh một chứng khoán trong bảng chọn Choose a Security.
  8. - Tùy biến các thông số cho việc scanning charts: Bạn đã tạo được một mẫu biểu đồ riêng theo ý thích cá nhân bao gồm đường bi ểu diễn về giá, các đ ường Bollinger Bands, MACD, RSI, Parabolic SAR, SO, các chỉ báo tín hiệu MACD mua/bán, … v � mu ốn áp d ụng mẫu biểu đồ n� y cho tất cả các loại chứng khoán có trong cơ s ở d ữ li ệu MetaStock. B ạn phải thực hiện 2 bước sau: + Thiết lập một mẫu Chart Template: (Sẽ được viết sau trong phần cách t ạo một biểu đồ phân tích trong MetaStock) ….. + Đánh dấu chọn mục Use chart as template, sau đó đánh dấu chọn mục Change all charts in a layout trong TAB Options của hộp thoại Choose a Security. 2.3. L� m việc với biểu đồ (chart): 2.3.1. Các lệnh (Commands) cơ bản: Các lệnh cơ bản khi l� m việc với biểu đồ gồm: Tạo m ới bi ểu đ ồ ( New), mở biểu đồ đã có (Open), đóng biểu đồ đang xem (Close), ghi lại (Save), in ấn biểu đồ ( Print), … Để thực hiện các chức năng nêu trên, bạn có thể chọn các nút l ệnh trên Toolbars (khi rê chuột v� o biểu tượng bất kỳ sẽ xuất hiện nội dung chức năng của nút lệnh). Hoặc bạn có thể tìm chúng trong menu File sau khi khởi động MetaStock (như hình sau). Trong các phần tiếp theo, tôi chỉ trình b� y một trong hai cách th ực hi ện l ệnh (t ừ menu h ệ thống hoặc từ toolbars, các bạn tự tìm hiểu cách còn lại, Ok?) v � tôi cũng s ẽ ch ỉ trình b � y các lệnh chức năng cần thiết. Phần còn lại các bạn t ự tìm hiểu thêm nhé.
  9. - Tạo mới biểu đồ: Bạn chọn New từ menu File, sau đó chọn Chart. Kiểu biểu đồ m� bạn tạo mới theo mặc định của MetaStock luôn l� Smart Charts. - Mở một biểu đồ có sẵn: Bạn chọn Open từ menu File. Với lệnh Open, bạn có thể mở 1 biểu đồ đã có, một mẫu Chart, Smart Charts hoặc Layout. Khi chọn chức năng New hoặc Open một biểu đồ, có 02 tham số tùy chọn trong ph ần Option của hộp thoại cần lưu ý l� : Load Options v� Open With Template.
  10. + Load Options: L� hộp thoại tùy biến cho phép bạn chọn th ời điểm s ử d ụng s ố li ệu v ẽ biểu đồ phân tích. Load [ ] Periords: khai báo số kỳ dữ liệu được tải v� o chart; Display [ ] periords: Số kỳ được hiển thị trên chart. MetaStock cho phép sử dụng tối đa l � 65.500 kỳ (kỳ ở đây có th ể l� ng� y, tuần, hoặc tháng, … tính t ừ kỳ cuối cùng trở về trước). Nếu b ạn ch ọn m ục n � y thì mỗi lần mở biểu đồ MetaStock sẽ tự động cập nhật dữ liệu mới nhất theo số kỳ m� bạn đã thiết lập. Ngược lại, nếu bạn muốn khai báo lại số kỳ theo t ừng l ần m ở chart thì b ạn ch ọn Prompt for dates when chart is opened. Với sự lựa chọn n� y, m ỗi khi mở chart s ẽ xu ất hi ện h ộp tho ại sau đây để bạn chỉ định kỳ phân tích.
  11. Bạn có thể chọn kỳ phân tích trong khoảng thời gian tùy ý b ằng cách nh ập ng � y c ụ th ể v � o trong ô First date v� Last date. + Open With Template: Tùy chọn n� y sẽ giúp bạn sử dụng ngay các mẫu biểu đồ do MetaStock (hoặc bên thứ 3 cung cấp sẵn) hoặc s ử dụng nh ững m ẫu bi ểu đ ồ do b ạn t ự t ạo ra tùy theo sở thích v� kinh nghiệm của mình m� không ph ải m ất công thi ết l ập l ại bi ểu đ ồ cho mỗi lần mở chart của một chứng khoán n� o đó. Trường hợp muốn sử dụng mẫu Template bất kỳ khi bạn đã m ở s ẵn bi ểu đ ồ c ủa ch ứng khoán n� o đó, bạn thực hiện tuần tự các bước sau: Nh ấn nút ph ải chuột (right-click) trên chart đang được mở; Chọn Apply Template t ừ Shortcut Menu; Ch ọn m ột m ẫu Template tùy ý trong hộp thoại Open With Template sau đó chọn nút Open. - Lưu biểu đồ vừa tạo: Bạn chọn 1 trong các lệnh sau từ menu File: Save, SaveAs, Save All. Sử dụng lệnh Save as HTML nếu bạn dự định sẽ tải chart n� o đó lên Internet. 2 lệnh có thêm phần tùy chọn m� bạn cần phải quan tâm. + Save as HTML: Cách n� y chẳng qua chỉ để thay cho việc bạn chụp lại bi ểu đ ồ th � nh dạng file ảnh bằng việc sử dụng phím PrintScreen. Tuy nhiên cũng có ưu điểm l� bạn sẽ nhận được 1 file ảnh có đầy đủ thông tin hơn so với việc chụp ảnh m � n hình.
  12. + Save As: Như đã trình b� y ở phần trước, Template l � m ẫu bi ểu đ ồ (chart hoặc layout) chứa các thông tin như: Đồ thị biến động giá, lượng; Các ch ỉ báo (RSI, MACD, …), các đường phân tích (Trendline, Fibonaci, …) hay ghi chú, … đ ược MetaStock ho ặc chính b ản thân bạn tự tạo ra theo sở thích v� kinh nghiệm phân tích k ỹ thuật c ủa mình đ ể ph ục v ụ cho việc theo dõi, phân tích chứng khoán. Template thường đ ược s ử d ụng khi t ạo m ới, m ở hoặc load một chart/layout đã có để có sự đồng nhất về thông tin khi phân tích các ch ứng khoán. Để chuyển một biểu mẫu bất kỳ th� nh template, b ạn ch ọn Save As từ menu File, đặt tên cho biểu mẫu Template trong phần File name, Nhớ chọn Template trong mục chọn Save as Type để Save lại.Sau n� y bạn sẽ thấy sự lợi hại của nó. MetaStock cũng cho phép sử dụng một Template đặc biệt đ ể mỗi khi b ạn t ạo m ới bi ểu đ ồ phân tích cho bất kỳ chứng khoán n� o thì nó luôn đ ược t ạo ra v ới khuôn m ẫu gi ống nhau m� không cần phải thực hiện bước Apply Template. Để sử dụng được tính năng n� y, hãy ho� n chỉnh 1 biểu mẫu theo ý của riêng bạn sau đó khi thực hiện Save As bạn đặt tên cho nó l� DEFAULT.MWT (được lưu trong thư mục EquisMetaStockCharts). Mỗi l ần t ạo mới biểu đồ phân tích cho chứng khoán n� o đó, b ạn s ẽ th ấy tính năng n � y c ủa MetaStock có ý nghĩa như thế n� o.
  13. 2.3.2. Các th� nh phần cấu th� nh v� các nút lệnh điều khi ển th ường s ử d ụng trong cửa sổ biểu diễn biểu đồ phân tích chứng khoán: Các vị trí được đánh số trong hình minh họa có ý nghĩa nh ư sau: 1- Inner Window Title Bars: Phần tiêu đề của các cửa sổ con. Các cửa s ổ con l� nơi biểu diễn các đồ thị về giá-lượng; Các chỉ báo tín hiệu, … các cửa sổ con được trình b� y trong 1 cửa sổ mẹ gọi l� Single Window (hoặc l� Main Window). 2- Indicators: Các chỉ báo kỹ thuật. Trong hình minh họa có các chỉ báo: RSI (Inner Window trên cùng); MACD (Inner Window thứ 2, ở gi ữa); PSAR (Inner Window th ứ 3, đ ường bi ểu diễn m� u xanh nét đứt). 3- Price: Đồ thị biểu diễn sự biến động của giá chứng khoán trong thời kỳ do b ạn t ự ch ọn. Trong hình minh họa l� mẫu Candle Stick. 4- Expert Advisors: Ý kiến của chuyên gia. Trong hình minh họa l� mẫu MACD-Equis. 5- Volume: Đồ thị biến động của khối lượng giao dịch tương ứng với biến động giá. 6- Y-Axis Scale: Thang mô tả các mức giá, lượng giao dịch; các mức đo dùng cho các ch ỉ báo kỹ thuật (VD: RSI dùng mức 30-70 để tính ng ưỡng lố mua/l ố bán, …)
  14. 7- Periodicity: Sử dụng điều khiển n� y để thay đổi đơn vị thời gian (periods) bi ểu di ễn d ữ liệu trên biểu đồ (Daily: ng� y; Weekly: tuần; Monthly: tháng; Quarterly: quý; Yearly: năm; Custom: tùy chọn khác; lưu ý các ký tự đầu của mỗi period). Nếu Period l� ng � y thì giá s ẽ l� Open v� Close của từng ng� y; period l� tuần thì giá Open l � Open c ủa th ứ 2 tu ần n� y, Giá close l� close của thứ 6 tuần n� y; Các period khác thì b ạn t ự suy lu ận t ương t ự như trên. Để thay đổi periodicity, click v� o bi ểu t ượng v� ch ọn period t ừ shortcut menu. Nếu muốn dùng period theo cách riêng như cứ 12 ng� y thì tính l � 1 period thì b ạn ch ọn Custom v� nhập số 12 v� o ô Periods. Cách khác để thay đ ổi Periodicity l � nh ấn nút ph ải chuột (right-click) v� o thang biểu diễn thời gian nằm d ưới vùng đáy c ủa đ ồ th ị (dòng có s ố ng� y/tháng) rồi chọn chức năng Periodicity trong shortcut menu vừa xuất hi ện.
  15. 8- ReScale Y-Axis: Khi muốn thay đổi đơn vị đo của thang Y-Axis Scale Click chuột v� o nút n� y MetaStock sẽ tự động tính lại thang đo một cách h ợp lý h ơn. 9- Zoom Controls: Có 3 nút Zoom Reset, Zoom In v� Zoom Out dùng để phóng to, thu nhỏ hoặc Reset lại biểu đồ. 10- Scanning Controls: Dùng để xem lướt qua đồ thị của từng chứng khoán như đã trình b� y ở phần trước. 11- Symbol Textbox: Ô n� y sẽ cho biết biểu đồ đang xem l� của mã chứng khoán n� o. Ngo� i ra còn một số điều khiển khác, các bạn tìm hiểu thêm vì nếu mô t ả h ết thì d� i l ắm. 2.3.3. Tạo một biểu đồ đơn giản: Một biểu đồ đơn giản nhất theo mặc định của MetaStock được ch ứa trong 1 single window gồm 1 đồ thị biểu diễn giá v� một đồ thị biểu diễn khối lượng giao dịch. MetaStock có 9 kiểu đồ thị giá (theo bản MS 10) như sau:
  16. Tạo một biểu đồ đơn giản đầu tiên của bạn. Thực hiện lần lượt các bước sau: - Chọn New/Chart từ menu File hoặc Toolbars - Chọn một chứng khoán bất kỳ trong hộp thoại New vừa xuất hiện; sử dụng các tùy chọn trong mục Option như đã hướng dẫn ở phần 2.3.1, xong chọn nút Open. - Biểu đồ của chứng khoán bạn vừa chọn sẽ xuất hiện. Nếu bạn ch ọn vi ệc lập bi ểu đ ồ theo một mẫu Template n� o đó thì biểu đồ chứng khoán của b ạn s ẽ có hình th ức gi ống hệt như Template đã chọn. Nếu không chọn Template thì biểu đồ sẽ được thiết l ập theo mẫu từ file DEFAULT.MWT như đã trình b� y ở phần trước. - Tùy theo nhu cầu v� sở thích, bạn có th ể lựa ch ọn các ki ểu đ ồ th ị giá, đ ồ th ị l ượng khác nhau hoặc thiết lập các m� u sắc cho bắt mắt b ằng cách nh ấn nút ph ải chu ột (right- click) trên đồ thị giá hoặc lượng, 1 shortcut menu s ẽ xuất hiện. Ch ọn dòng l ệnh đ ầu tiên
  17. (trong hình minh họa l� ACB Properties), hộp thoại khai báo các tham số tùy chọn s ẽ xuất hiện. - Bạn có thể chọn một trong chín kiểu đồ thị giá do MetaStock cung cấp nh ư đã trình b � y ở phần trên bằng cách chọn kiểu đồ thị trong phần Price style; Chọn m� u biểu diễn trong mục chọn Colors;
  18. - Ngo� i ra Bạn có thể thay đổi các tham s ố cho đ ồ th ị bằng cách click chu ột v � o đ ồ thị muốn thay đổi, sau đó click chuột v� o các ô điều khi ển QuickList n ằm ở góc bên trái dưới đáy của m� n hình như hình sau: Đến đây bạn đã có thể tạo ra các biểu đồ đơn giản cho riêng mình rồi, thú vị không b ạn? 3/. Thiết lập các chỉ báo (Indicators) trong biểu đồ phân tích Indicators thực ra chỉ là những phép tính đơn thuần về toán học. Kết quả của các phép tính này thường được dùng để dự đoán sự thay đổi của giá chứng khoán trong tương lai. Indicators có thể được trình bày ở các Inner window riêng biệt hoặc trình bày chung trong inner window có chứa đường giá của chứng khoán. Ví dụ: Ta thường vẽ đường biểu diễn RSI, MACD ở các inner window riêng nhưng ta sẽ vẽ đường Parabolic SAR, hay đường Bollinger Bands chung trong inner window có vẽ đồ thị giá chứng khoán, … Có 3 loại Indicator trong MetaStock: + Price Indicators: Các chỉ báo giá luôn sử dụng dữ liệu giá chứng khoán để tính toán. + Custom Indicators: Các chỉ báo tùy chọn do bạn tự thiết lập công thức tính toán bằng cách sử dụng Indicator Builder (cái này hay l ắm và s ẽ đ ược viết ở phần sau). + Plot-based Indicators: Các chỉ báo dưới dạng đồ thị (MACD, RSI, PSAR, …) Ký hiệu để nhận biết Indicators thuộc loại nào xem trong hình minh h ọa. Bạn có thể tìm thấy tất cả các loại Indicators kể trên trong công c ụ Indicators QuickList hoặc trong Indicators Dialog. Có 2 cách để vẽ đồ thị biểu diễn chỉ báo phân tích: + Drag and Drop (thao tác kéo và thả):
ADSENSE
ADSENSE

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản