intTypePromotion=3

Công nghệ CAD/CAM và nguyên lý điều khiển trong công nghiệp Phần 2 - Nguyễn Thế Tranh

Chia sẻ: Nguyễn Thị Ngọc Lựu | Ngày: | Loại File: PDF | Số trang:42

0
108
lượt xem
35
download

Công nghệ CAD/CAM và nguyên lý điều khiển trong công nghiệp Phần 2 - Nguyễn Thế Tranh

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Cuốn sách Công nghệ CAD/CAM và nguyên lý điều khiển trong công nghiệp gồm các nội dung sau: tổng quan về công nghệ CAD/CAM, cơ sở của mô hình hoá hình học, mô hình hoá các thực thể hình học, cơ sở của CAD, phần cứng và phần mềm trong CAD, giới thiệu phần mềm Pro/Engineer Wildfire, kỹ thuật điều khiển số và công nghệ gia công điều khiển số CNC. Đây là giáo trình giảng dạy và học tập dành cho sinh viên ngành Cơ khí - Chế tạo máy.

Chủ đề:
Lưu

Nội dung Text: Công nghệ CAD/CAM và nguyên lý điều khiển trong công nghiệp Phần 2 - Nguyễn Thế Tranh

  1. C5 CAD-CAM>PC-PM CAD 1 GVC NGUYỄN THẾ TRANH Chương 5 PHẦN CỨNG VÀ PHẦN MỀM TRONG CAD 5.1. PHẦN CỨNG TRONG CAD 5.1.1 GIỚI THIỆU CHUNG. Các bộ phận phần cứng dùng cho một hệ CAD rất đa dạng về kích thước, cấu hình và về mức độ hiện đại, tuỳ theo nhiệm vụ của từng đơn vị mà chọn hệ CAD cho phù hợp. Ta biết rằng nền tảng của một hệ CAD hiện đại là đồ hoạ máy tính tương tác (ICG) cho phép người thiết kế có ngay những ứng xử của hệ thống về dữ liệu đầu vào để có được những tác động thích hợp vì giữa người thiết kế và hệ thống có một mối liên lạc trực tiếp theo cách người sử dụng vào lệnh cho hệ thống và đáp ứng lại những câu hỏi mà hệ thống đưa ra. Ngày nay các phần cứng trong công nghệ thông tin rất phong phú và đa dạng được sử dụng trong hệ CAD. 5.1.2 CẤU HÌNH PHẦN CỨNG CỦA MỘT HỆ CAD ĐIỂN HÌNH. Một hệ CAD nói chung thường có các thiết bị phần cứng sau đây: 1. Một hoặc một số trạm thiết kế với một đầu cuối đồ hoạ và các thiết bị vào của người thiết kế. 2. Một hoặc một số máy vẽ và các thiết bị ra khác. 3. Một máy tính. 4. Các bộ lưu trữ ngoài (bộ nhớ ngoài). Lưu trữ ngoài Thiết bị Các Máy tính đầu cuối thiết bị đồ hoạ vào Máy vẽ và các thiết bị ra khác Hình 5.1. Cấu hình phần cứng một hệ CAD điển hình Hệ CAD có loại độc lập trong đó chỉ có một máy tính cá nhân điều khiển, có loại nối mạng cuc bộ với nhiều trạm thiết kế do một máy trung tâm điều khiển. 5.1.3. TRẠM THIẾT KẾ Trạm thiết kế hay còn gọi là trạm công tác của hệ CAD là một hệ thống giao diện với thế giới bên ngoài. Đây là một yếu tố quan trọng tạo nên tính hiệu quả và sự thuận tiện đối
  2. C5 CAD-CAM>PC-PM CAD 2 GVC NGUYỄN THẾ TRANH với người thiết kế khi làm việc với một hệ CAD. Bao gồm một trạm thiết kế có PC, thiết bi đầu cuối đồ họa (màn hình CRT), thiết bị vào(bàn phím, chuột). * Chức năng của một trạm thiết kế đồ hoạ : Một trạm thiết kế phải đảm trách được năm chức năng sau đây : 1. Giao diện với máy tính. 2. Tạo ra các bản vẽ ổn định cho người thiết kế. 3. Cung cấp các bản mô tả dưới dạng số của các bản vẽ trên. 4. Chuyển các lệnh máy tính thành các chức năng vận hành. 5. Tạo thuận lợi cho việc truyền thông giữa người thiết kế và hệ thống Cách tốt nhất để thực hiện các chức năng trên là sử dụng hệ đồ hoạ tương tác. Một trạm thiết kế dùng cho hệ đồ hoạ tương tác ắt phải có hai bộ phận hợp thành sau : 1. Môt thiết bị đầu cuối đồ hoạ 2. Các thiết bị vào của người thiết kế. 5.1.4.THIẾT BỊ ĐẦU CUỐI ĐỒ HỌA 1. Giới thiệu mở đầu : Từ trước đến nay đã có nhiều cách tiếp cận kỹ thuật khác nhau được áp dụng để nghiên cứu cải tiến các thiết bị đầu cuối đồ hoạ, và trong tương lai công nghệ vẫn không ngừng phát triển vì các nhà sản xuất các hệ thống CAD luôn luôn cố gắng nâng cao chất lượng và hạ giá thành sản phẩm của họ. Hiện có 2 loại thiết bị đầu cuối đồ hoạ được sử dụng trong các trạm thiết kế như sau : 1. Thiết bị đầu cuối tối thiểu: màn hình CRT 2. Thiết bị đầu cuối đồ hoạ có vi xử lý riêng: Màn hình CRT có card điều khiển gắn với bộ vi xử lý riêng. Dù là thiết bị đầu cuối đồ họa loại nào thì việc tạo sinh hình ảnh và hiển thị hình ảnh đó lên màn hình đều theo những nguyên tắc giống nhau. 2.Tạo hình ảnh trong đồ hoạ máy tính Chúng ta sẽ xét tới hai kỹ thuật cơ bản để tạo ra các hình ảnh, đó là kỹ thuật quét mành (dòng) và kỹ thuật quét vectơ. Ngoài ra còn có kỹ thuật tạo hình ảnh màu. 1).Cấu tạo và nguyên lý làm việc của CRT Các bộ phận chính của CRT gồm : 1. Cuộn đốt 2. Catôt 3. Lưới điều khiển 4. Anốt 5. Bộ phận hội tụ 6. Bộ phận lái tia 2).Quét dòng (hay quét mành) 1. Nguyên lý chung 2. Quét dòng không đan xen và quét dòng đan xen • Quét dòng không đan xen, ưu điểm, nhược điểm • Quét dòng đan xen, ưu điểm, nhược điểm 3. Độ phân giải
  3. C5 CAD-CAM>PC-PM CAD 3 GVC NGUYỄN THẾ TRANH • Độ phân giải theo chiều cao • Độ phân giải theo chiều rộng 4. Pixel: diện tích một chấm ảnh chiếm trên màn hình. 5. Hiệu ứng bậc thang 6. Ưu nhược điểm của quét dòng: Hình ảnh tạo ra tốt, chất lượng và giá thành luôn được cải thiện. Tuy nhiên còn tồn tại hiệu ứng bậc thang. Nếu không thì độ phân giải phải cao dẫn đến tốn bộ nhớ. 3).Quét vectơ 1. Nguyên lý chung 2. Ưu nhược điểm của quét vectơ: Khắc phục được các nhược điểm của hệ quét dòng nhưng có nhược điểm là hoạt hình kém hơn. 4). Hiển thị màu. Với CRT màu hình ảnh sẽ có màu sắc. CRT màu có các đặc điểm: - Mặt trong tấm kính màn hình có một lớp khám với các chấm nhỏ li ti gọi là triad gồm bộ ba chấm tròn có màu khác nhau Red, Green và Blue. - CRT màu tạo ra 3 chùm tia điện tử ứng với 3 màu riêng biệt. - CRT màu có một tấm phẳng có khoét lỗđặt gần màn hình nhằm ngăn một chùm tia xâm phạm vào vùng cấm. - Trong CRT màu có thang xám để điều khiển sự thay đổi cường độ của các chùm tia. 3. Màn hình đồ họa trong CAD Màn hình độ hoạ, đôi khi còn được gọi là thiết bị hiển thị video, là thiết bị quan trọng nhất đối với mục đích đồ hoạ. Về nguyên tắc, nó là một màn hình TV, có thể hiển thị ký tự và đồ hoạ với độ nét cao. Chỗ khác nhau là : màn hình TV sử dụng các tín hiệu “analog” do video camera tạo ra, còn màn hình đồ hoạ sử dụng các tín hiệu số hoá (“digital”) do máy tính tạo ra. Cốt lõi của một màn hình video là “ống phóng chùm tia âm cực”, hay còn được gọi là CRT. Hiện nay CAD sử dụng các loại màn hình phổ biến như: 1. Màn hình quét vectơ (hay làm tươi chùm vẽ vectơ) 2. Màn hình quét dòng 3. Màn hình lưu ảnh trực tiếp 4. Các loại màn hình đặc biệt khác: a) Màn hình tương tác b) Màn hình tinh thể lỏng - LCD 5.1.5. BẢN MẠCH GHÉP NỐI ĐỒ HOẠ. 1. Sơ đồ khối của video card điển hình. 2. Một số bản mạch ghép nối đồ hoạ. - Card màn hình đồ hoạ đen-trắng. - Card màn hình đồ hoạ màu. - Card màn hình đồ hoạ có gắn vi xử lý riêng. - các bản mạch ghép nối đồ hoạ hiện đại. 5.1.6. CÁC THIẾT BỊ NHẬP (INPUT) Các thiết bị input được trang bị tại một trạm thiết kế là nhằm cung cấp cho người sử dụng những phương tiện thuận lợi trong việc giao thông liên lạc với hệ thống. Chủng loại thiết bị Input rất phong phú, ta có thể chia các thiết bị này thành 4 loại chính sau: 1. Các thiết bị điều khiển con tró. - Bảng trò chơi.
  4. C5 CAD-CAM>PC-PM CAD 4 GVC NGUYỄN THẾ TRANH - Cần điều khiển. - Cầu vạch. - Chuột. - Các phím di chuyển con trỏ trên bàn phím. - Bút quang. - Bảng và bút điện tử. 2. Bàn đồ hoạ. Có thể được xem như một bàn vẽ điện tử. 3. Máy quét (Scanner). Máy quét là một thiết bị dùng để đọc bản vẽ hay chữ viết trên giấy, số hoá chúng rồi đưa vào cho máy tính xử lý. 4. Bàn phím. Có nhiều loại: - Bàn phím ký tự. - Bàn phím chức năng chuyên dùng. 5.1.7. CÁC THIẾT BỊ XUẤT (OUPUT) Bao gồm: 1. Màn hình. 2. Máy vẽ. 3. Máy copy màn hình. 4. Các thiết bị vi phim. 5. Máy in. 5.2. PHẦN MỀM VÀ CƠ SỞ DỮ LIỆU ĐỒ HOẠ MÁY TÍNH 5.2.1.GIỚI THIỆU Phần cứng của CAD chỉ có tác dụng và hoạt động với phần mềm kèm theo. Phần mềm đó ở đây gồm hai loại : • Phần mềm đồ hoạ. Đây là một bộ chương trình được viết ra nhằm tạo điều kiện cho người sử dụng vận hành hệ thống đồ hoạ máy tính (hệ ICG). Bộ chương trình này thường được sản xuất trọn gói nên còn có tên gọi gói phần mềm đồ hoạ, bao gồm những chương trình để tạo ra hình ảnh trên màn hình CRT, để điều khiển các hình ảnh đó và để thực hiện các kiểu tương tác khác nhau giữa ICG. AutoCAD là ví dụ điền hình về một bộ chương trình như vậy. Còn hệ ICG là một hệ thống đồ hoạ tương tác, ngoài phần mềm còn có phần cứng. • Phần mềm ứng dụng (kể cả những chương trình bổ trợ để thực hiện những chức năng đặc biệt có liên quan đến CAD/CAM): Bao gồm những phần mềm phân tích thiết kế (chẳng hạn như phân tích phần tử hữu hạn, mô phỏng động học cơ cấu...) và những phần mềm lập kế hoạch sản xuất - chế tạo (chẳng hạn như lập kế hoạch gia công tự động, lập trình vật làm điều khiển số...). Những phần mềm loaị thứ hai này sẽ được đề cập tới ở các chương sau, khi nghiên cứ về CAM. Phần mềm đồ hoạ dùng cho một hệ thống đồ hoạ máy tính cụ thể có tính đặc thù rất mạnh đối với phần cứng của hệ thống đó - có nghĩa là nó được viết ra chủ yếu là để chạy trên phần cứng đó của hệ thống. Vì thế, phần mềm phải được viết sao cho phù hợp với kiểu màn hình CRT và kiểu thiết bị vào được dùng trong hệ thống. Những chi tiết của phần mềm để chạy trên CRT quét vectơ sẽ phải có những điểm khác so với khi viết cho CRT quét dòng vì cấu tạo và nguyên tắc hoạt động của hai loại màn hình này không hoàn toàn giống nhau. Dẫu rằng những sự khác nhau như thế trong phần mềm nhiều khi người sử dụng không nhận
  5. C5 CAD-CAM>PC-PM CAD 5 GVC NGUYỄN THẾ TRANH ra, nhưng chúng lại rất quan trọng đối với người xây dựng một hệ thống đồ hoạ máy tính tương tác. Các nguyên tắc cơ bản cho việc thiết kế phần mềm đồ hoạ như sau : 1. Tính đơn giản : Phần mềm đồ hoạ phải dễ sử dụng. 2. Tính nhất quán : Goí phần mềm phải đem đến cho người sử dụng một phương pháp vận hành nhất quán và có thể dự đoán được các thao tác tiếp theo. 3. Tính đồng bộ : Không bỏ sót một chức năng nào đáng kể trong bộ chức năng đồ hoạ của phần mềm. 4. Tính bền vững : Chịu đựng được những sai phạm nhỏ trong vận hành của người sử dụng. 5. Tính hiệu quả : Với những hạn chế của phần cứng, phần mềm cần khai thác được đến mức tối đa khả năng của nó. 6. Tính kinh tế : Phần mềm không quá lớn hoặc quá đắt tiền đến mức khách hàng không chấp nhận được. 5.2.2. CẤU HÌNH PHẦN MỀM CỦA MỘT HỆ THỐNG ĐỒ HOẠ TƯƠNG TÁC (ICG) Khi người sử dụng vận hành một hệ ICG, có rất nhiều hoạt động khác nhau xảy ra. Có thể chia những hoạt động đó thành 3 loại : 1. Tương tác với thiết bị đầu cuối đồ hoạ để tạo ra và thay đổi những hình ảnh trên màn hình. 2. Kiến tạo nên một mô hình mà về mặt vật lý có thể vượt ra ngoài hình ảnh chứa trên màn hình. Đôi khi mô hình này còn được gọi là mô hình ứng dụng. 3. Nhập mô hình vào bộ nhớ trong (và cả bộ nhớ ngoài khi cần). Khi làm việc với hệ thống đồ hoạ, người sử dụng thực hiện những công việc theo cách phối hợp chứ không phải theo cách hết loại công việc nọ đến công việc khia. Người sử dụng kiến tạo nên một mô hình vật lý và nhập vào bộ nhớ bằng sự mô tả hình ảnh của mô hình đó cho hệ thống biết theo cách tương tác mà không cần suy nghĩ động tác nào thuộc vào loại nào trong ba loại kể trên. Sở dĩ phân ra như thế là để tương ứng với cấu hình tổng quát của một hệ phần mềm đồ hoạ dùng trong hệ ICG sẽ nói dưới đây. Theo truyền thống, người ta xác định cấu hình tổng quát của một hệ phần mềm đồ hoạ gồm có ba môdun sau : 1. Gói phần mềm đồ hoạ 2. Chương trình ứng dụng (mô hình ứng dụng) 3. Cơ sở dữ liệu đồ hoạ TRẠM THIẾT KẾ Thiết bị HỆ PHẦN MỀM ĐỒ HOẠ đầu cuối đồ hoạ CSDL chương trình Gói ứng dụng ứng dụng phần mềm Thiết bị đồ hoạ vào của người sử dụng Hình 5.2. Cấu hình của một hệ phần mềm đồ hoạ
  6. C5 CAD-CAM>PC-PM CAD 6 GVC NGUYỄN THẾ TRANH 1/ Chương trình ứng dụng : Đây là môdun trung tâm của hệ đồ hoạ. Nó là cái mô tả mô hình vật lý mà người sử dụng muốn thiết kế ra nên còn có tên là mô hình ứng dụng. Nó điều khiển sự lưu trữ dữ liệu vào cơ sở dữ liệu ứng dụng và gọi dữ liệu ra từ cơ sở dữ liệu ứng dụng. Nó được người sử dụng xây dựn nên thông qua gói phần mềm đồ hoạ. Chương trình ứng dụng được ngời sử dụng tạo ra để xây dựng mô hình của thực thể vật lý mà hình ảnh của nó sẽ thấy được trên màn hình đồ hoạ. Mỗi thực thể vật lý được mô tả bởi một chương trình ứng dụng và bao giờ cũng thuộc về những miền bài toán cụ thể. Những miền bài toán trong thiết kế kỹ thuật bao gồm kiến trúc, xây dựng, cơ khí, điện, công nghệp hoá chất... Những miền bài toán không thuộc về thiết kế thì có thể là các bộ trình mô phỏng bay, là hiển thị dữ liệu dưới dạng đồ hoạ, là phân tích toán học và thậm chí là mỹ nghệ. Trong mỗi trường hợp, chương trình ứng dụng được xây dựng nên để xử lý hình ảnh và các quy ước tương ứng với lĩnh vực đó. 2/ Gói phần mềm đồ hoạ: Đây là công cụ trợ giúp giữa người sử dụng và thiết bị đầu cuối đồ họa. Nó có nhiệm vụ quản lý sự tương tác đồ hoạ giữa người sự dụng và hệ thống. Đồng thời nó cũng hoạt đông với tư cách là giao diện giữa người sử dụng với chương trình ứng dụng. Gói phần mềm đồ họa bao gồm: • Các chương trình con (thường trình) Output. • Các chương trình con (thường trình) Input nhận lệnh và dữ liệu do người sử dụng đưa vào rồi tiếp tục đưa chúng tới chương trình ứng dụng. Các chương trình Output điều khiển màn hình (hoặc thiết bị ra khác) và chuyển đổi các mô hình ứng dụng thành những hình ảnh hai chiều hoặc ba chiều. 3/ Cơ sở dữ liệu ứng dụng : Đây là môdun thứ ba trong cấu hình của hệ phần mềm đồ hoạ, trong đó chứa những định nghĩa về toán học, về số và về logic của các mô hình ứng dụng như các mạch điện, các chi tiết máy, các bộ phận ôtô v.v.. Nó còn chứa những thông tin dưới dạng ký tự như bảng liệt kê vật liệu, thuộc tính hình học, khối lượng... Nội dung của cơ sở dữ liệu có thể sẵn sàng hiển thị lên màn hình CRT hoặc vẽ ra trên giấy. 5.2.3. CÁC CHỨC NĂNG CỦA MỘT GÓI PHẦN MỀM ĐỒ HOẠ Để đáp ứng đầy đủ vai trò của nó trong cấu hình hệ phần mềm nói trên, gói phần mềm đồ hoạ phải thực hiện rất nhiều chức năng khác nhau. Những chức năng này có thể gộp thành từng nhóm, mỗi nhóm thực hiện một kiểu tương tác nhất địn giữa người sử dụng và hệ thống (ICG). Có thể nêu lên một số nhóm thông dụng như sau: • Tạo sinh các yếu tố hình học: • Các phép chuyển đổi (quay, dịch chuyển...) • Điều khiển hiển thị (lên màn hình, lên giấy vẽ...) và các chức năng cửa sổ. • Các chức năng phân đoạn • Các chức năng Input 1/ Tạo sinh các yếu tố đồ hoạ Trong đồ họa, thuật ngữ “Entity” dùng để chỉ một yếu tố đồ họa hai chiều như điểm, đoạn thẳng, đường tròn, v.v... Bên cạnh đó còn phải kể đến bộ chữ cái, bộ chữ số cùng các ký hiệu đặc biệt khác, tạo nên bộ yếu tố đồ họa có trong hệ thống. Thường có một bộ phận phần cứng đặc biệt (một chip được cấy thêm vào card màn hình) nhằm tăng tốc độ của quá
  7. C5 CAD-CAM>PC-PM CAD 7 GVC NGUYỄN THẾ TRANH trình tạo sinh các yếu tố đồ họa và cho phép người sử dụng kiến tạo ra mô hình ứng dụng từ những yếu tố không thuộc vào các yếu tố có sẵn trong hệ thống. Thuật ngữ “Primitive” (nguyên thể) thường được dùng để chỉ một yếu tố đồ hoạ ba chiều như hình cầu, hình trụ hay lập phương. Trong mô hình khung dây ba chiều và mô hình đặc, các nguyên thể được sử dụng với tư cách là những khối cơ sở để xây dựng nên một mô hình ba chiều về đối tượng cụ thể mà người ta sử dụng đang quan tâm. 2/ Các phép chuyển đổi: Các phép chuyển đổi được dùng để thay đổi hình ảnh trên màn hình và để định vị lại các yếu tố trong cơ sở dữ liệu. Đó là công cụ giúp cho người sử dụng xây dựn mô hình ứng dụng theo ý muốn. Các phép chuyển đổi nói ở đây bao gồm phép dịch chuyển (tái định vị), phép quay, phép tỷ lệ (phóng to hoặc thu nhỏ)... 3/ Điều khiển hiển thị và các chức năng cửa sổ Nhóm chức năng này giúp người sử dụng quan sát hình ảnh từ một góc độ mong muốn và với môt tỷ lệ yêu cầu. Để làm được như vậy, các phép chuyển đổi đã được vận dụng để hiển thị mô hình ứng dụng theo cách mà người sử dụng mong muốn. Công việc này đôi khi được gọi là phép “Window” vì màn hình đồ họa được quan niệm như một khung cửa sổ qua đó người sử dụng nhìn vào mô hình. Chú ý rằng cửa sổ có thể đặt bất cứ đâu để nhìn vào đối tượng đang xét. Bên cạnh đó, khử bỏ nét khuất cũng thuộc nhóm chức năng này. Trong đa số hệ đồ họa, hình ảnh được tạo nên bởi những đường nét thể hiện một đối tượng cụ thể. Khử bỏ nét khuất là một thủ tục mà nhờ đó hình ảnh được chia ra thành những nét thấy được và không thấy được (hay những nét khuất). Ở một số hệ đồ hoạ, người thiết kế phải chỉ ra nét nào (hay phần nào của nét) không thấy được để khử bỏ khiến cho hình vẻ dễ hiểu hơn. Ở một số hệ khác, gói phần mềm đủ mạnh để tự động khử bỏ nét khuất. 4/ Chức năng phân đoạn : Các chức năng thuộc nhóm này cho phép người sử dụng thay thế, xoá có lựa chọn hoặc sửa chữa những phần hình ảnh mong muốn. Thuật ngữ “đoạn” dùng để chỉ một phần cụ thể của bản vẽ cần chọn ra để sửa chữa. Phép phân đoạn là phép chia một đối tượng phức tạp thành những bộ phận đơn giản hơn có thể quản lý được. Mỗi bộ phận như thế được gọi là một đoạn. Đoạn có thể là một phần tử đơn như đoạn thẳng, đường tròn, hoặc cũng có thể là một nhóm phần tử đơn nhưng về mặt logic thì vẫn được xem như một phần tử đơn mà ta có thể thao tác trên đó. Màn hình DVST không phù hợp với các chức năng phân đoạn vì muốn xoá hoặc sửa chữa chỉ một phần nhờ hình ảnh trên màn hình vẫn phải xoá toàn cảnh rồi vẽ lại. Màn hình quét dòng thích hơp một cách lý tưởng với các chức năng phân đoạn vì nó luôn được làm “tươi” bằng cách quét 30 lần hay trên 30 lần trong một giây (trong khi DVST không thể làm tươi nhanh được). Từ một tệp hiển thị, hình ảnh được tái sinh qua mỗi chu kỳ quét. Tập hiển thị này được lưu trữ trong một bộ phận cứng nằm trong CRT quét dòng (RAM của card màn hình). Một đoạn có thể dễ dàng xác định như là một phần của tệp hiển thị bằng cách đặt cho nó môt tên. Nội dung của phần đó của tệp nhờ vậy sẽ được xoá hoặc được thay thế tuỳ theo yêu cầu. 5/ Các chức năng Input của người sử dụng: Đây là nhóm cực kỳ quan trọng trong gói phần mềm đồ hoạ vì chúng cho phép người sử dụng đưa lệnh và dữ liệu vào cho hệ thống. Những công việc này được thực hiện nhờ các thiết bị Input. Các chức năng Input tất nhiên phải được viết sao cho phù hợp với các thiết bị vào cụ thể có trong hệ thống, đồng thời phải dễ nhơ, dễ làm quen và tiện lợi cho người sử dụng.
  8. C5 CAD-CAM>PC-PM CAD 8 GVC NGUYỄN THẾ TRANH Các chức năng Input cần được viết sao cho có thể khai thác đến mức tối đa lợi thế tương tác của hệ ICG. Một bản thiết kế phần mềm tốt vừa có đủ mọi chức năng đáp ứng mọi tình huống vào dữ liệu, lại vừa không có quá nhiều lệnh khiến người sử dụng ngập chìm trong đó. Tuy nhiên điều này rất khó đạt được đối với những gói phần mềm lớn và phức tạp. Một trong những hướng giải quyết chủ yếu là đơn giản hoá sự giao diện người - máy đến mức một người sử dụng không hiểu biết nhiều về máy tính cũng có thể khai thác phần mềm một cách hiệu quả cho mục đích chuyên môn của mình. Các phần mềm đồ họa chạy trong DOS gần đây và đặc biệt là chạy trong Windows là những ví dụ thành công theo hướng ấy. 5.2.4. XÂY DỰNG HÌNH HỌC 1. Sử dụng các yếu tố đồ hoạ Hệ thống đồ hoạ xây dựng các mô hình phức tạp từ những yếu tố đồ hoạ đơn giản. Các yếu tố này được người sử dụng gọi ra, sắp xếp cái này bên cạnh cái kia, thực hiện một số sửa chữa thích hợp để tạo ra mô hình. Có một số vấn đề cần quan tâm trong quá trình xây dựng như sau : a. Xác định kích thước, vị trí và phương chiều của yếu tố vừa mới được gọi ra trước khi thêm nó vào mô hình. Sự xác định này làm nhằm tạo ra cho yếu tố đó có tỉ lệ, kích thước và hình dạng thích hợp. Để làm việc này, người sử ụng cần đến các phép chuyển đổi (quay, dịch chuyển...) b. Các yếu tố đồ hoạ có thể cộng hoặc trừ với nhau theo cách tốt nhất để đưa vào mô hình. Như vậy, một mô hình có thể tạo ra từ những yếu tố dương cùng các yếu tố âm. c. Tạo khối : Khi xây dựng mô hình có thể gộp nhiều yếu tố đồ họa thành từng đơn vị gọi là khối hay block. Khối có thể được gọi ra để xử lý và xen vào bất kỳ nơi nào trên mô hình. Chẳng hạn mô hình bulông được tạo ra từ nhiều nét vẽ, đến lượt mô hình bulông này lại được định nghĩa là một khối và đặt cho một tên và cất vào bộ nhớ dưới tên đã đặt rồi gọi từ bộ nhớ ra qua tên gọi ấy để xen vào những nơi cần thiết trong bản vẽ lắp ghép đang hiển thị trên màn hình. 2. Xác định các yếu tố đồ họa. Có nhiều cách để gọi một yếu tố đồ hoạ cụ thể từ cơ sở dữ liệu ra để đặt nó vào vị trí mong muốn trong mô hình. Các yếu tố đồ hoạ thông qua tương tác với hệ ICG, được lưu trữ trong cơ sở dữ liệu dưới dạng toán học và được tham chiếu tới một hệ toạ độ ba chiều. Chẳng hạn một điểm được xác định một cách đơn giản bởi ba toạ độ x, y, z của điểm đó, hoặc một đa giác được xác định bởi một bộ gồm các đỉnh liên tiếp của đa giác ấy, hay một đường tròn được xác định bởi tâm và bán kính của nó, chẳng hạn về mặt toán học, một đường tròn trong mặt phẳng xOy có thể xác định bởi phương trình : (x - m)2 + (y - n)2 = r2 Trong đó r là bán kính, (m,n) là toạ độ của tâm vòng tròn trong mặt phẳng xOy. Trong mỗi trường hợp, định nghĩa toán học có thể chuyển đổi thành những điểm, những đường và những mặt tương ứng để lưu trong cơ sở dữ liệu và để hiển thị lên màn hình CRT
  9. C5 CAD-CAM>PC-PM CAD 9 GVC NGUYỄN THẾ TRANH Các phương pháp xác định các yếu tố đồ hoạ trong hệ ICG Yếu tố đồ hoạ Phương pháp xác định trong hệ ICG 1. Trỏ vào vị trí mong muốn trên màn hình bằng cách điều khiển con trỏ. 2. Nhập vào các toạ độ thông qua bàn phím. Điểm 3. Nhập vào offset (khoảng cách về x, y, z) so với một điểm đã có trước đó. 4. Giao điểm của hai đường. 5. Định vị các điểm tại những khoảng cách cố định dọc theo một yếu tố đồ hoạ đã cho. 1. Sử dụng hai điểm cho trước. 2. Sử dụng một điểm và một góc cho trước so với phương nằm ngang. 3. Sử dụng một điểm rồi từ điểm đó kẻ đường thẳng góc hay Đường thẳng tiếp tuyến với một đường cong cho trước. 4. Sử dụng một điểm và tại điểm đó kẻ đường song song hay thẳng góc với một đường thẳng cho trước. 5. Kẻ đường tiếp tuyến với hai đường cong cho trước. 6. Kẻ đường tiếp tuyến với một đường cong cho trước đồng thời song song hay thẳng góc với một đường thẳng cho trước. 1. Xác định tâm và bán kính. Cung tròn và 2. Xác định tâm và một điểm nằm trên cung hay đường tròn. đường tròn 3. Vẽ qua 3 điểm không thẳng hàng cho trước 4. Vẽ đường cong tiếp tuyến với 2 đường thẳng cho trước. 5. Xác định bán kính và vẽ đường cong tiếp tuyến với 2 đường thẳng hay 2 đường cong cho trước. Conics 1. Xác định 5 điểm nằm trên đường cong. (Ellipse, 2. Xác định 3 điểm và một điều kiện tiếp tuyến. Parabol, Hyperbol) Đường cong Các Spline toán học được sử dụng để tra vừa một đường cong thông qua dữ liệu cho trước. Các kỹ thuật tạo đường cong khác được sử dụng trong đồ hoạ máy tính bao gồm phương pháp đường cong Bezier và B-spline. Kết quả cho đường cong không chứa tất cả các điểm của dữ liệu. Trong các trường hợp này, các điểm dữ liệu thì được đưa vào hệ thống đồ hoạ còn các kỹ thuật đường cong tra vừa sẽ được chọn để xác định đường cong. Mặt cong Các phương pháp tạo đường cong ở trên cũng có thể dùng để xác định định nghĩa toán học của một mặt cong. 3. Edit hình học. Một hệ CAD nào cũng có khả năng Edit để tu sửa và điều chỉnh trong mô hình hình học như chèn, sao chép, dịch chuyển, quay v.v.. đối với các yếu tố đồ hoạ tạo nên mô hình đó.
  10. C5 CAD-CAM>PC-PM CAD 10 GVC NGUYỄN THẾ TRANH Một số khả năng Edit thông dụng trong một hệ CAD: Move, Copy, Rotate, Mirror, Delete, Remove, Trim (cắt bỏ phần đoạn thẳng vượt ra ngoài một điểm cho trước), Block, Scale. 5.2.5. CÁC PHÉP CHUYỂN ĐỔI. 1. Phép dịch chuyển. 2. Phép quay. 3. Phép tỷ lệ. 4. Phép dối xứng. 5.2.6. TỔ CHỨC VÀ NỘI DUNG CƠ SỞ DỮ LIỆU ĐỒ HOẠ. Cơ sở dữ liệu là một trong 3 mô đun tạo nên cấu hình của một hệ phần mềm đồ hoạ. Hầu như mọi chức năng của một hệ CAD là phụ thuộc vào cơ sở dữ liệu của nó. 1. Nội dung cơ sở dữ liệu. Bao gồm các mô hình, chương trình ứng dụng, các bản thiết kế, các bản vẽ, các bản lắp cùng các thông tin thuộc dạng ký tự như liệt kê vật liệu và các văn bản. Ngoài ra nó còn chứa nhiều thông tin của gói phần mềm đồ hoạ như các lệnh hệ thống, các Menu chức năng và các chương trình Ouput của máy vẽ. Cơ sở dữ liệu nằm trên RAM và tại bộ nhớ ngoài. 2. Tố chức của cơ sở dữ liệu. Nói chung một mô hình/chương trình ứng dụng được cấu trúc nên từ những thành phần sau đây: 1. Các yếu tố đồ hoạ như điểm, đoạn thẳng. 2. Hình dạng hình học của các bộ phận hợp thành của mô hình và sự bài trí của chúng trong không gian. 3. Topology hay cấu trúc liên kết của mô hình. 4. Dữ liệu riêng của mô hình như các thuộc tính vật liệu. 5. Các chương trình phân tích kỹ thuật riêng của mô hình. 5.2.7. MÔ HÌNH KHUNG DÂY VÀ MÔ HÌNH ĐẶC. 1. Tầm quan trọng của đồ hoạ 3 chiều. Các hệ CAD hiện đại đều có khả năng 3 chiều (3D). Đây là khả năng rất mạnh vì nó cho phép người thiết kế xây dựng mô hình đầy đủ 3 chiều của một vật thể chứ không phải là chỉ mô tả 2 chiều. Nó có thể cho phép tạo ra các hình chiếu trực giao, bản vẽ phối cảnh và đặc tả cận cảnh các chi tiết thuộc vật thể. 2. Mô hình khung dây. 3. Mô hình đặc.
  11. C6 CAD-CAM> ProEWF 1 GVC NGUYỄN THẾ TRANH Chương 6 PHẦN MỀM Pro/ENGINEER CHỨC NĂNG PHÁT THẢO CHỨC NĂNG CƠ BẢN - revolve, extrude, blend, - Các mặt phẳng toạ độ cho sweep trước. - Thực hiện tạo các hệ toạ độ cấu trúc và lắp ráp Tham số hoá Ý tưởng CHI TIẾT - gồm nhiếu kết cấu - đối xứng, quan hệ.. PHẦN LẮP RÁP TẠO MỘT BẢN VẼ - gồm nhiếu chi tiết - của chi tiết, lắp ráp, có - tạo các chi tiết trong kích thước phần lắp ráp - lập danh mục tự động - nghiên cứu sự giao nhau - mặt cắt, mặt cắt chi tiết … - lập thư viên
  12. C6 CAD-CAM> ProEWF 2 GVC NGUYỄN THẾ TRANH Parametric Technology Corporation * Pro/ENGINEER có cả phiên bản UNIX lẫn Windows (NT, 95, 98). Hiện nay, Pro/ENGINEER đã giới thiệu một giao diện mới. * Các verson Pro/E 2000i1, Pro/E 2000i2 chạy trên Win 98, các verson Pro/E 2001, Pro/E Wildfire chạy trên Win XP với card mạng. 6.1. CHỨC NĂNG PHẦN MỀM Pro/ENGINEER. • Đây là một trong số các bộ phần mềm CAD/CAM chuyên nghiệp và nổi tiếng trên thế giới. • Có cấu trúc lệnh đơn giản. • Phương thức giao tiếp rõ ràng và dễ sử dụng. Bộ phần mềm Pro/ENGINEER bao gồm có 5 môđun (chế độ) chương trình ứng dụng chính: a. Sketch : Vẽ phát thảo. b. Part : Tạo mẫu thiết kế, c. Assembly: Lắp ráp tạo mô hình. d. Manufacturing : Chế tạo e. Drawing : Tạo hình chiếu và bản vẽ kỹ thuật,
  13. C6 CAD-CAM> ProEWF 3 GVC NGUYỄN THẾ TRANH 6.2. TẠO MÔ HÌNH THEO THAM SỐ. Tạo mô hình theo tham số là một cách lập bản vẽ thiết kế có sự trợ giúp của máy vi tính mà Pro/E sử dụng. Các lệnh trong 2D CAD được chuyển sang Pro/E như: LINE, CIRCLE, ARC, DELETE, OFFSET, TRIM, MIRROR, COPY, ARRAY. Trên cơ sở đó, Pro/E có khả năng thực hiện các công việc: 1. Tạo mô hình dựa trên chi tiết (không gian dương hay âm) . 2. Vẽ phác hoạ (vẽ mặt cắt không cần đúng kích thước). 3. Tạo mô hình bằng sự cưỡng bức (vuông góc, song song, tiếp xúc, trùng khớp, thẳng đứng, nằm ngang). 4. Mối quan hệ giữa các chiều được thiết lập qua các công thức toán học. 5. Sự tham chiếu giữa các chi tiết (mối quan hệ phả hệ). Model TREE với các chức năng: xác định lại một chi tiết, xoá một chi tiết, sắp xếp lại trình tự các chi tiết, dựa vào các chi tiết và xoá các chi tiết. Các chi tiết chuẩn trong Pro/E: Mặt phẳng chuẩn: Trục chuẩn: Đường cong chuẩn: Điểm chuẩn: Hệ toạ độ: Mục đích của việc thiết kế: Khả năng đưa mục đích của việc thiết kế vào một mô hình là một tính năng độc đáo của Pro/E. Các chương trình tạo mô hình theo tham số có nhiều công cụ khác nhau để kết hợp các mục đích thiết kế, như: - Sơ đồ định kích cỡ. - Các hình thức cưỡng bức chi tiết. - Các hình thức cưỡng bức khối lắp ráp. - Các tham chiếu. 6.3. MÀN HÌNH LÀM VIỆC CỦA Pro/ENGINEER WILDFIRE. 6.3.1 Thanh Menu. Trong chế độ Part trong Pro/ENINEER, các tuỳ chọn trên thanh Menu gồm: 1. Menu File. 6. Menu Info: 2. Menu Edit. 7. Menu Applications: 3. Menu View. 8. Menu Utilities: 4. Menu Insert. 9. Menu Window: 5. Menu Analysis: 10. Menu Help.
  14. C6 CAD-CAM> ProEWF 4 GVC NGUYỄN THẾ TRANH 6.3.2 Thanh công cụ. 1. Nhóm quản lý file: New, Open, Save, Save A Copy, Print. 2. Nhóm hiển thị khung xem: Repaint, Zoom in, Zoom Out, Refit, Orient, Saved Views. 3. Nhóm hiển thị mô hình: nhằm thay đổi cách hiển thị các đối tượng trong Pro/ENGINEER: Wireframe (theo khung dây), Hidden Line (có nét ẩn), No Hidden (không có nét ẩn), Shade (tạo bóng đổ), Model Tree. 4. Nhóm hiển thị các chi tiết chuẩn: điều chỉnh cách hiển thị các chi tiết chuẩn: Datum Planes (tắt mở hiển thị các mặt phẳng chuẩn), Datum Axes (tắt mở hiển thị các trục chuẩn), Point Symbold (tắt mở hiển thị các điểm chuẩn), Coordinate Systems (tắt mở hiển thị các hệ toạ độ). 5. Nhóm Context - Sensitive Help: dùng để hiển thị thông tin trợ giúp về các menu riêng lẽ hay các tuỳ chọn trong hộp thoại. 6.4 CÁC CHỨC NĂNG THÔNG THƯỜNG. 6.4.1 Quản lý file. Lệnh mở và lưu file trong Pro/ENGINEER có một số điểm khác biệt quan trọng giữa tính năng quản lý file trong trình ứng dụng của Windows: • Tên file trong Pro/E đòi hỏi chặt chẽ hơn. • Việc lưu một đối tượng trong Pro/E sẽ tạo ra một phiên bản mới. • Pro/E không cho phép một đối tượng được lưu với một tên file đã được đặt trước đó, tức là không lưu trên một file hiện có.
  15. C6 CAD-CAM> ProEWF 5 GVC NGUYỄN THẾ TRANH 1. Tên file. Bảng 5.1; các tên file mở rộng với các chế độ trong Pro/E CHẾ ĐỘ PHẦN MỞ RỘNG Sketch *.sec* Part *.prt* Assembly *.asm* Manufacturing *.mfg* Drawing *.drw* Format *.frm* Bảng 5.2: Các tên file không có hiệu lực và có hiệu lực Tên file không có Sự cố Tên file có hiệu lực hiệu lực Part one Có khoảng trống trong tên file part_one Part@ 11 Có ký tự không phải chữ hay số part_11 Part[1_10] Trong tên file có sử dụng dấu ngoặc part_1_10 2. Bộ nhớ. 3. Thư mục hiện hành. 4. Mở một đối tượng: dùng hộp thoại File Open: bước 1: Chọn FILE>>OPEN để hiển thị hộp thoại File Open. bước 2: Chọn thư mục có chứa đối tượng như minh hoạ bước 3: Chọn đối tượng cần mở. bước 4: Chọn Open trong hộp thoại. 5. Tạo một đối tượng mới. bước 1: Chọn FILE>>NEW để hiển thị hộp thoại New. bước 2: Chọn một loạt kiểu chế độ và kiểu phụ của Pro/E. bước 3: Nhập vào một tên file. bước 4: Chọn OK từ hộp thoại. 6.4.2 Lưu một đối tượng. Có nhiều tuỳ chọn có thể được dùng để lưu các đối tượng: 1. Save ; 2. Lưu một bản sao; 3. Backup; 4. Rename; 5. Delete 6. Erase; 7. Kích hoạt một đối tượng. 5.4.3 Xem các mô hình. Có nhiều cách để xem một đối tượng hoặc thay đổi kiểu hiển thị một mô hình. 7. Xem động, 1. Shaded Display 8. Dynamic Zoom 2. Định hướng hình chiếu 9. Dynamic Rotate 3. Angle 10. Dynamic Pan 4. Dynamic Orientation 11. Wireframe Display 5. Orientation By Reference 12. Hidden Display 6. Đặt tên và lưu các hình 13. No Hidden Display chiếu.
  16. C6 CAD-CAM> ProEWF 6 GVC NGUYỄN THẾ TRANH 6.4.4 Thiết lập một mô hình. 1. Các đơn vị. Pro/E có 4 loại đơn vị chính: Độ dài, khối lượng, thời gian và nhiệt độ. • Thiết lập một hệ thống đơn vị: Từ hộp thoại Unit Manager ta truy cập các hệ thống đơn vị: KMS, CGS, mmNS, FPS, IPS, Pro/E default. • Tạo một hệ thống đơn vị: 2. Chất liệu. • Ấn định một chất liệu: - Bước 1: Chọn SET UP>>MATERIALS>>DEFINE - Bước 2: Nhập vào một tên chất liệu. - Bước 3: Nhập vào các tham số có liên quan đến chất liệu. • Lưu một chất liệu vào đĩa: Các chất liệu được tạo cho một thành phần không được tự động lưu vào đĩa. Để lưu đặc tính của mọt chất liệu để các thành phần khác có thể sử dụng thì chất liệu đó phải được lưu ở một vị trí lâu dài. - Bước 1: Chọn SET UP>>MATERIALS>>WRITE - Bước 2: Chọn đặc tính của một chất liệu cần lưu vào đĩa. - Bước 3: Nhập vào một tên cho file lưu chất liệu đó. • Gán các chất liệu: - Bước 1: Chọn SET UP >> MATERIALS >> ASSIGN - Bước 2: Chọn FROM PART hay FROM FILE làm nguồn gán chất liệu. 3. Xác lập dung sai kích thước. Dung sai là khoảng dao động cho phép về hình dáng và kích thước của một chi tiết. Theo mặc định Pro/E hiển thị các dung sai ở dạng giá trị tiêu chuẩn. Có 4 dạng hiển thị dung sai: Nominal; Limits; Plusminus; Plusminussym. • Tiêu chuẩn dung sai ANSI: được xác lập trước tiên dựa trên các giá trị được tìm thấy trong file cấu hình. • Tiêu chuẩn dung sai ISO: 6.5. TẠO MỘT BẢN PHÁC THẢO (Chế độ Sketch). Phác thảo là một kỹ năng cơ bản của Pro/E. Các chi tiết hình học như Protrusion hay Cut yêu cầu sử dụng một bản phác thảo để xác định mặt cắt của các chi tiết. 6.5.1 Các điểm cơ bản về phác thảo. Các phần phác thảo được kết hợp với các kích thước (DIMENSION), ràng buộc (CONSTRAINT) và tham chiếu (REFERENCE) hình thành một mặt cắt. Các phần kéo, đùn, phần cắt, trục và gờ là ví dụ về các chi tiết đòi hỏi một mặt cắt phát thảo.
  17. C6 CAD-CAM> ProEWF 7 GVC NGUYỄN THẾ TRANH Mặt phẳng phát thảo có thể là một bề mặt của chi tiết hay mặt phẳng, hay có thể là một mặt phẳng số liệu không hiện hữu trên một bộ phận nào, nó được tạo ra nhờ tuỳ chọn Make Datum và không được xem là các chi tiết và không hiển thị. Thông tin mặt cắt: Menu Sketch cung cấp các tuỳ chọn để nhận được thông tin về các thực thể trong môi trường phác thảo hiện hành: Distance, Angle, Entity, Intersection point, Tangency point, Curvature. 6.5.2 Constraint. Một Constraint là một quan hệ được ấn định hiện hữu giữa 2 thực thể hình học ( song song, thẳng góc, bằng nhau...) - Các Constraint với Intent Manager: Các Constraint được tạo trong khi phác thảo. - Các Constraint với Intent Manager được tắt: Không có tuỳ chọn nào để người dùng áp dụng một constraint sau khi tạo lại một mặt cắt. - Các tuỳ chọn Constraint: Intent Manager cho phép áp dụng động các Constraint vào các thực thể được phác thảo thông qua các tuỳ chọn: Same points * , Horizontal H , Vertical V , Point on entity, Tangent T , Perpendicular, Parallel, Equal Radii R , Equal lengths L , Symetric, Line up horizontal, Line up vertical, Collinear, Alignment. 6.5.3 Các tuỳ chọn hiển thị phác thảo. Undo và Redo, Parallel sketch plane (Mặt phẳng phác thảo song song), Dimension Display (Hiển thị kích thước), Constraint Display (Hiển thị ràng buộc), Grid Display (Hiển thị lưới), Vertex Display (Hiển thị đỉnh). 6.5.4 Phác thảo với Intent Manager. 6.5.5 Phác thảo không sử dụng Intent Manager. 6.6. KÉO, CHỈNH SỬA VÀ ẤN ĐỊNH LẠI CÁC CHI TIẾT. Khái niệm các chi tiết kéo đi cùng với các điểm cơ bản về lập mô hình. Trong Pro/E, tuỳ chọn Extrude thường được sử dụng giữa các lệnh Protrusion và Cut. Lệnh Redefine cung cấp các kỹ thuật chỉnh sửa chi tiết và tạo số liệu. 6.6.1 Định nghĩa: Chi tiết cơ sở: Chi tiết hình đầu tiên được tạo trong một bộ phận, là chi tiết bố cho tất cả các chi tiết khác.
  18. C6 CAD-CAM> ProEWF 8 GVC NGUYỄN THẾ TRANH Chi tiết con. Phần cắt: Một chi tiết khoảng trống âm. Phần ấn định: Một tham số của bộ phận, như chiều sâu của lỗ. Phần kéo: Một chi tiết khoản trống dương. Chi tiết khoảng trống âm: Xoá chất liệu ra khỏi một mô hìnhn như các lỗ, phần cắt, khe. Chi tiết khoảng trống dương: Thêm chất liệu vào một mô hình như các phần kéo, trục, gờ. 6.6.2. Lập mô hình dựa vào chi tiết. 6.1 Hình học là sự mô hình một chi tiết bằng hình ảnh được xác định bằng phác thảo hay được ấn định sẵn. Các gói phần mềm thiết kế thường được xem là các bộ lập mô hình dựa trên chi tiết. Một chi tiết là một thành phần con của một bộ phận có các tham số, các tham chiếu và hình riêng của nó. 6.6.3 Quan hệ bố - con. Các chi tiết được tạo dựa vào những chi tiết khác theo một cách giống như cây gia phả, đó là một cây lịch sử về các mối quan hệ giữa các chi tiết trong một mô hình Pro/E giống như một mạng. Mối quan hệ này có thể được thiết lập một cách trực tiếp (một chi tiết được sử dụng để cấu tạo một chi tiết khác) hay gián tiếp (thông qua việc bổ sung một phương trình số bằng cách sử dụng tuỳ chọn Relations).
  19. C6 CAD-CAM> ProEWF 9 GVC NGUYỄN THẾ TRANH 6.6.4 Chi tiết thứ nhất. Việc xác định chi tiết nào là chi tiết thứ nhất hay chi tiết cơ sở của một bộ phận sẽ là một quyết định quan trọng và nó sẽ trở thành chi tiết bố trong bọ phận đó. Có 3 chi tiết đầu tiên có thể có của một bộ phận: 1. Mặt phẳng số liệu: Theo mặc định các mặt phẳng số liệu mặc định được đặt tên là DTM1, DTM2 và DTM3 dùng làm hệ tham chiếu. 2. Phần kéo: Lệnh Protrusion tạo một chi tiết hình học. Ví dụ về các phần kéo bao gồm các chi tiết được kéo, được xoay và được quét. 3. Một chi tiết do người dùng ấn định: Chi tiết đã được lưu sẵn. 6.6.5 Các bước để tạo một bộ phận mới. 1. Thiết lập thư mục làm việc chính xác. 2. Tạo một đối tượng mới với Template mặc định của Pro/E. 3. Thiết lập mô hình. 4. Chọn phương pháp tạo chi tiết: Protrusion là công cụ chính có sẵn đối với bộ phận đặc. 5. Thiết lập mặt phẳng phác thảo 5. Phác thảo mặt cắt của chi tiết. 6. Hoàn chỉnh chi tiết. 7. Thực hiện các yêu cầu quản lý file. 6.6.6 Các phần kéo và phần cắt. Các thủ tục để thực hiện một phần kéo (Protrusion) và cắt (Cut) hầu như hoàn toàn giống nhau. Extrude: Quét một mặt cắt phác thảo dọc theo một quĩ đạo thẳng. Revolve: Quét một mặt cắt quanh một đường tâm. Sweep: Kéo một mặt cắt dọc theo quỹ đạo nào đó do người dùng phác thảo. Blend: Nối 2 hay nhiều mặt cắt phác thảo, quỹ đạo có thể thẳng hay được xoay. Advanced: Gồm các tuỳ chọn: Variable Section Sweep, Swept Blend và Helical Sweep.
  20. C6 CAD-CAM> ProEWF 10 GVC NGUYỄN THẾ TRANH Hình 6.2

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản