intTypePromotion=1

Hướng dẫn sử dụng Orcad 10.5

Chia sẻ: TRẦN VĂN THUẤN THUẤN | Ngày: | Loại File: PDF | Số trang:62

0
138
lượt xem
22
download

Hướng dẫn sử dụng Orcad 10.5

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Bạn đã từng thiết kế mạch, bạn muốn kiểm tra, phân tích sản phẩm của mình có đúng với ý tưởng của mình không? Bạn mong muốn sản phẩm của mình được ứng dụng vào thực tế. Những công đoạn như vậy hãy để Orcad chia sẽ cùng bạn. Phiên bản Orcad 10.5 sẽ là "người trợ lý" đắc lực của bạn trong việc vẽ sơ đồ nguyên lý, chạy mô phỏng và đặc biệt vẽ mạch in.

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn sử dụng Orcad 10.5

I NÓI U<br /> <br /> B n ã t ng thi t k m ch , b n mu n ki m tra, phân tích s n<br /> ph m c a mình có úng v i ý t ng c a mình không ? B n mong<br /> mu n s n ph m c a mình nhanh chóng c ng d ng vào th c t .<br /> Nh ng công n nh v y hãy OrCAD chia s cùng b n . Phiên<br /> n OrCAD 10.5 s là “ng i” tr lý c l c c a b n trong vi c v<br /> nguyên lý, ch y mô ph ng và c bi t là v m ch in .<br /> Chính kh n ng ng d ng và s c m nh c a nó ã c kh ng<br /> nh và ch ng minh b ng th c t trong nghành n t c a chúng<br /> ta .<br /> <br /> Nh ng ngày qua, tôi là ng i nh n nhi m v tìm hi u , nghiên<br /> u và s là ng i gi i thi u tr c ti p ph n m m OrCAD n v i<br /> các b n, Chúng tôi ã t ng k t k t qu lao ng c a mình trong<br /> t giáo trình sau ây .Chúng tôi hy v ng r ng , v i cu n giao<br /> trình này s cung c p cho các b n m t cách t ng quát nh t các<br /> công c và l nh các b n khai thác có hi u qu nh t, giúp ích cho<br /> công vi c thi t k c a b n. S c m nh c a OrCAD ã c kh ng<br /> nh và chúng ta không ph i bàn v nó n a, cái mà ta quan tâm bây<br /> gi chính là “làm th nào khai thác và s d ng nó trong công<br /> vi c c a mình”.<br /> Hy v ng các b n có nh ng ng d ng hi u qu v i ph n m m<br /> OrCAD 10.5<br /> Trong quá trình biên so n không tránh nh ng sai sót, kính<br /> mong các b n b sung, góp ý giáo trình c a chúng tôi hoàn<br /> ch nh h n.<br /> <br /> <br /> <br /> Nhóm 7 -l p 03 T1<br /> Khoa TVT - H Bách khoa N<br /> cl c<br /> <br /> Ch ng 1: v s nguyên lý<br /> 1.1:Kh i ng CAPTURE CIS<br /> 1.2: Gi i thi u các thanh công c<br /> 1.3 :Cách l y linh ki n<br /> 1.4: Cách s p x p linh ki n<br /> 1.5 N i dây<br /> 1.6 Thay i giá tr linh ki n.<br /> 1.7 L u và ki m tra s nguyên lý.<br /> 1.8 Th c hành v s nguyên lý.<br /> Ch ng 2: m ch in<br /> 2.1:Kh i ng Layout Plus<br /> 2.2 Ch n chân linh ki n:<br /> 2.2.1Các th vi n chân thông d ng trong ORCAD<br /> 2.2.2 T o chân linh ki n m i:<br /> 2.3 Xoá các ký t không c n thi t trên s chân<br /> 2.4 Di chuy n linh ki n :<br /> 2.5 Ch n l p m ch in:<br /> 2.6 Ch n kích th c ng m ch in<br /> 2.7 Xác nh chân âm c a ngu n.<br /> 2.8 V khung m ch in<br /> 2.9 V m ch in.<br /> 3.9.1 V t ng<br /> 3.9.2V m ch in b ng tay<br /> 2.10 ng:<br /> 2.11.T o text cho m ch in<br /> <br /> Ch ng 3: Mô ph ng trong ORCAD 10.5<br /> 3.1 V s m ch mô ph ng3.1.1 Th vi n trong m ch mô ph ng<br /> 3.1.2 Các ngu n c s d ng trong mô ph ng<br /> 3.2. Các thanh công c trên c u s orcad capture h tr cho vi c mô ph ng c a b n:<br /> 3.3.Các lo i mô ph ng trong ORCAD 10.5<br /> 3.4. Các b c ti n hành mô ph ng<br /> 3.4.1 Mô ph ng t ng t :<br /> 3. 4.1.1 Mô ph ng transient:<br /> 3.4.1.2 .Quét DC<br /> 3.4.1.2.1 : Quét DC s c p (DC sweep priman<br /> 3.4.1.2.2 Quét DC th c p:(secondary sweep)<br /> 3.4.1.3 Quét AC:<br /> 3.4.1.4.Phân tích nhi u :<br /> 3.4.2 Mô ph ng s :<br /> Ch ng 1 : S NGUYÊN LÝ<br /> <br /> 1.1 Kh i ng CAPTURE<br /> v s nguyên lý ta dung giao di n màn hình Capture Cis.<br /> Ch n Start > Program > OrCAD Release 10.5 > Capture Cis<br /> <br /> <br /> <br /> <br /> Sau ó bi u t ng c a ch ng trình OrCAD Capture xu t hi n trên màn hình<br /> <br /> <br /> <br /> <br /> Trong c a s này chon File > New > Project. t o s nguyên lý m i h p<br /> tho I New Project xu t hi n t i m c Name nh p vào tên s m i.<br /> Tai muc Create a New Project Using nh p ch n Shematic t i m c Location<br /> tên ng d n ch a t p tin m I sau dó nh p chu t vào nút OK<br /> <br /> <br /> C a s OrCAD Capture dung v s nguyên lý xu t hi n.Trong c a s<br /> y ta th y các thanh công c dung v s nguyên lý n m d c góc ph i màn hình<br /> làm vi c.<br /> 1.2 Gi i thi u v thanh công c<br /> Các bi u t ng thanh công c th ng dung.<br /> <br /> Select : Hoàn t t m t thao tác.<br /> <br /> <br /> Place part : Vào c a s ch n linh ki n.<br /> <br /> Place wire : N I dây .<br /> <br /> Place net alias : t tên cho ng dây n i.<br /> Place bus :V ng Bus.<br /> Place junction : T o giao m gi a các ng n i.<br /> <br /> Place power : Ngu n n.<br /> Place ground : N I mass.<br /> <br /> Place port : Ch n c ng.<br /> <br /> Place text : T o ch .<br /> <br /> Design rules check : Ki m tra m ch.<br /> <br /> Create netlist : T o t p tin có uôi .mnl thi t k m ch in.<br /> <br /> 1.3 Cách l y linh ki n.<br /> Có 2 cách :<br /> Trong c a s OrCAD Capture hãy nh p ch n Place >Part.<br /> Ho c nh p vào bi u t ng Place Part trên thanh công c .<br /> <br /> <br /> <br /> <br /> H p tho I Place Part xu t hi n .<br /> Vì trong th m c Libraries ch a có các m c ch a các linh ki n ta c n nên hãy nh p chu t<br /> vào nút Add Library ch n các th vi n ch a linh ki n ta c n. Sau ó kích vào nút Open.<br /> Ho c n u ta bi t c tên th vi n và linh ki n ta c n thi hãy ánh tên th vi n vào<br /> c Libraries ,và tên linh ki n vào m c Part trong c a s Place Part. Ch n xong ta<br /> kích chu t vaò nút OK ch n linh ki n.<br /> T i màn hình làm vi c lúc này t I u con tr chu t xu t hi n hình d ng linh ki n ta<br /> ch n.Sau ó nh p chu t vào các v trí trên màn hình va sau do nh p vào bi u t ng<br /> Select trên thanh công c k t thúc vi c l y linh ki n.<br /> <br /> 1.4 Cách s p x p linh ki n.<br /> s p x p linh ki n, nh p chu t vào bi u t ng linh ki n, lúc này linh ki n i màu<br /> sau ó gi và di chuy n linh ki n n v trí thích h p, nh p chu t t linh ki n.<br /> Trong quá trình s p x p linh ki n co th quay linh ki n m t góc 90 ho c có th l t<br /> linh ki n i x ng theo tr c X hay Y b ng cách nh p ch n linh ki n , linh ki n i màu<br /> sau ó nh p ph i chu t va chon l nh Rotate ho c Mirror Horizontally hay Mirror<br /> Vertically t trên xu ng. Ho c ta có th nh n phím R trên bàn phím quay linh ki n<br /> theo góc 90 ô.<br /> <br /> <br /> <br /> <br /> Trong ó:<br /> Mirror Horizontally: i x ng theo tr c hoành.<br /> Mirror Vertically : i x ng theo tr c tung.<br /> Rotate : xoay góc 90 ng c chi u kim ng h .<br /> Có th c t, copy, xoá, phóng to( Zoom In), thu nh ( Zoom Out) ho c chuy n n<br /> trí khác trên b n v ( Go To…).<br /> Edit Properties.(ho c có th double-click vào linh ki n) : hi u ch nh thông s linh<br /> ki n, s xu t hi n box: (Hình 1.8).<br /> 1.5 N i dây .<br /> n i dây chon Place > Wire ho c nh p vào bi u t ng Place Wire trên thanh công<br /> .<br /> Kích chu t trái b t u n i dây, rê chu t n i t chân linh ki n này n chân linh ki n<br /> khác. K t thúc n i dâyb ng c ách ch n nút l nh Select.<br /> N u mu n v các ng BUS ,ch nbi u t ng Place Bus trên thanh công c v .<br /> Mu n t tên cho ng dây trên m ch n ,ch n bi u t ng Place net Alias trên thanh công<br /> va ánh tên ng dây.<br /> 1.6 Thay i giá tr linh ki n.<br /> Mu n thay I giá tr linh ki n theo úng s nguyên lý, nh p úp chu t vào giá<br /> tr linh ki n . Khi ó h p tho i Edit Part xu t hi n, tai m c Value nh p giá tr c n thay<br /> i , sau ó nh p chu t vào nút OK ch p nh n thi t t m i này.<br /> <br /> <br /> <br /> <br /> Ho c kích úp chu t vào linh ki n , h p tho i edit properties và sau ó hi u ch nh<br /> nh ng thông s c n thi t .<br /> 1.7 L u và ki m tra s nguyên lý.<br /> Khi hoàn thanh xong s nguyên lý, l u lai s vào bi u t ng Save document<br /> trên thanh công c l ul is v a v .H p tho i OrCAD Capture xu t hi n h i b n<br /> có mu n l u t t c s nguyên lý không . Nh p OK ch p nh n.<br /> <br /> <br /> <br /> <br /> Nh p vào nút Restore trên thanh công c thu nh màn hình làm vi c<br /> Kích ho t c a s qu n lý Project nh p ch n trang s v a thi t k , sau ó nh p<br /> vào bi u t ng Design rules check trên thanh công c ki m tra s .<br /> H p tho i Design Rules Check xu t hi n , nh p OK ti n hành ki m tra.<br /> <br /> <br /> <br /> <br /> Nh p ch n bi u t ng Create netlist trên thanh công c t o t p tin netlist co<br /> uôi m r ng .MNL.<br /> H p tho i OrCAD Capture xu t hi n thong báo cho b n bi t thi t k b n v a t o s<br /> c l u trong danh sách m ng.Nh p OK ch p nh n.<br /> <br /> <br /> <br /> <br /> Nh p ph i chu t vào bi u t ng c a ch ng trình sau ó ch n l nh Close t menu<br /> xu ng óng ch ng trình v m ch nguyên lý.<br /> Chuy n sang t o m ch in t s nguyên lý v a thi t k b ng cách dung ch ng<br /> trình Layout.<br /> 1.8 Th c hành v s nguyên lý.<br /> Ví d v m ch u khi n t c ng c nh hình v sau.<br /> <br /> <br /> <br /> <br /> S nguyên lý trên g m các linh ki n: 3 n tr R, 1 bi n tr , 1 t có c c tính, 1<br /> diode th ng, 1 SCR, 2 Port hai chân c m.<br /> v s ch n Start > Programs > OrCAD Release 10.5 > Capture Cis.<br /> Khi c a s OrCAD Capture xu t hi n , trong c a s này ch n File > New > Project<br /> t os nguyên lý m i.<br /> H p tho i New Project xu t hi n, t i m c Name nh p vào tên U KHI N T C<br /> NG C .Tai muc Create a New Project Using nh p ch n Shematic nh p vào<br /> nút Browse ho c nh p vào m c Location tên ng d n ch a t p tin m i sau dó nh p<br /> chu t vào nút OK.<br /> C a s OrCAD Capture dung v s nguyên lý xu t hi n.<br /> Trong c a s OrCAD Capture hãy nh p ch n Place >Part.<br /> Ho c nh p vào bi u t ng Place Part trên thanh công c .<br /> <br /> <br /> <br /> <br /> H p tho i Place Part xu t hi n .<br /> Vì trong th m c Libraries ch a có các m c ch a các linh ki n ta c n nên hãy nh p<br /> chu t vào nút Add Library ch n các th vi n ch a linh ki n ta c n. Sau ó kích vào<br /> nút Open.<br /> H p tho i Browse File xu t hi n nh p chu t vào th vi n Connector r i nh n phím<br /> Ctrl trên bàn phím và nh p chu t vào m c Dicrete. . Sau ó kích vào nút Open.<br /> Khi ó h p tho i Place Part xu t hi n , trong h p tho i này t i m c Libraries chon<br /> th vi n DICRETE ,tai m c Part nh p vào kí t R ho c nh p chu t vào thanh tr t kéo<br /> lên xu ng ch n R.Ch n xong nh p chu t vào nút OK.<br /> T i màn hình làm vi c lúc này t i u con tr chu t xu t hi n hình d ng n tr<br /> R.Nh p chu t vào 3 v trí khác nhau trên màn hình làm vi c ch n 3 linh ki n n tr<br /> R sau ó nh p vào bi u t ng Select trên thanh công c k t thúc viêc l y n tr .<br /> <br /> <br /> <br /> <br /> ch n bi n tr , b ng cách nh p ch n vào bi u t ng Place Part .H p tho i Place<br /> Part xu t hi n này t i m c Libraries chon th vi n DICRETE ,tai m c Part ch n<br /> RESISTOR VAR.Ch n xong nh p chu t vào nút OK.<br /> <br /> <br /> <br /> <br /> Tr l i h p tho I Place Part , ch n t phân c c trong th vi n DISCRETE b ng<br /> cách ch n CAPACITOR POL trong m c Part c a th vi n này. Nh p OK ch n linh<br /> ki n.<br /> C ng trong th vi n DISCRETE ch n DIODE trong m c Part. Sau ó nh p OK<br /> ch n linh ki n.<br /> Trong th vi n DISCRETE ch n SCR ng cách ch n EC103M/T t I m c Part .Sau<br /> ó nh p OK ch n.<br /> Ch n Port hai chân c m trong th vi n CONNECTOR b ng cách t I m c Libraries<br /> ch n th vi n CONNECTOR, sau ó t I m c Part chon CON2. Nh p OK ch n linh<br /> ki n.<br /> Sau khi k t thúc vi c l y linh ki n , trên màn hình thi t k các linh ki n s p x p nh<br /> sau.<br /> S p x p linh ki n .<br /> s p x p linh ki n, nh p chu t vào bi u t ng linh ki n,lúc này linh ki n i<br /> màu sau ó gi và di chuy n linh ki n n v trí thích h p, nh p chu t t linh ki n<br /> Trong quá trình s p x p linh ki n co th quay linh ki n m t góc 90 ho c có th<br /> t linh ki n i x ng theo tr c X hay Y b ng cách nh p ch n linh ki n , linh ki n i<br /> màu sau ó nh p ph i chu t va chon l nh Rotate ho c Mirror Horizontally hay Mirror<br /> Vertically t trên xu ng. Ho c ta có th nh n phím R trên bàn phím quay linh<br /> ki n.<br /> Sau khi s p x p linh ki n xong ta ti n hành n I dây b ng cách ch n Place > Wire ho c<br /> nh p vào bi u t ng Place Wire trên thanh công c .<br /> <br /> <br /> <br /> <br /> Khi s p x p linh ki n và n i dây xong , ta có cs nguyên lý sau:<br /> Mu n thay i giá tr linh ki n theo úng s nguyên lý, nh p úp chu t vào linh<br /> ki n. Khi ó h p tho i Edit Part xu t hi n, tai m c Value nh p giá tr c n thay i , sau<br /> ó nh p chu t vào nút OK ch p nh n thi t t m i này<br /> <br /> <br /> <br /> <br /> Lúc này ta có cs hoàn ch nh nh sau.<br /> Vào bi u t ng Save document trên thanh công c l ul is v a v .H p tho i<br /> OrCAD Capture xu t hi n h i b n có mu n l u t t c s nguyên lý không . Nh p<br /> chon OK ch p nh n.<br /> <br /> <br /> <br /> <br /> Nh p vào nút Restore trên thanh công c thu nh màn hình làm vi c.<br /> Kích ho t c a s qu n lý Project nh p ch n trang s v a thi t k , sau ó nh p<br /> vào bi u t ng Design rules check trên thanh công c ki m tra s .<br /> H p tho i Design Rules Check xu t hi n , nh p OK ti n hành ki m tra.<br /> <br /> <br /> <br /> <br /> Nh p ch n bi u t ng Create netlist trên thanh công c t o t p tin netlist co uôi<br /> r ng .MNL.<br /> H p tho i Create Netlist xu t hi n , trong h p tho i này ch n nhãn Layout , t i m c<br /> Netlist File nh p vào th m c ch a t p tin .MNL s c t o sau o nh p OK.<br /> <br /> <br /> <br /> <br /> H p tho i OrCAD Capture xu t hi n thong báo cho b n bi t thi t k b n v a t o s<br /> c l u trong danh sách m ng.Nh p OK ch p nh n.<br /> Nh p ph I chu t vào bi u t ng c a ch ng trình sau ó ch n l nh Close t menu<br /> xu ng óng ch ng trình v m ch nguyên lý.<br /> Ch ng 2: V M CH IN V I LAYOUT PLUS<br /> ( ORCAD 10.5)<br /> :<br /> 2.1:Kh i ng Layout Plus:<br /> <br /> T Start-> All Program->Orcad 10.5-> Layout plus<br /> <br /> <br /> <br /> <br /> Trên màn hình xu t hi n c a s layuot<br /> - menu File-> New. xu t hi n H p tho i AutoECO<br /> <br /> -Trong h p tho i AutoECO<br /> T i m c Input Layout TCH or TPL or MAXfile t Browse ch n default.tch theo<br /> ng d n C:/ Orcad 10.5/tools/layout_plus/data.<br /> <br /> <br /> <br /> <br /> T i m c Input MNL netlist file,t Browse ch n file mang tên m ch c n v m ch in có<br /> uôi .MNL<br /> Nh p Apply ECO, xu t hi n h p tho i Link Footprint to component<br /> <br /> <br /> <br /> <br /> 2.2 Ch n chân linh ki n:<br /> B c ti p theo b n ti n hành ch n chân linh ki n b ng cách Nh p ch n Link<br /> existing footprint to component….<br /> Vi c ch n chân linh ki n c n liên h v i chân linh ki n th c t , nh t là v n v kích<br /> th c , n u trong th vi n chân không áp ng yêu c u th c t thì ta có th t o linh ki n<br /> i phù h p h n(s c gi i thi u sau).<br /> 2.2.1Các th vi n chân thông d ng trong ORCAD.<br /> -JUMPER (2 chân ) v i các kích th c khác nhau nh :JUMPER 100, JUMPER<br /> 200, JUMPER300….<br /> <br /> <br /> <br /> <br /> -TO(Ch a các linh ki n 3 chân ) nh :TO126, TO202AC,TO202AB…v i hình d ng<br /> và kích th c khác nhau .<br /> - DIP100T :ch a các chân linh ki n dành cho các chíp v i s chân và kích th c<br /> khác nhau .<br /> 2.2.2 T o chân linh ki n m i:<br /> Kích vào thanh công c Library manager trên c a s :<br /> -Xu t hi n h p tho i Library manager, kích vào create new footprinf. Xu t<br /> hi n h p tho i create new footprint, ánh tên chân linh ki n mình mu n t o vào m c<br /> name<br /> <br /> <br /> <br /> <br /> Trong h p tho i Library-Pin tool , Kích vào trên màn hình và di chuy n<br /> n v trí mong mu n kích trái chu t c nh chân linh ki n c n t o ,sau ó nh n Insert<br /> t o chân th 2 và c nh th cho n khi c linh ki n mong mu n.<br /> Ti p theo ch n Osbtracse tool v khung chân linh ki n .<br /> Nh n save và ch n ng d n l u l i linh ki n v a t o c.<br /> Sau khi ch n chân linh ki n nh p Accept this ECO trong h p tho i AUTO ECO<br /> <br /> <br /> <br /> <br /> C a s layuot xu t hi n .<br /> 2.3 Xoá các ký t không c n thi t trên s chân<br /> -Dùng thanh công c TEXT TOOL trên màn hình xoá b nh ng ký t<br /> không c n thi t trên m ch b ng cách dùng chu t rê vào ch c n xoá ,sau ó nh n DEL<br /> 2.4 Di chuy n linh ki n :<br /> Dùng thanh công c COMPONENT TOOL di chuy n linh ki n theo nh ng v<br /> trí thích h p các dây n i không ch ng chéo lên nhau<br /> -Kích chu t vào linh ki n ,rê chu t n v trí thích h p r i kích trái chu t c nh<br /> linh ki n.<br /> - N u muôn xoay linh ki n 1 góc 90 thì dùng phím R<br /> <br /> <br /> <br /> <br /> 2.5 Ch n l p m ch in:<br /> -kích vào thanh công c view spreadsheet -> Strategy-> route layer<br /> <br /> <br /> <br /> <br /> p tho i Route Layer xu t hi n<br /> Kích vào Enable,nh n Shift r ich n nh ng l p không in, kích chu t ph i ch n<br /> properties,xu t hi n h p tho i edit layer trategy nh n b Routing Enabled, sau ó<br /> nh n OK, r i close óng h p tho i .<br /> <br /> <br /> <br /> <br /> 2.6 Ch n kích th c ng m ch in<br /> -Tr c h t vào Options->System Settings. h p tho i System Setting xu t hi n,<br /> ch n kích th c o (c th là ch n Millimeters) m c Display Units ,sau ó nh n OK<br /> -Ti p theo kích vào thanh công c view spreadsheet ,ch n Net.<br /> H p tho i Net xu t hi n, kích chu t vào Width Min Con Max, kích trái chu t ch n<br /> properties .<br /> <br /> <br /> <br /> <br /> H p tho i Edit net xu t hi n , n kích th c ng m ch vào các m c Min Width,<br /> Con Width, Max Width. Sau ó nh n OK và óng h p tho i l i .<br /> 2.7 Xác nh chân âm c a ngu n.<br /> V i nh ng m ch dùng connetor bi u di n ngu n xoay chi u , thì ph i ch n chân<br /> âm c a ngu n b ng cách kích vào thanh công c Connection tool ,rê chu t n chân âm<br /> a ngu n , sau ó kích chu t ph i ch n Name net.Xu t hi n h p tho i Modify Nets.t i<br /> c New net name ánh GND, Sau ó nh n OK.<br /> <br /> <br /> <br /> <br /> 2.8 V khung m ch in<br /> Ch n thanh công c Obstacle tool :Ch n v trí thích h p , kích trái chu t và<br /> khung in. sau khi v xong khung c a m ch in , kích ph i chu t ch n end<br /> command k t thúc l nh<br /> 2.9 V m ch in.<br /> 3.9.1 V t ng :Ch n Auto -> Autoroute -> Board<br /> <br /> <br /> <br /> <br /> K t qu v m ch in t ng nh sau:<br /> 2.9.2V m ch in b ng tay : Các thanh công c h tr v m ch in b ng tay nh :edit<br /> segment mode, Shove trace mode…<br /> <br /> -Cách v kích vào u dây c n v và kéo n v trí k t thúc ng in ,r i kích<br /> ph i chu t<br /> 2.10 ng:<br /> Kích vào thanh công c Osbtacse tool ,trên m ch in kich ph i chu t ch n new, ti p<br /> c kích ph i chu t ch n properties.<br /> <br /> <br /> <br /> <br /> p tho i Edit Osbtracse xu t hi n.<br /> -T i m c Osbtracse type ch n Copper pour<br /> -T i m c Osbtracse layer ch n l p in c n v<br /> -T i m c Clearance ch n b dày l p in (ch n 0.8)<br /> -T i m c Net Attacment ch n GND<br /> Sau ó nh n OK<br /> Kích trái chu t, gi và rê chu t ngang qua b n m ch in .<br /> t qu ng nh sau:<br /> <br /> <br /> <br /> <br /> 2.1.1 ghi tên lên m ch in ch n thanh công c Text tool, kích chu t ph i ch n new ,sau<br /> ó ghi tên m ch in vào m c text string ,nh n OK<br /> Tên m ch in dín u con chu t ,di chuy n và t vào v trí thích h p c a mach in.<br /> CH NG 3: MÔ PH NG TRONG ORCAD 10.5<br /> <br /> th c hi n mô ph ng trong ORCAD tr c h t b n ph i v s d nguyên lý c a<br /> ch c n mô ph ng .<br /> Ch n start -> programs->Orcad 10.5 ->capture CIS<br /> Ch n File->New -> project<br /> p tho i new project xu t hi n:<br /> - ánh tên c a m ch c n mô ph ng t i m c name<br /> - Ch n Analog or Mixed A/D trong m c creat a new project Using<br /> - Nh n OK<br /> <br /> <br /> <br /> <br /> p tho i create Pspice project xu t hi n ,nh n ch n create a bank project<br /> Trên màn hình s xu t hi n c a s OrCAD Capture.<br /> 3.1V s m ch mô ph ng<br /> 3.1.1 Th vi n trong m ch mô ph ng<br /> Vi c v s nguyên lý m ch mô ph ng c ng làm t ng t nh ã trình bày<br /> ph n S NGUYÊN LÝ ch khác ch các linh ki n c l y trong các th<br /> vi n khác<br /> Chú ý :các linh ki n c l y t th vi n v m ch in s không mô ph ng c<br /> Cách l y linh ki n trong m ch mô ph ng:<br /> -Nh n place part, h p tho i place part xu t hi n<br /> -Nh n Remove lirbary (n u còn các th vi n c )<br /> -Nh n Add lirbary ,ch n m t ho c t t c các th vi n ,sau ó nh n Open<br /> - c ti p theo b n ti n hành l y linh ki n nh ã trình bày<br /> 3.1.2 Các ngu n c s d ng trong mô ph ng:<br /> Các ngu n s d ng trong m ch mô ph ng c l y t th vi n SOURCE va<br /> SOURCETM:<br /> -VDC ngu n áp m t chi u<br /> -VAC: ngu n áp xoay chi u<br /> -VSIN: ngu n áp (hình sin)<br /> -VEXP: ngu n áp(d ng hàm m )<br /> -VPULSE: ngu n áp(d ng xung)<br /> -IDC: ngu n dòng m t chi u<br /> -IAC: ngu n dòng xoay chi u<br /> -ISIN:ngu n dòng (d ng sin)<br /> -IEXP:ngu n dòng (d ng hàm m )<br /> -IPULSE: ngu n dòng(d ng hàm m )<br /> …..<br /> Sau khi v s nguyên lý xong ,b n nh n save document l u l i.<br /> <br /> 3.2. Các thanh công c trên c u s orcad capture h tr cho<br /> vi c mô ph ng c a b n:<br /> -Voltage/level : que o hi n th n áp t i các nút trong<br /> ch n<br /> <br /> -Current maket : que o hi n th dòng n t i các m<br /> trong m ch n<br /> <br /> <br /> -Power dissipation maket : que o hi n th công su t t i các m<br /> trong m ch n<br /> <br /> -Voltage differential maket : que o hi n th n áp t i 2 mb tk<br /> trong m ch n<br /> <br /> -Enable bias current display : hi n th dòng n m t chi u t i t t c<br /> các nút trong m ch n<br /> <br /> -Enable bias voltage display : hi n th n áp m t chi u t i t t c các<br /> nút trong m ch n<br /> <br /> - Enable bias power display : hi n th công su t m t chi u t i t t c các<br /> nút trong m ch n<br /> <br /> -New simulation profile : ánh tên ,bài mô ph ng<br /> <br /> -Edit simulation setting : ch n lo i phân tích<br /> <br /> -Run : ch y mô ph ng<br /> <br /> -View simulation result : xem l i k t qu mô ph ng<br /> <br /> <br /> 3.3.Các lo i mô ph ng trong ORCAD 10.5<br /> -Mô ph ng t ng t<br /> -Mô ph ng s<br /> 3.4. Các b c ti n hành mô ph ng :<br /> 3.4.1 Mô ph ng t ng t :<br /> 3. 4.1.1 Mô ph ng transient:<br /> <br /> • c ích: Bi u di n d ng sóng bi n i theo th i gian t i các m mà<br /> mình mu n<br /> • u ki n: Có m t ngu n bi n i theo th i gian ho c c gán cho<br /> nh ng giá tr t m th i<br /> • Cách ti n hành:<br /> -Ch n m ch c n mô ph ng<br /> -Ch n Pspice -> New simulation profile ho c ch n bi u t ng<br /> trên màn hình .Xu t h p tho i new simulation , ánh tên bài mô ph ng<br /> vào m c name ,sau ó nh n create<br /> <br /> <br /> <br /> <br /> Xu t hi n h p tho i simulation settings:<br /> Ch n Analyiss<br /> <br /> + T i m c Analyis type: ch n time Domain<br /> + T i m c Run to time: ch n th i gian c n mô ph ng<br /> + T i m c Start saving data affer: ch n th i gian b t u<br /> + T i m c Maximum step size: ch n b c nh y<br /> + Nh n Apply ,sau ó Nh n OK<br /> -Nh n Run ch y mô ph ng<br /> <br /> * Chú ý : mu n mô ph ng thông s nào ,t i nút nào trong m ch thì t que o<br /> thông s ó vào t i nút ó.<br /> <br /> • ch mô ph ng minh ho<br /> VD: Mô ph ng (transient) m ch dao ng harley<br /> Ch n Run to time: 50ms<br /> Start saving data affer: 0<br /> Maximum step size: 1ms<br /> t qu mô ph ng nh sau:<br /> Trong c a s Pspice A/D a k t qu mô ph ng :<br /> <br /> <br /> <br /> <br /> -Fourier :chuy n d ng sóng theo mi n th i gian sang mi n w (bi n<br /> i Fuorier)<br /> <br /> -Add Trace ch a k t qu mô ph ng t i các nút trong m ch n<br /> <br /> <br /> -Toggle cursor : cho phép<br /> hi n th to c a các m trên th k t qu<br /> <br /> <br /> <br /> <br /> -Plot -> Axis Setting : thay i<br /> tr c o cu th<br /> <br /> <br /> 3.4.1.2 .Quét DC<br /> 3.4.1.2.1 : Quét DC s c p (DC sweep primany)<br /> <br /> * c ích: cho phép áp ng c a m ch t i b t k m t nút nào ó trong m ch<br /> n ng v i m t d i giá tr c a m t ngu n cho tr c.<br /> <br /> * u ki n : có m t ngu n trong m ch n c gán m t d i giá tr nh t nh<br /> i nh ng b c nh y nh t nh .<br /> <br /> *Các ngu n c s d ng trong quét DC<br /> -VDC, VSRC<br /> -IDC, ISRC<br /> *Các thông s quét DC:<br /> -Voltage source<br /> -Current source<br /> -Globol parameter<br /> -Model parameter<br /> -Temperature<br /> *Cách ti n hành mô ph ng:<br /> -Ch n m ch mô ph ng<br /> - Pspice -> New simulation profile ho c ch n bi u t ng trên<br /> màn hình .Xu t h p tho i new simulation , ánh tên bài mô ph ng vào m c<br /> name ,sau ó nh n create<br /> Xu t hi n h p tho i simulation settings<br /> Ch n Analysis<br /> + i m c Analysis type: ch n DC sweep<br /> + i m c options: ch n Primary Sweep<br /> + i m c Sweep variable :ch n thông s c n quét<br /> + i m c Name : ánh tên c a ngu n c ng nh d i giá tr cho tr c<br /> +T i m c Start value: ánh giá tr ban u<br /> +T i m c End value: ánh giá tr k t thúc<br /> +T i m c increment: ánh b c nh y<br /> <br /> <br /> <br /> <br /> +Nh p Apply , sau ó nh p OK<br /> <br /> -Nh p Run ch y mô ph ng<br /> <br /> * ch mô ph ng minh ho :<br /> VD: Mô ph ng m ch UJT<br /> Ch n thông s quét là n áp(voltage source)<br /> Ch n Start value: -10V<br /> End value : 30V<br /> Increment: 1<br /> t qu mô ph ng nh sau :<br /> 3.4.1.2.2 Quét DC th c p:(secondary sweep)<br /> <br /> * c ích: cho phép áp ng c a m ch t i b t k m t nút nào ó<br /> trong m ch n ng v i m t ngu n quét DC trong m t d i nhi t<br /> nh t nh .Trong ó,s thay i c a ngu n th nh t s c quét theo t<br /> ng b c thay i c a ngu n th hai.<br /> <br /> * u ki n : ph i thi t l p 2 ngu n có giá tr thay i trong kho ng nh t nh<br /> ,v i nh ng b c nh y nh t nh .<br /> <br /> *Cách ti n hành :<br /> <br /> -Ch n m ch mô ph ng<br /> - Pspice -> New simulation profile ho c ch n bi u t ng<br /> trên màn hình .Xu t h p tho i new simulation , ánh tên bài mô ph ng vào<br /> c name ,sau ó nh n create<br /> Xu t hi n h p tho i simulation settings<br /> Ch n Analysis<br /> + i m c Analysis type: ch n DC sweep<br /> + i m c options: ch n secondary DC sweep<br /> + i m c Sweep variable :temperature<br /> Nh p d i nhi t c n quét t i các m c start value, end value , increment<br /> + Thi t l p 2 ngu n DC nh ã trình bày ph n quét DC s c p.<br /> + Nh n Apply , sau ó nh n OK<br /> -Nh n Run ch y mô ph ng.<br /> <br /> *M ch mô ph ng minh ho<br /> VD: mô ph ng bi u di n c tuy n c a BJT<br /> Ch n Temperature: Start value: 20<br /> End value: 200<br /> Increment: 5<br /> <br /> Ch n ngu n s c p V1: Start value: 0<br /> End value: 1v<br /> Increment: 0.1<br /> Ch n ngu n th c pV2: Start value: 0v<br /> End value: 5v<br /> Increment: 0.1<br /> <br /> * t qu mô ph ng:<br /> <br /> <br /> <br /> <br /> 3.4.1.3 Quét AC:<br /> * c ích :cho bi t áp ng c a m ch theo s thay ic am td it ns c a<br /> t ngu n AC<br /> <br /> * u ki n :Trong m ch n có m t ngu n AC<br /> *Các ngu n AC th ng dùng trong ch quét AC là:<br /> -VAC, VSRC :ngu n áp<br /> -IAC, ISRC:ngu n dòng<br /> <br /> *Cách ti n hành mô ph ng:<br /> - Ch n m ch mô ph ng<br /> - Pspice -> New simulation profile ho c ch n bi u t ng trên màn<br /> hình .Xu t h p tho i new simulation , ánh tên bài mô ph ng vào m c name ,sau<br /> ó nh n create<br /> Xu t hi n h p tho i simulation settings<br /> Ch n Analysis<br /> + i m c Analysis type: ch n AC sweep<br /> + i m c options :ch n genaral settings<br /> + i AC sweep type: ch n logarithmic<br /> i start frequency :ch n t n s b t u<br /> i end frequency : ch n n s k t thúc<br /> i point /decade :ch n s m<br /> +Nh n Apply ,sau ó nh n OK<br /> <br /> <br /> <br /> <br /> -Nh n Run ti n hành ch y mô ph ng:<br /> * ch mô ph ng minh ho :<br /> VD:Ch n m ch khuy ch i dùng BJT<br /> <br /> <br /> <br /> <br /> Ch n Start frequency: 1HZ<br /> End frequency : 100kHZ<br /> Points/ decade : 300<br /> <br /> t qu mô ph ng :<br /> 3.4.1.4.Phân tích nhi u :<br /> <br /> Trong m ch n có ngu n xoay chi u th ng b nh h ng c a nhi u theo t n s<br /> a ngu n .<br /> Các lo i nhi u ó là:<br /> -Nhi u u vào c a m ch<br /> -Nhi u u ra c a m ch<br /> -Nhi u trên m i linh ki n có trong m ch<br /> -Nhi u gi a các chân linh ki n bán d n<br /> …<br /> Pspice s cho chúng ta bi t c t ng các lo i nhi u ó<br /> *Cách ti n hành phân tích nhi u:<br /> - Trong h p tho i simulation settings<br /> +T i m c Analysis type: ch n AC Sweep/noise<br /> +T i m c ch n option: chon General settings<br /> +T i m c Noise Analysis :ch n Enabled<br /> Ch n u ra c n xác nh nhi u m c Output Voltage<br /> Ch n ngu n c n xác nh nhi u m c I/V Source<br /> Ch n b c nh y m c interval<br /> <br /> <br /> <br /> <br /> bi t c k t qu nhi u c a m ch n ta vàoview -> uotput file<br /> * VD minh ho :ch n m ch khuy ch i<br /> <br /> <br /> <br /> <br /> -Thi t l p simulation settings nh b ng trên<br /> -K t qu phân tích nhi u c a m ch c l u trong output file nh sau :<br /> 3.4.2 Mô ph ng s :<br /> *Công vi c tr c tiên c a mô ph ng s c ng gi ng nh mô ph ng t ng t là v<br /> nguyên lý<br /> <br /> *Các ngu n tín hi u c s d ng trong mô ph ng s có 2 lo i:<br /> - Các ngu n tín hi u l y t th vi n SOURCE thì ã c nh ngh a , ch c n<br /> y ra t th vi n nh p ph i chu t ch n edit properties và thay i các thông s<br /> mong mu n .Các ngu n ó là:<br /> +Filestim1 : 1 bit<br /> +Filestim2 : 2 bit<br /> +Filestim4: 4 bi t<br /> +Filestim8: 8 bi t<br /> +Filestim16 :16 bit<br /> +Filestim 32: 32 bit<br /> +Digclock :xung ng h<br /> -Các ngu n c l y t th vi n SOURCETM thì sau khi l y ra s c nh<br /> ngh a theo các ngu n tín hi u mong mu n nh : ngu n tín hi u r i r c , ngu n<br /> xung clock hay là 1 bus<br /> <br /> Cách nh ngh a nh sau :<br /> -L y ra ngu n ra t th vi n SOURCE<br /> -Nh p ph i vào ngu n c l y ra ,ch n edit ->pspice stimulus.Xu t hi n c a<br /> stimulus editor,thi t l p các thông s c n thi t trong các m c có trong c a s<br /> ,k t qu s c hi n lên trên màn hình c a c a s .<br /> -Nh n Save l u l i trong m ch mô ph ng<br /> Cách ti n hành mô ph ng s :<br /> -Ch n m ch c n mô ph ng<br /> -Ch n các ngu n tín hi u thích h p<br /> -Ch n mô ph ng transient ,nh p các thông s th i gian .<br /> -Di u ch nh ngu n tín hi u c n thi t<br /> -Nh n Run ti n hành mô ph ng<br /> <br /> ch mô ph ng minh ho :<br /> Ch n m ch ÈN GIAO THÔNG<br /> Ch n 2 ngu n Digstim1 làm xung clock,trong ó:<br /> Thi t l p Ngu n XUNG1:<br /> Trong h p tho i New Stimulus<br /> Trong h p tho i clock Attributes<br /> <br /> <br /> <br /> <br /> T ng t nh v y thi t l p ngu n XUNG2<br /> K t qu d ng sóng c a 2 ngu n xung nh sau:<br /> <br /> <br /> <br /> <br /> Ch n thông s th i gian nh sau:<br /> Dùng các u ra c a chip 7408 là N0, N1, N2, N3, N4, N5 .Trong ó:<br /> -N0: èn xanh 1<br /> -N1: èn vàng 1<br /> -N2: èn 1<br /> -N3: èn xanh 2<br /> -N4: èn vàng 2<br /> -N3: èn 2<br /> <br /> Nh n Run ch y mô ph ng .<br /> <br /> K t qu mô ph ng nh sau:<br />
ADSENSE
ADSENSE

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản
2=>2