intTypePromotion=1

Bài giảng matlab

Chia sẻ: Nguyễn Quang Lập | Ngày: | Loại File: DOC | Số trang:102

0
774
lượt xem
409
download

Bài giảng matlab

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Học phần Tin ứng dụng thuộc khối kiến thức cơ sở chung của các ngành Đại học kỹ thuật chuyên ngành điện. Trang bị cho sinh viên những kiến thức cơ bản về: Phần mềm Matlab và ứng dụng của nó để mô phỏng các bài toán điều khiển các quá trình công nghệ thông dụng Sau khi đã cài đặt xong, chúng ta hãy xem MATLAB có thể làm đ¬ược những gì. Trong phần này chúng ta sẽ trình bày một số những ứng dụng của nó; vì để trình bày...

Chủ đề:
Lưu

Nội dung Text: Bài giảng matlab

  1. BỘ CÔNG THƯƠNG TRƯỜNG ĐẠI HỌC KINH TẾ - KỸ THUẬT CÔNG NGHIỆP KHOA ĐIỆN-ĐIỆN TỬ BÀI GIẢNG TIN ỨNG DỤNG NGÀNH KỸ THUẬT ĐIỆN Đối tượng: HSSV trình độ Đại học, Cao đẳng, TCCN Ngành đào tạo: Dùng chung cho Khối ngành Công nghệ Lưu hành nội bộ
  2. MỤC LỤC LỜI GIỚI THIỆU.........................................................................................................................4 CHƯƠNG 1: CƠ SỞ MATLAB..................................................................................................1 MỤC TIÊU CỦA CHƯƠNG......................................................................................................... 1 1.1.Khái niệm về Matlab............................................................................................................... 1 1.1.1.Định nghĩa..................................................................................................................1 1.1.2. Cài đặt chương trình.................................................................................................2 1.1.3 Khởi động và thoát khỏi Matlab.................................................................................5 1.2.Bắt đầu làm quen với Matlab................................................................................................. 6 1.2.2.Hiệu chỉnh, sửa đổi dòng lệnh...................................................................................7 1.2.3.Xoá cửa sổ lệnh.........................................................................................................7 1.2.4.Dừng một chương trình đang chạy............................................................................7 1.2.5. Ngăn không cho hiển thị kết quả tính toán ra màn hình...........................................7 1.2.6.Dòng lệnh dài.............................................................................................................8 1.2.7. Các Menu của Matlab...............................................................................................8 1.2.8. Một số phím chuyên dụng và lệnh thông dụng.....................................................11 1.3.Sử dụng các lệnh trực tiếp từ Matlab................................................................................. 14 1.9. Lưu và lấy dữ liệu................................................................................................................ 19 1.10. Các toán tử Logic và các lệnh điêu kiện........................................................................... 20 1.10.1.Các toán tử logic....................................................................................................20 1.10.2. Cấu trúc câu lệnh điều kiện:.................................................................................21 1.11.Vòng lặp................................................................................................................................. 23 1.11.1.Vòng lặp for............................................................................................................23 1.11.2.Vòng lặp for lồng nhau...........................................................................................24 1.11.3.Vòng lặp While.......................................................................................................25 1.11.4 Các lệnh break, return, error:.................................................................................25 1.12. Biến toàn cục (global variables)......................................................................................... 26 1.13.Một số hàm toán học........................................................................................................... 26 1.14. Định dạng số........................................................................................................................ 27 CHƯƠNG 2: SYMBOLIC TOOLBOX......................................................................................29 MỤC TIÊU CỦA CHƯƠNG....................................................................................................... 29 2.1. Giới thiệu về symbolic.......................................................................................................... 29 2.2. Lệnh và hàm trong Symbolic Matlab................................................................................... 29 2.2.1. Cấu trúc : ................................................................................................................29 2.2.2 Biến symbolic mặc định...........................................................................................29 2.2.3. Phép đạo hàm.........................................................................................................30
  3. 2.2.4. Phép tích phân........................................................................................................31 2.2.5. Tìm giới hạn............................................................................................................32 2.2.6. Tính tổng của dãy số symbolic...............................................................................33 2.2.7. Tách tử số và mẫu số của một biểu thức symbolic................................................34 2.2.8 Thay thế..................................................................................................................34 2.2.9 Biểu diễn biểu thức symbolic dưới dạng toán học ................................................35 2.2.10. Giải phương trình đại số.......................................................................................36 2.2.11. Phương trình vi phân.............................................................................................36 2.2.12 Biến đổi laplace và laplace ngược........................................................................37 CHƯƠNG 3:MA TRẬN VÀ MẢNG TRONG MATLAB.............................................................39 MỤC TIÊU CỦA CHƯƠNG....................................................................................................... 39 3.1 Nhập ma trận trong Matlab.................................................................................................. 39 3.6 Giải hệ phương trình tuyến tính......................................................................................... 43 3.6.1 Hệ phương trình tuyến tính :...................................................................................43 3.6.2 Hệ Phương trình tuyến tính không đồng nhất.........................................................44 3.6.3 Hệ phương trình tuyến tính đồng nhất....................................................................45 3.6.4 Giải hệ phương trình tuyến tính bằng Matlab(Dùng toán tử \)................................45 3.7 Điều kiện có nghiệm ............................................................................................................. 46 3.8 Hệ điều kiện yếu................................................................................................................. 47 Cách giải hệ phương trình điều kiện yếu A*X=B....................................................................48 3 .9 Lệnh cond Tính điều kiện của ma trận............................................................................. 49 Câu hỏi ôn tập.............................................................................................................................. 50 CHƯƠNG 4 :ĐỒ HOẠ TRONG MATLAB................................................................................52 MỤC TIÊU CỦA CHƯƠNG....................................................................................................... 52 4.1 Màn hình đồ thị .................................................................................................................... 52 4.2.Các lệnh trên menu đồ họa:.................................................................................................. 52 4.2.1 File: .........................................................................................................................52 4.2.3 Tools ( Ctrl + t) : .....................................................................................................58 4.3.Thực hành vẽ đồ thị 2- D...................................................................................................... 64 4.3.1.Đồ thị tuyến tính:.....................................................................................................64 4.3.2.Đồ thị dạng đánh dấu: ...........................................................................................65 4.3.4 Chú thích và kiểm soát đồ thị:................................................................................65 4.3.5.Đồ thị hình thanh:.....................................................................................................67 4.3.6.Đồ thị toạ độ cực: ...................................................................................................68 4.3.7.Đồ thị hình Pie:........................................................................................................68 4.3.9.Lệnh staris:...............................................................................................................69
  4. 4.4 Thực hành vẽ đồ thị 3- D...................................................................................................... 69 CHƯƠNG 5: CƠ SỞ PHƯƠNG PHÁP TÍNH........................................................................71 MỤC TIÊU CỦA CHƯƠNG....................................................................................................... 71 Giả sử có n điểm đo rời rạc tương ứng với kết quả đo như sau:............................................71 5.1.2 Nội suy cho bài toán hai chiều.................................................................................74 5.2 Giải phương trình phi tuyến ............................................................................................... 75 5.3 Dùng Laplace để giải bài toán trong Lý thuyết Mạch....................................................... 79 5.4 Giải hệ phương trình đại số tuyến tính ........................................................................... 81 5.5 Phương trình vi phân thường............................................................................................... 82 MỤC TIÊU CỦA CHƯƠNG............................................................................................... 86 6.1 Khái niệm về simulink........................................................................................................... 86 6.2 Thư viện simulink và môi trường làm việc ........................................................................ 86 TÀI LIỆU THAM KHẢO.............................................................................................................95 LỜI GIỚI THIỆU Học phần Tin ứng dụng thuộc khối kiến thức cơ sở chung của các ngành Đại học kỹ thuật chuyên ngành điện. Trang bị cho sinh viên những kiến thức cơ bản về: Phần mềm Matlab và ứng dụng của nó để mô phỏng các bài toán điều khiển các quá trình công nghệ thông dụng Sau khi đã cài đặt xong, chúng ta hãy xem MATLAB có thể làm đ ược những gì. Trong phần này chúng ta sẽ trình bày một số những ứng dụng của nó; vì để trình bày tất cả những ứng dụng của MATLAB sẽ rất dài và tốn thời gian. Nếu bạn đ ọc quyển hướng dẫn này, bạn sẽ thấy MATLAB là ngôn ngữ rất mạnh để giải quyết những vấn đề quan trọng và khó khăn của bạn. Nó sẽ rất hữu ích khi bạn đọc phần hướng dẫn cơ bản vì nó sẽ cung cấp cho bạn những kiến thức cơ bản để bạn hiểu rõ MATLAB và phát triển được những khả năng của mình sau này. Có lẽ cách dễ nhất để hìng dung về MATLAB là nó có đầy đủ các đặc điểm của máy tính cá nhân: giống như các máy tính cơ bản, nó làm tất cả các phép tính toán học cơ bản như cộng, trừ, nhân, chia; giống như máy tính kỹ thuật, nó bao gồm: số phức, căn thức, số mũ, logarithm, các phép toán l ượng giác như sine, cosine, tang; nó cũng giống như máy tính có khả năng lập trình, có thể l ưu trữ, tìm kiếm lại dữ liệu, cũng có thể tạo, bảo vệ và ghi trình tự các lệnh để tự động phép toán khi giải quyết
  5. các vấn đề, bạn có thể so sánh logic, điều khiển thực hiên lệnh để đ ảm bảo tính đúng đắn của phép toán. Giống như các máy tính hiện đại nhất, nó cho phép bạn biểu diễn dữ liệu dới nhiều dạng như: biểu diễn thông thường, ma trân đại số, các hàm tổ hợp và có thể thao tác với dữ liệu thường cũng như đối với ma trận. Trong thực tế MATLAB còn ứng dụng rất rộng rãi trong nhiều lĩnh vực và nó cũng sử dụng rất nhiều các phép tính toán học. Với những đặc điểm đó và khả năng thân thiện với người sử dụng nên nó dễ dàng sử dụng hơn các ngôn ngữ khác như Basic, Pascal, C. Nó cung cấp một môi trường phong phú cho biểu diễn dữ liệu, và có khả năng mạnh mẽ về đồ hoạ, bạn có thể tạo các giao diện riêng cho ng ười sử dụng(GUIs) để gải quyết những vấn đề riêng cho mình. Thêm vào đó MATLAB đưa ra những công cụ để giải quyết những vấn đề đặc biệt, gọi là Toolbox (hộp công cụ). Ví dụ Student Edition của MATLAB bao gồm cả Toolbox điều khiển hệ thống, Toolbox xử lí tín hiệu, Toolbox biểu tượng toán học. Ngoài ra bạn có thể tạo Toolbox cho riêng mình. Với những khả năng mạnh mẽ, rộng lớn của MATLAB nên nó rất cần thiết cho bạn bắt đầu từ phần cơ bản. Sau đây chúng ta sẽ nghiên cứu từng phần, và cuốn sách này sẽ giúp bạn hiểu được chúng. Trước tiên, một cách đơn giản nhất là chúng ta quan niệm như là một máy tính cơ bản, tiếp theo là nh ư máy tính kỹ thuật và như máy tính có thể lập trình được, cuối cùng là như máy tính hiện đại nhất. Bằng cách quan niệm này bạn sẽ dễ dàng hiểu đựơc những cách mà MATLAB giải quyết những vấn đề thông thường và xem MATLAB giải quyết những vấn đề về số phức mềm dẻo như thế nào. Tuỳ thuộc vào kiến thức của bạn, bạn có thể tìm thấy những phần trong cuốn sách hướng dẫn này hứng thú hay buồn tẻ... Nhóm sửa chữa Nhóm biên soạn Ký tên Ký tên Nguyễn Văn A Nguyễn Văn B Ký tên Ký tên Nguyễn Thị A Nguyễn Thị B
  6. CHƯƠNG 1: CƠ SỞ MATLAB MỤC TIÊU CỦA CHƯƠNG - Hiểu rõ khái niệm và cách cài đặt phần mềm Matlab - Nắm được các menu và các lệnh cơ bản trong Matlab - Về thái độ: Học sinh, Sinh : Biết cách khai bao biến trong Matlab, tạo và sử dụng function và script file. NỘI DUNG BÀI GIẢNG LÝ THUYẾT 1.1.Khái niệm về Matlab 1.1.1.Định nghĩa MATLAB là 1 phần mềm ứng dụng chạy trong môi trường Windows do hãng MathWorks sản xuất và cung cấp. Có thể coi Matlab là ngôn ngữ của kỹ thuật. Nó tích hợp các công cụ rất mạnh phục vụ tính toán, lập trình, thiết kế, mô phỏng,... trong một môi trường rất dễ sử dụng trong đó các bài toán và các lời giải được biểu diễn theo các ký hiệu toán học quen thuộc. Các ứng dụng điển hình là: - Toán học và tính toán. - Phát triển thuật toán. - Tạo mô hình, mô phỏng và tạo giao thức. - Khảo sát, phân tích số liệu. - Đồ hoạ khoa học kỹ thuật. - Phát triển ứng dụng, gồm cả xây dựng giao diện người dùng đồ hoạ GUI. Matlab là một hệ thống tương tác mà phần tử dữ liệu cơ bản là một mảng (array) không cần khai báo kích thước. Điều này cho phép bạn giải nhiều bài toán tính toán kỹ thuật đặc biệt là các bài toán liên quan đến ma trận và véc tơ. Matlab là viết tắt của hai từ tiếng Anh Matrix Laboratory (Phòng thí nghiệm ma trận). Ban đầu Matlab được viết chỉ để phục vụ cho việc tính toán ma trận. Trải qua thời gian dài, nó đã được phát triển thành một công cụ hữu ích, một ngôn ngữ của kỹ thuật. Trong môi trường đại học, nó là một công cụ chuẩn cho các khoá học mở đầu và cao cấp về toán học, khoa học và kỹ thuật. Trong công nghiệp, nó là công cụ được lựa chọn cho việc phân tích, phát triển và nghiên cứu hiệu suất cao. Matlab cung cấp một họ các giải pháp theo hướng chuyên dụng hoá được gọi là các Toolbox (hộp công cụ). Các toolbox cho phép người sử dụng học và áp dụng các kỹ thuật chuyên dụng cho một lĩnh vực nào đó. Toolbox là một tập hợp toàn diện các hàm của Matlab (M-file) cho phép mở rộng môi trường Matlab để giải các lớp bài toán cụ thể. Các lĩnh vực trong đó có sẵn các toolbox bao gồm: Xử lý tín hiệu, hệ thống điều khiển, logic mờ, mô phỏng,... Hệ thống Matlab gồm có 5 phần chính: 1
  7. - Ngôn ngữ Matlab: là một ngôn ngữ ma trận/ mảng cấp cao với các câu l ệnh, hàm, cấu trúc dữ liệu, vào/ ra, các tính năng lập trình hướng đối tượng. Nó cho phép lập trình các ứng dụng từ nhỏ đến các ứng dụng lớn và phức tạp. - Môi trường làm việc Matlab: Đây là một bộ các công cụ và phương tiện mà bạn sử dụng với tư cách là người dùng hoặc người lập trình Matlab. Nó bao gồm các phương tiện cho việc quản lý các biến trong không gian làm việc Workspace cũng như xuất nhập khẩu dữ liệu. Nó cũng bao gồm các công cụ phát triển, quản lý, gỡ rối và định hình M-file, ứng dụng của Matlab. - Xử lý đồ hoạ: Đây là hệ thống đồ hoạ của Matlab. Nó bao gồm các lệnh cao cấp cho trực quan hoá dữ liệu hai chiều và ba chiều, xử lý ảnh, ảnh động,... Nó cũng cung cấp các lệnh cấp thấp cho phép bạn tuỳ biến giao diện đồ hoạ cũng như xây dựng một giao diện đồ hoạ hoàn chỉnh cho ứng dụng Matlab của mình. - Thư viện toán học Matlab: Đây là tập hợp khổng lồ các thuật toán tính toán từ các hàm cơ bản như cộng, sin, cos, số học phức,... tới các hàm phức tạp hơn như nghịch đảo ma trận, tìm trị riêng của ma trận, phép biến đổi Fourier nhanh. - Giao diện chương trình ứng dụng Matlab API (Application Program Interface): Đây là một thư viện cho phép bạn viết các chương trình C và Fortran tương thích với Matlab. Simulink, một chương trình đi kèm với Matlab, là một hệ thống tương tác với việc mô phỏng các hệ thống động học phi tuyến. Nó là một chương trình đồ hoạ sử dụng chuột để thao tác cho phép mô hình hoá một hệ thống bằng cách vẽ một sơ đồ khối trên màn hình. Nó có thể làm việc với các hệ thống tuyến tính, phi tuyến, hệ thống liên tục theo thời gian, hệ gián đoạn theo thời gian, hệ đa biến,... 1.1.2. Cài đặt chương trình a. Khởi động windows. Matlab là một phần mềm chạy trong môi trường Windows nên qui trình cài đặt Matlab cũng tương tự như việc cài đặt các chương trình phần mềm khác trong Windows, chỉ cần làm theo các hướng dẫn của chương trình cài đặt. b.Tiến hành cài đặt - Đưa đĩa CD vào ổ đĩa (nếu cài từ đĩa CD-ROM) Do chương trình được cấu hình theo chế độ Autorun (tự chạy) nên khi đưa đĩa CD vào ổ đĩa thì trình Setup tự động được kích hoạt. Trường hợp chế độ Autorun không được kích hoạt (do tập tin Autorun bị lỗi), dùng. Hoặc ta có thể kích chuột vào nút Start trên thanh tác vụ (Task bar) của windows, chọn lệnh run, gõ vào đường dẫn của file, nhấn Enter hoặc kích vào nút lệnh Run. Sau đó làm theo các hướng dẫn của trình cài đặt của Windows. 2
  8. - Trường hợp cài đặt Matlab từ đĩa cứng: Hình 1. Cài đặt Matlab trong Windows và màn hình Welcome Trường hợp này yêu cầu phải có sẵn bộ cài đặt trong đĩa cứng. Khi đó, ta sử dụng Windows Explorer hây My Computer để duyệt ổ cứng, tìm đến thư mục (folder) cài đặt rồi kích đúp chuột vào file (tập tin) Setup.exe. Sau đó làm theo các hướng dẫn của trình cài đặt của Windows. Sau khi file setup.exe được kích hoạt, cửa sổ Welcom to MATLAB Setup hiện lên trong giây lát. Kích vào nút lệnh Next để chuyển sang cửa sổ cài đặt kế tiếp. Hình 1.2. Cửa sổ Software License Agreement và cửa sổ thông tin về khách hàng c.Nhập thông tin của người dùng và Personal License Password Cửa sổ thứ hai thể hiện các thông tin về bản quyền của chương trình. Kích Yes để sang cửa sổ cài đặt kế tiếp. Trong cửa sổ thông tin về khách hàng Customer Information (hình 1.2), nhập họ tên vào khung Name, địa chỉ hoặc tên công ty vào khung Company. Nhập mã khoá (Serial Key) của chương trình vào khung Personal License Password. Kích chuột vào Next để tiếp tục quá trình cài đặt. 3
  9. d) Lựa chọn các thành phần sẽ cài đặt Trong cửa sổ Select Matlab Components (hình 1.3), bỏ đánh dấu những thành phần không cần thiết trong chương trình để tiết kiệm dung lượng đĩa cứng. Muốn kiểm tra dung lượng của chương trình, kích vào Disk Space để quan sát. Muốn thay đổi thư mục cài đặt Matlab, kích chuột vào nút Browse và tạo đường dẫn tới địa chỉ cần đặt thư mục Matlab. Hình 1.3. Lựa chọn các thành phần của Matlab sẽ được cài đặt Thư mục mặc định là C:\MATLABR11. Để tiếp tục kích Next, màn hình hiện khung thông tin Setup và trình setup bắt đầu copy các tập tin vào thư mục cài đặt. e.Hoàn thành cài đặt Sau khi hoàn thành quá trình Copy các file của chương trình vào thư mục cài đặt, màn hình hiện thoại khung Setup Hình 1.4. Quá trình copy file của chương trình vào thư mục cài đặt Complete. Bỏ đánh dấu ở ô “Yes, launch the Help Desk to view the Release Note” nếu không muốn trình setup khởi động Help Desk (phần trợ giúp). Bỏ đánh dấu ở ô “Yes, launch Matlab” nếu chưa muốn khởi động Matlab ngay. Kích Finish để kết thúc qúa trình cài đặt. Sau khi kết thúc cài đặt cửa sổ kế tiếp là Internet Explorer (nếu không bỏ đánh dấu ở ô “Yes, launch the Help Desk to view the Release Note”). Kích Close để trở về cửa sổ nền Desktop của windows, biểu tượng của Matlab sẽ được tự động đưa ra Desktop của windows.. 4
  10. 1.1.3 Khởi động và thoát khỏi Matlab a) Khởi động MATLAB Cũng như các chương trình ứng dụng khác chạy trên nền Windows, có rất nhiều cách để khởi động Matlab. Kích đúp chuột vào biểu tượng Matlab5.3 trên màn hình Desktop của Windows: hoặc kích chuột theo trình tự như sau: Start/ Programs/ Matlab/ Matlab 5.3 Sau khi khởi động xong cửa sổ Matlab Command Window hiện ra như hình 1.4. Cũng như các chương trình chạy trong môi trường Windows khác Matlab cũng có những thành phần giao diện của chương trình. • Dòng trên cùng là thanh tiêu đề gồm: + Tận trái là biểu tượng chương trình. Khi kích vào biểu tượng này Matlab hiện menu xổ chứa các lệnh liên quan tới việc xử lý khung cửa sổ chương trình cũng như thoát khỏi chương trình. + Kế tiếp biểu tượng là tên chương trình cùng với cửa sổ chương trình. Tận cùng là ba biểu tượng có chức năng phong to, thu nhỏ và thoát khỏi chương trình. • Dòng thứ hai là thanh menu (Menu bar – thanh thực đơn) của chương trình gồm các menu chính chứa các lệnh liên quan đến việc tạo, xử lý, gán thuộc tính,... cho các đối tượng, thiết lập cấu hình phần mềm,... • Dòng thứ ba là thanh công cụ (Tool bar – thanh công cụ) chứa biểu tượng đường tắt (Shortcut) của các lệnh thường sử dụng, giúp người sử dụng truy cập nhanh vào các lệnh của Matlab. • Phần chiếm gần chọn màn hình là cửa sổ lệnh, là nơi nhập các lệnh và hiển thị kết quả cũng như các thông tin khác. 5
  11. • Cuối cùng là thanh tác vụ hay thanh trạng thái (status bar) hiện thông tin về tình trạng đang xử lý, thực hiện đối với đối tượng. Hình 1.4. Cửa sổ Command Windows của Matlab b) Thoát khỏi MATLAB Trong Windows, có rất nhiều cách để thoát khỏi một chương trình ứng dụng, để thoát khởi Matlab ta có thể sử dụng một trong những cách sau: Từ cửa sổ lệnh Matlab Command Window đánh lệnh quit hoặc kích biểu tượng close nằm ngay góc phải trên thanh tiêu đề Matlab. Hoặc kích chuột theo đường dẫn sau: File / Exit MATLAB Hoặc nhấn tổ hợp phím : Ctrl + Q. 1.2.Bắt đầu làm quen với Matlab 1.2.1. Cửa sổ lệnh Cửa sổ lệnh là cửa sổ chính trong đó người sử dụng giao tiếp với Matlab. Trình dịch của Matlab hiển thị một dấu nhắc >> để biểu thị rằng nó đã sẵn sàng nhận và thực hiện lệnh của bạn. Ví dụ, khi muốn nhập dòng lệnh gán biến x=5, ta gõ như sau: >>x=5 ↵ Sau khi nhấn phím enter (↵ ), Matlab đáp ứng như sau: >>x=5 x= 6
  12. 5 1.2.2.Hiệu chỉnh, sửa đổi dòng lệnh Các phím mũi tên, các phím điều khiển trên bàn phím cho phép gọi lại, sửa đổi và tái sử dụng các lệnh đã gõ vào trước đó. Ví dụ, giả sử ta gõ vào dòng lệnh: >>a=(1+sqt(5))/2 %sqrt(x) là hàm tính giá trị căn bậc hai của x Do ta gõ thiếu chữ r trong cú pháp của hàm sqrt nên Matlab báo lỗi như sau: Undefined function or variable ‘sqt’ có nghĩa là hàm hoặc biến ‘sqt’ không được định nghĩa. Thay vì gõ lại cả dòng lệnh, đơn giản là ta nhấn phím ↑, câu lệnh bị sai ở trên sẽ được hiển thị lại. Sử dụng phím ← (hoặc dùng chuột) để di chuyển con trỏ đến vị trí giữa chữ q và chữ t rồi chèn vào chữ r sau đó nhấn enter, kết quả là: >>a=(1+sqrt(5))/2 ↵ a= 1.6180 Ta có thể sử dụng phím nhiều lần để tìm các lệnh đã gõ trước đó. Cũng có thể gọi nhanh lại một câu lệnh đã thực hiện trước đó bằng cách gõ ký tự đầu của dòng lệnh rồi nhấn ↑. Ví dụ, để gọi lại chính xác lệnh ở trên như sau: >>a ↑ 1.2.3.Xoá cửa sổ lệnh Sử dụng lênh clc để xoá cửa sổ lệnh (xoá màn hình). Lệnh này không xoá nội dung trong không gian làm việc Workspace, mà chỉ xoá màn hình. Sau khi sử dụng clc ta có thể sử dụng phím ↑ để gọi lại lệnh cũ. 1.2.4.Dừng một chương trình đang chạy Về nguyên tắc có thể dừng một chương trình đang chạy trong Matlab tại bất kỳ thời điểm nào bằng cách nhấn tổ hợp phím Ctrl + C. Tuy nhiên, ta vẫn có thể phải đợi cho đến khi một hàm đang thực thi bên trong hoặc MEX-file kết thúc hoạt động của nó. 1.2.5. Ngăn không cho hiển thị kết quả tính toán ra màn hình Nếu bạn chỉ đơn giản là gõ vào một câu lệnh (phép tính) và nhấn ↵ , Matlab sẽ tự động hiển thị kết quả của câu lệnh (phép tính) đó ra màn hình. Tuy nhiên nếu bạn kết thúc dòng lệnh với một dấu (;) thì Matlab sẽ thực hiện việc tính toán nhưng không hiển thị kết quả ra màn hình. Điều này đặc biệt có ích khi thực hiện tính toán với các véc tơ hoặc Matlab trận có số phần từ rất lớn. 7
  13. 1.2.6.Dòng lệnh dài Nếu một câu lệnh quá dài, không vừa trên một dòng, ta sử dụng một toán tử ba chấm (…) sau đó nhấn ↵ để biểu thị rằng câu lệnh còn tiếp tục ở dòng kế tiếp. Ví dụ: s = 1 – 1/2 + 1/3 – 1/4 + 1/5 – 1/6 + 1/7 ... – 1/8 + 1/9 – 1/10 + 1/11 – 1/12; Số ký tự tối đa cho phép trên một dòng là 4096 ký tự. Các khoảng trắng (dấu cách) xung quanh các dấu =, +, -, *, /,… là tuỳ ý (không nhất thiết phải có) nh ưng chúng giúp ta dễ đọc hơn. 1.2.7. Các Menu của Matlab a.Menu File Kích chuột vào File hoặc nhấn tổ hợp phím Alt-F, xuất hiện menu xổ chứa các lệnh liên quan đến việc tạo mới, quản lý, gán thuộc tính cho đối tượng (các tập tin - file) đã có sắn, thiết lập cấu hình phần mềm.... - New (hình 2.1): Hiện menu chứa ba lệnh để tạo đối tượng mới. Đối tượng ở đây có thể là một script, một cửa sổ đồ hoạ hay một mô hình mô phỏng hệ thống. + M-file: Hiện cửa sổ Editor/ Debugger. Đây là môi trường bạn tạo mới cũng như sửa đổi, gỡ rối các tập tin chương trình như M-file hoặc MEX-file hoặc các đối tượng nào đó để thực hiện một nhiện vụ nào đó. Để có thể tạo được các tập tin này, bạn Hình 2.1. Menu File và menu con của lệnh New phải dùng ngôn ngữ lập trình C hoặc FORTRAN. + Figure : Đây là môi trường đồ hoạ để bạn tự vẽ các đối tượng hoặc để Matlab vẽ các đồ thị theo hàm lệnh bạn nhập từ khung cửa sổ lệnh của MATLAB hoặc mở đồ thị cũ với lệnh Open của Matlab. 8
  14. - Open (hình 2.5): Mở tập tin đồ thị hoặc hình ảnh trong cửa sổ Figure để xử lý. Hình 2.7. Cửa sổ Open files Hình 2.2. Cửa sổ MATLAB Editor/Debuger Hình 2.3. Cửa sổ đồ hoạ của MATLAB + Trong cửa sổ Matlab Command windows kích: File/Open. Xuất hiện khung thoại Open. + Từ khung thoại, gõ địa chỉ của file vào ô file name, nhấn open hoặc kích chọn tên tập tin cùng kiểu tập tin (file type) muốn mở và kích Open. - Run Script : Chạy một chương trình đã lưu thành một tập tin. Trong cửa sổ Matlab Command window kích: File/Run Script. Hình 2.9. Khung thoại Run Script và hộp thoại Browse Trên màn hình xuất hiện khung thoại Run Script (hình 2.9). Gõ địa chỉ và tên tập tin vào trong khung nhập lệnh Run rồi kích OK. Để tìm kiếm các tập tin đã lưu trong máy, kích vào nút để duyệt. Từ khung thoại Browse chọn nguồn chứa và tên tập tin cần mở rồi 9 Hình 2.18. Cửa sổ Print setup
  15. kích vào Open để về khung thoại Run Script với toàn bộ đường dẫn cùng tên tập tin muốn mở. Kích OK. - Print Setup : Hiện khung thoại Print cùng các chức năng phụ liên quan đến việc in ấn (hình 2.18). -Exit MATLAB ( Ctrl + Q ): Thoát khỏi chương trình MATLAB để và trở về Windows B.MENU EDITS Hiện menu con chứa các lệnh liên quan đến việc xử lý các đối tượng (hình 2.19). - Undo : Huỷ lệnh hoặc thao tác đã thực hiện trước đó. Sau khi chọn lệnh Undo để huỷ lệnh, lệnh sẽ đổi thành Redo để người sử dụng khôi phục những gì đã huỷ trước đó với lệnh Undo. - Cut (Ctrl +X): Hình 2.19. Menu Edit Xoá tạm thời đối tượng trong khung cửa sổ lệnh hiện hành và đưa vào bộ nhớ đệm của chương trình, sau đó có thể dán đối tượng trở lại vào vị trí được chọn. Đối tượng được cắt có thể là một công thức, một chuỗi ký tự, hàm lệnh… + Chọn đối tượng muốn cắt trong khung cửa sổ lệnh MATLAB và ấn Ctrl + X hoặc chọn Cut từ menu Edit. Đối tượng sẽ tạm biến mất tại vị trí hiện hành. + Chọn vị trí cần dán rồi nhấn Ctrl + V hoặc Paste. Đối tượng sẽ được dán vào vị trí đã chọn. - Copy (Ctrl + C): Sao chép đối tượng trong khung cửa sổ lệnh MATLAB và sau đó dán vào vị trí đã chọn. Đối tượng được Copy có thể là một công thức, một chuỗi ký tự, hàm lệnh… + Chọn đối tượng cần Copy tại cửa sổ lệnh MATLAB và sau đó ấn Ctrl + C hoặc Copy. +Chọn vị trí cần copy đến và ấn Ctrl + V hoặc chọn Paste từ menu Edit. - Paste (Ctrl + V): Dán đối tượng đã được Cut hoặc Copy vào vị trí đã chọn. Ngoài ra , , bạn còn có thể dùng lệnh Paste của MATLAB để dán các đối tượng khác vào MATLAB. Xoá đối tượng đã được chọn trong khung cửa sổ MATLAB. - Clear: - Select All: Chọn toàn bộ nội dung trong khung cửa sổ lệnh của MATLAB. - Clear Session: 10
  16. Xoá toàn bộ nội dung của cửa sổ lệnh MATLAB sau khi chọn với lệnh Select All. Lệnh này cho phép xoá tất cả các thông tin trong bộ nhớ của chương trình, tương tự như việc ta đóng Matlab lại sau đó khởi động lại Matlab. C.MENU VIEW Đánh dấu chọn để hiện hay ẩn thanh công cụ trong khung cửa sổ lệnh MATLAB COMMAND WINDOW. D.MENU WINDOW Hình 2.20. Menu View Hiện thông tin về số tập tin đang mở trong khung cửa sổ lệnh MATLAB. 1.2.8. Một số phím chuyên dụng và lệnh thông dụng ↑ Hoặc Ctrl + p : Gọi lại các lệnh đã thực hiện trước đó. - ↓ Hoặc Ctrl +n : Gọi lại lệnh vừa thực hiện trước đó. - → Hoặc Ctrl + f : chuyển con trỏ sang bên phải 1 ký tự. - ← hoặc Ctrl + b: chuyển con trỏ sang trái một ký tự. - Dấu “;” dùng trong […] để kết thúc một hàng của ma trận - hoặc kết thúc một biểu thức hoặc câu lệnh mà không hiển thị kết quả ra mà hình. ↵ nhảy xuống dòng dưới - Ctrl + A hoặc Home : chuyển con trỏ về đầu dòng. - Ctrl + E hoặc End: Chuyển con trỏ đến cuối dòng. - BackSpace: Xoá ký tự bên trái con trỏ. - Esc: xoá dòng lệnh. - Ctrl + K : Xoá từ vị trí con trỏ đến cuối dòng. - Ctrl + C : Dừng chương trình đang thực hiện. - Clc : lệnh xoá màn hình. - Clf: Lệnh xoá màn hình đồ hoạ. - Input: lệnh nhập dữ liệu vào từ bàn phím. - Demo: lệnh cho phép xem các chương trình mẫu. - Help: lệnh cho phép xem phần trợ giúp. - Ctrl – c: Dừng chương trình khi nó bị rơi vào trạng thái lặp - không kết thúc. Dòng lệnh dài: Nếu dòng lệnh dài quá thì dùng … ↵ để chuyển - xuống dòng dưới. 1.2.9.Biến trong Matlab a.Đặc điểm của biến trong Matlab: 11
  17. - Không cần khai báo biến và kiểu của biến. Tuy nhiên trước khi gán một biến thành một biến khác thì cần đảm bảo rằng biến ở bên phải của phép gán có một giá trị xác định. - Bất kỳ một phép toán nào gán một giá trị vào một biến sẽ tạo ra biến đó nếu cần (biến đó chưa xác định) hoặc ghi đè lên giá trị hiện tại nếu nó đã tồn tại trong Workspace. - Tên biến bao gồm một chữ cái sau một số bất kỳ các chữ cái, chữ s ố và d ấu gạch dưới. Matlab phân biệt chữ in hoa và chữ in thường, vì vậy X và x là hai bi ến phân biệt. - Tên biến là một dãy ký tự bao gồm các chữ cái hay các chữ số hoặc một số ký tự đặc biệt dùng để chỉ tên của biến hoặc tên của hàm. Chúng phải được bắt đầu bằng chữ cái sau đó có thể là các chữ số hoặc một vài ký tự đặc biệt. Chiều dài tối đa của tên là 31 ký tự. - Bình thường Matlab có sự phân biệt các biến tạo bởi chữ cái thường và chữ cái in hoa. Các lệnh của Matlab nói chung thường sử dụng chữ cái thường. Việc phân biệt đó có thể được bỏ qua nếu chúng ta thực hiện lệnh : >> casensen off b. Một số lệnh với biến clear: lệnh xoá tất cả các biến đã được định nghĩa trước trong - chương trình . clear biến1, biến 2... : xoá các biến được liệt kê trong câu - lệnh. Who: hiển thị các biến đã được định nghĩa trong chương trình. - Whos: hiển thị các biến đã được định nghĩa trong chương trình - cùng với các thông số về biến. Size (tên biến đã được định nghĩa): cho biét kích cỡ của biến - dưới dạng ma trận với phần tử thứ nhất là số hàng của ma trận, phần tử thứ 2 là số cột của ma trận. Save: Lưu giữ các biến vào một File có tên là Matlab. mat. - Load: Tải các biến đã được lưu giữ trong một File đưa vào - vùng làm việc. c.Một số biến đã được định nghĩa trước - ans: Answer - tự động gán tên này cho kết quả của một phép tính mà ta không đặt tên. VD >> [ 1 2] ↵ ans = 2 π = 3.1415926535897... - pi 12
  18. - realmax: đưa ra giá trị của số lớn nhất mà máy tính có thể tính toán được. - realmin: đưa ra giá trị của số nhỏ nhất mà máy tính có thể tính toán được. - i, j: Đơn vị ảo của số phức. - inf: infinity- vô cùng lớn. 1.2.10. Các phép toán trong Matlab a.Phép toán số học Matlab có hai kiểu phép toán số học, đó là phép toán ma tr ận (matrix arithmetic operation) và phép toán mảng (array arithmetic operation). Phép toán ma trận được định nghĩa bởi các luật của đại số tuyến tính. Phép toán mảng được thực hiện tương ứng từng phần tử, chẳng hạn phép nhân mảng hai ma trận A có các phần tử là a(i,j) và B có các phần tử là b(i,j) được thực hiện bằng cách nhân tương ứng từng phần tử của A và B: c(i,j) = a(i,j)b(i,j) Để phân biệt giữa phép toán ma trận và phép toán mảng người ta đưa thêm vào trước các toán tử một dấu chấm “.”. Phép toán ma trận Phép toán mảng Toán tử Phép Phép toán To án tử toán Cộng Cộng + + Trừ Trừ. - - Nhân * Nhân. .* Chia phải Chia / ./ phải \ Chia trái .\ Chia Luỹ thừa. ^ .^ trái = Phép gán. = Luỹ thừa Phép gán b.Thứ tự ưu tiên trong phép toán số học ngoặc đơn. luỹ thừa 13
  19. nhân, chia. Cộng, trừ. c.Các phép toán quan hệ và phép toán logic Các phép toán quan hệ bao gồm: Nhỏ hơn: - < Nhỏ hơn hoặc bằng: Lớn hơn hoặc bằng: >= - - Bằng: == Không bằng (khác): ~= - Biểu thức có các toán tử quan hệ nhận gia trị đúng là (true) hoặc sai (false). Trong Matlab, biểu thức đúng sẽ có giá trị là 1, biểu thức sai có gia trị là 0. Ví dụ 1 >>12.2>12 >> A=[ 1:3;4:6;7:9] >> A=[ 1:3;4:6;7:9] ans = A= A= 1 1 2 3 1 2 3 >>1~=1 4 5 6 4 5 6 ans = 7 8 9 7 8 9 0 >> >> A==B B=[1:3;2:4;10:12] ans = B= 1 1 1 1 2 0 0 0 3 0 0 0 2 3 4 10 11 12 1.3.Sử dụng các lệnh trực tiếp từ Matlab • Ví dụ 1: Giải phương trình bậc hai ax2 +bx +c = 0 Ta biết các nghiệm của phương trình này có dạng: − b ± b 2 − 4ac x= 2a 14
ADSENSE
ADSENSE

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản