intTypePromotion=1

Bài giảng MasterCam X part 5

Chia sẻ: Ashdkajd Daksdjk | Ngày: | Loại File: PDF | Số trang:15

0
414
lượt xem
251
download

Bài giảng MasterCam X part 5

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

MasterCAMX sẽ biểu diễn ellipse khi bạn nhập xong điểm tâm của ellipse Chú ý: Tất cả các góc được đo bằng độ, hướng ngược chiều kim đồng hồ Thủ tục: ví dụ 1 Điều chỉnh ellipse với chỉ định sẵn A (bán kính trục X) = 3.0 B (bán kính trục Y) = 1.5 Góc bắt đầu = 30 Góc kết thúc = 300 Góc quay = 0 Chọn Center Point Nhập điểm tâm: Pick P1 Thủ tục: ví dụ 2 Điều chỉnh ellipse với chỉ định sẵn A (bán kính trục X) = 3.0 B (bán kính trục...

Chủ đề:
Lưu

Nội dung Text: Bài giảng MasterCam X part 5

  1. Bµi gi¶ng MasterCAM  Radius B : dùng b¸n kÝnh trôc Y cña ellipse  Start angle : Dùng gãc b¾t ®Çu cña gãc.  End angle : Dùng gãc kÕt thóc  Rot angle : Dùng gãc quay vÒ h­íng cña trôc X  Center Point : Dùng t©m cña ellipse  Surface : Chän ®èi t­îng theo mÆt  Base point : DÞch chuyÓn ellipse sau khi nhËp täa ®é ®iÓm t©m (víi gèc dÞch chuyÓn lµ ®iÓm t©m cña ellipse). MasterCAMX sÏ biÓu diÔn ellipse khi b¹n nhËp xong ®iÓm t©m cña ellipse Chó ý: TÊt c¶ c¸c gãc ®­îc ®o b»ng ®é, h­íng ng­îc chiÒu kim ®ång hå Thñ tôc: vÝ dô 1 Thñ tôc: vÝ dô 2 §iÒu chØnh ellipse víi chØ ®Þnh s½n §iÒu chØnh ellipse víi chØ ®Þnh s½n A (b¸n kÝnh trôc X) = 3.0 A (b¸n kÝnh trôc X) = 3.0 B (b¸n kÝnh trôc Y) = 1.5 B (b¸n kÝnh trôc Y) = 1.5 Gãc b¾t ®Çu = 30 Gãc b¾t ®Çu = 30 Gãc kÕt thóc = 300 Gãc kÕt thóc = 300 Gãc quay = 0 Gãc quay = 15 Chän Center Point Chän Center Point NhËp ®iÓm t©m: Pick P1 NhËp ®iÓm t©m: Pick P1 P1 P1 H×nh 2.65 2.12 Polygon vµ thanh c«ng cô Polygon: Menu polygon ®­îc gäi nh­ sau: Create > Polygon hoÆc pick chän §Ó t¹o ra mét ®a gi¸c trong MasterCAMX b¹n cÇn khai b¸o n¨m tham sè vµ to¹ ®é t©m - 61 -
  2. Bµi gi¶ng MasterCAM No. side §Æt sè c¹nh cña ®a gi¸c Radius B¸n kÝnh ®­êng trßn ngo¹i tiÕp hay néi tiÕp cña ®a gi¸c §­êng trßn néi tiÕp ®a gi¸c §­êng trßn ngo¹i tiÕp ®a gi¸c B¸n kÝnh cña gãc lù¬n gi÷a 2 c¹nh cña ®a gi¸c Gãc xoay cña trôc X Chän ®èi t­îng theo mÆt Dùng t©m cña ellipse Chó ý: Gãc b¾t ®Çu ®­îc ®o b»ng ®é h­íng ng­îc chiÒu kim ®ång hå Thñ tôc: vÝ dô 1 Thñ tôc: vÝ dô 2 HiÖu chØnh ®a gi¸c sè 1 HiÖu chØnh ®a gi¸c sè 2 víi nh÷ng chØ ®Þnh s½n víi nh÷ng chØ ®Þnh s½n Sè c¹nh cña ®a gi¸c = 5 Sè c¹nh cña ®a gi¸c = 5 B¸n kÝnh cña ®a gi¸c = 1.0 B¸n kÝnh cña ®a gi¸c = 1.0 §o b¸n kÝnh tíi gãc Corner §o b¸n kÝnh tíi gãc Flat Chän t©m (Center Point) Chän t©m (Center Point) NhËp to¹ ®é t©m Pick P1 NhËp to¹ ®é t©m Pick P1 P1 P1 H×nh 2.66 2.13 X©y dùng m« h×nh h×nh häc 2D Trong phÇn tiÕp theo ta cã 5 bµi tËp, b¹n sÏ luyÖn tËp b»ng viÖc phèi hîp c¸c lÖnh ®· ®­îc häc trong ch­¬ng nµy. Tõng b­íc c¸c thñ tôc ®· häc sÏ ®­îc hoµn thiÖn. Ghi l¹i c¸c f ile d­íi c¸ci tªn ®· ®­îc chØ ®Þnh s½n. B¹n sÏ nhËn ®­îc c¸c file ®Ó t¹o ra c«ng cô tiÕp theo cho ch­¬ng 7 vµ 8. - 62 -
  3. Bµi gi¶ng MasterCAM Project 1. T¹o ra phÇn m« h×nh h×nh häc nh­ trong h×nh 2.67. Ghi l¹I file d­íi c¸I tªn contuor1. File sÏ ®­îc sö dông trong ch­¬ng 7 Chó ý: 1. M« h×nh h×nh häc trªn ®èi xøng qua trôc Y. 2. C¬ së cho m« h×nh nµy chñ yÕu ë hai h×nh ch÷ nhËt, hai cung, hai gãc bo. Step 1. T¹o ®­êng th¼ng d­íi cïng Chän Create > Line > Create Line Endpoint Chän ®­êng n»m ngang Horizontal , kÝch chän NhËp täa ®é ®iÓm ®Çu: P1 H×nh 2.67 NhËp chiÒu dµi cña ®o¹n th¼ng (Enter) H×nh 2.68 Step 2. T¹o 1 ®­êng th¼ng offset víi ®­êng th¼ng trªn 0.75 KÝch chän ®­êng th¼ng cÇn offset : P1 Chän Xform > Xform Offset NhËp gi¸ trÞ offset vµo « H×nh 2.69 Chän Coppy vµ h­íng offset (Direction) , OK Step 3: T¹o ra 2 cung trßn R4 vµ R5 Chän Create > Arc > Create Arc Polar Chän chÕ ®é b¾t ®iÓm Midpoint trong config Chän ®iÓm t©m n»m ë trung ®iÓm cña ®­êng th¼ng võa t¹o bªn trªn: P1 - 63 - H×nh 2.70
  4. Bµi gi¶ng MasterCAM NhËp b¸n kÝnh , gãc ban ®Çu , gãc kÕt thóc NhËp xong nhÊn Enter hoÆc Esc T­¬ng tù chän ®iÓm t©m : P1 NhËp b¸n kÝnh , gãc ban ®Çu: , gãc kÕt thóc NhËp xong nhÊn Enter hoÆc Esc Step 4 : T¹o ra c¸c ®o¹n th¼ng nèi kÝn gi÷a cung trßn ngoµi vµ ®­êng th¼ng d­íi cïng Chän Create > Line > Endpoint KÝch chän 2 ®iÓm nèi ®Ó t¹o thµnh 2 ®o¹n th¼ng nh­ h×nh vÏ H×nh 2.71 Step 5 : T¹o ra c¸c ®­êng th¼ng cßn l¹i  Tr­íc tiªn ta t¹o 1 ®­êng th¼ng vu«ng gãc víi ®­êng th¼ng d­íi cïng vµ cã ®é dµi 7.0, b»ng c¸ch :  Chän Create > Line > Create Line Endpoint  Chän ®­êng th¼ng ®øng , kÝch chän  NhËp täa ®é ®iÓm ®Çu (lµ t©m cña ®­êng th¼ng d­íi cïng): P1  NhËp chiÒu dµi cña ®o¹n th¼ng , (Enter)  Offset sang 2 bªn cña ®­êng th¼ng võa t¹o 1 l­îng lµ 1.5 vµ 3.0  KÝch chän ®­êng th¼ng cÇn offset : P1  Chän Xform > Xform Offset  NhËp gi¸ trÞ offset vµo «  Chän Coppy vµ h­íng offset (Direction) , OK  T­¬ng tù Offset 1 l­îng 3.0  Nèi 2 ®iÓm ®Çu cña 2 ®­êng th¼ng (Offset 1.5) - 64 -
  5. Bµi gi¶ng MasterCAM Step 6 : C¾t bá vµ xãa nh÷ng ®­êng H×nh 2.72 th¼ng kh«ng cÇn thiÕt Chän Create > Edit > Trim/Break > Divide Chän c¸c ®èi t­îng ®Ó c¾t : P1, P2, P3, …®Ó ®­îc nh­ h×nh vÏ Step 7 : Create > Fillet > Fillet Entities H×nh 2.73 NhËp b¸n kÝnh gãc bo Chó ý: H·y ch¾c ch¾n r»ng hai tuú chän kia ph¶i ®óng. NÕu nÕu gãc bo nhá h¬n 1800 Chän mét ®èi t­îng thø nhÊt : Pick P1 Chän mét ®èi t­îng thø 2 : Pick P2 P3 NhËp b¸n kÝnh kh¸c P4 Chän mét ®èi t­îng thø nhÊt : Pick P3 Chän mét ®èi t­îng thø 2 : Pick P4 2 fillet ®­îc t¹o ra nh­ trªn h×nh 2.74 P2 P1 M« h×nh h×nh häc ®· ®ùîc hoµn thµnh nh­ h×nh 2.75 H×nh 2.74 - 65 -
  6. Bµi gi¶ng MasterCAM H×nh 2.75 Step 8: Ghi l¹i file ®· lµm Chän File > Save Chän ®­êng dÉn tíi th­ môc cÇn l­u file trong Save in NhËp tªn file (file name): contour1 Project 2. VÏ ra phÇn h×nh häc nh­ trªn h×nh vÏ 2.76. Ghi l¹I file trªn víi tªn contour3. File nµy sÏ dïng trong bµi 3 cña ch­¬ng 7. Chó ý: H×nh 2.76 1. M« h×nh nµy cã thÓ t¹o ra b»ng c¸ch sö dông 1 h×nh ch÷ nhËt vµ lÖnh line 2. HoÆc mét sè to¹ ®é ®iÓm nh­ trªn h×nh d­íi ®©y P2(6,4) P5(2,3.5) P6(4,3.5) P4(0.5,2) P7(5.5,2) P1(0,0) P8(5.5,0) P3(0.5,0) H×nh 2.78 - 66 -
  7. Bµi gi¶ng MasterCAM Step 1. T¹o mét h×nh ch÷ nhËt Chän Create > Rectangle hoÆc chän biÓu t­îng NhËp gãc d­íi tr¸i NhËp gãc trªn ph¶i Step 2. T¹o n¨m line Chän Create > Line , råi kÝch chän Multi_Line NhËp ®iÓm thø nhÊt (P3) NhËp ®iÓm thø 2 (P4) NhËp ®iÓm thø 3 (P5) NhËp ®iÓm thø 4 (P6) NhËp ®iÓm thø 5 (P7) NhËp ®iÓm thø 6 (P8) Ta ®­îc m« h×nh nh­ h×nh 2.79 Step 3. L­u tÖp tin. H×nh 2.79 Chän MAIN MENU > File > Save NhËp tªn file (Enter file name): contour3 Project 3 X©y dùng m« h×nh nh­ h×nh 1.80. Ghi l¹i d­íi tªn pocket1 File nµy sÏ ®­îc dïng ®Ó t¹o ra ®­êng dÉn cho bµi tËp 5 ë ch­¬ng 7. H×nh 2.80 - 67 -
  8. Bµi gi¶ng MasterCAM Chó ý: 1. T¹o hai h×nh ch÷ nhËt vµ s¸u ®­êng trßn 2. BÎ g·y hai ®­êng th¼ng ngang cña h×nh ch÷ nhËt trong thµnh hai phÇn ®Ó cho phÐp c¾t ®­êng trßn thµnh hai 3. C¾t s¸u ®­êng trßn vµ bèn line ba ®èi t­îng lÖnh Step 1. T¹o ra hai h×nh ch÷ nhËt Chän Create > Rectangle Chän 1 ®iÓm bÊt k× : P1 NhËp chiÒu réng vµ chiÒu dµi cña h×nh ch÷ nhËt , nhÊn Enter Chän Xform > Xform Offset Contour KÝch chän Chain råi chän Option , xuÊt hiÖn 1 b¶ng lùa chän , ta chän ®èi t­îng theo mÇu kÝch chän ,xong chän OK Chän ®èi t­îng cÇn offset (h·y ®Ó ý ®Õn chiÒu dÞch chuyÓn cña ®èi t­îng) , råi chän OK XuÊt hiÖn b¶ng chän c¸c th«ng sè sau: Coppy, 1 ®èi t­îng, l­îng Offset vµ h­íng Offset cho phï hîp , xong chän OK Ta ®­îc kÕt qu¶ nh­ h×nh sau : H×nh 2.81 Step 2. T¹o s¸u ®­êng trßn Chän Create > Arc > Arc Polar hoÆc chän biÓu t­îng Chän ®iÓm t©m : P1 NhËp b¸n kÝnh , gãc b¾t ®Çu , gãc kÕt thóc NhÊn Enter hoÆc Esc Chän ®iÓm t©m : P2 NhËp b¸n kÝnh , gãc b¾t ®Çu , gãc kÕt thóc NhÊn Enter hoÆc Esc - 68 -
  9. Bµi gi¶ng MasterCAM Chän ®iÓm t©m : P3 NhËp b¸n kÝnh , gãc b¾t ®Çu , gãc kÕt thóc NhÊn Enter hoÆc Esc Chän ®iÓm t©m : P4 NhËp b¸n kÝnh , gãc b¾t ®Çu , gãc kÕt thóc NhÊn Enter hoÆc Esc Chän ®iÓm t©m : P5 (sö dông chÕ ®é b¾t ®iÓm Midpoint) NhËp b¸n kÝnh , gãc b¾t ®Çu , gãc kÕt thóc NhÊn Enter hoÆc Esc Chän ®iÓm t©m : P6 (sö dông chÕ ®é b¾t ®iÓm Midpoint) NhËp b¸n kÝnh , gãc b¾t ®Çu , gãc kÕt thóc NhÊn Enter hoÆc Esc 6 cung trßn ®­îc t¹o ra nh­ h×nh sau Step 3. C¾t bá nh÷ng phÇn thõa ®Ó ®­îc m« h×nh hoµn chØnh H×nh 2.82 Chän Xform > Trim > Divide Chän c¸c ®èi t­îng ®Ó c¾t : P1, P2, P3, …®Ó ®­îc nh­ h×nh vÏ H×nh 2.83 - 69 -
  10. Bµi gi¶ng MasterCAM 1 1 Step 4. Save file l¹i Chän File > Save NhËp tªn file (file name): drill2 4 2 Chó ý : File h×nh häc drill2 ®­îc dïng ®Ó khoan vµ ta r« s¸u lç trong bµi 8 ë ch­¬ng 7 1 2 2 2 Project 4: T¹o mét h×nh ch÷ nhËt vµ bèn ®iÓm nh­ trªn h×nh vÏ 1.5 2.25 Ghi l¹i file víi tªn drill3. File sÏ ®­îc dïng trong bµi 9 cña ch­¬ng 7 0.75 H×nh 2.84 P6(5,3,-2.25) §èi t­êng h×nh häc nµy bao gåm mét P4(1,3,-1.5) h×nh ch÷ nhËt vµ 4 ®iÓm. HÖ trôc to¹ ®é P2(6,4) cña c¸c ®iÓm mèc ®­îc thÓ hiÖn trong h×nh 2.85 P1(0,0) P5(5,1,-2.25) P3(1,1,-1.5) H×nh 2.85 Step 1. T¹o mét h×nh ch÷ nhËt Chän Create > Rectangle hoÆc chän biÓu t­îng NhËp gãc d­íi tr¸i NhËp gãc trªn ph¶i Step 2. T¹o bèn ®iÓm Chän Create > Point > Position hoặc chọn biểu tượng NhËp to¹ ®é : NhËp to¹ ®é : NhËp to¹ ®é : NhËp to¹ ®é : - 70 -
  11. Bµi gi¶ng MasterCAM Step 3. Ghi l¹i file Chän File > Save NhËp tªn file (file name): drill3 Project 5. Sö dung lÖnh Letters ®Ó t¹o m« h×nh sau. M« h×nh nµy gåm hai ®­êng trßn vµ n¨m chuç i ch÷ trong 3 lo¹i ph«ng; MCX (box) font, Arial, vµ TimesNew Roman. Sö dông c¸c ph«ng ®ã ®Ó t¹o c¸c ch÷: 1. EASTERN MICHIGAN UNIVERSITY Font = MCX (box) font Height = 0.5 Spacing = 0.05 Arc Radius = 2.4 2. INDUSTRIAL TECHNOLOGY Font = MCX (box) font H×nh 2.86 Height = 0.3 Spacing = 0.05 Arc Radius = 2.5 3. CAD CAM Font = Arial (Regular) Height = 0.4 Spacing = 0.1 Arc Radius = 1.4 4. CNC Font = Arial (Bold Italic) Height = 0.6 Spacing = 0.15 Starting point = (-1,-0.3) 5. YES Font = Times New Roman (Regular) Height = 0.8 Spacing = 0.2 Arc Radius = 1.4 Chó ý : B¹n cã thÓ thay ®æi mÇu vµ ch÷ trªn h×nh trªn - 71 -
  12. Bµi gi¶ng MasterCAM Step 1.T¹o hai ®­êng trßn Chän Create > Arc > Circle center point hoặc chọn biểu tượng NhËp to¹ ®é t©m : NhËp ®­êng kÝnh : NhËp to¹ ®é t©m : NhËp ®­êng kÝnh : Hai ®­êng trßn sÏ xuÊt hiÖn nh­ h×nh vÏ 7.87 Step 2. T¹o ra chuçi kÝ tù sö dông mÇu 12 vµ level 2 Hình 2.87 KÝch chọn sau ®ã nhËp 2 KÝch chọn sau đó chọn mầu 12 Chän Create > Letters Chọn font : MCX (box) font NhËp letters : EASTERN MICHIGAN UNIVERSITY Chän Top of arc NhËp chiÒu cao ch÷ (letter height): 0.5 NhËp ®é n©ng cña ch÷ (letter spacing): 0.05 NhËp b¸n kÝnh cung trßn (arc radius): 2.45 Khoảng cách giữa các chữ (spacing ) : 0.05 Chọn c¸c thong số xong kÝch chọn OK NhËp to¹ ®é t©m cung trßn : Step 3. T¹o chuçi ch÷ d­íi ®¸y cung trßn Chän Create > Letters Chọn font : MCX (box) font NhËp ch÷ ( letters): INDUSTRIAL TECHNOLOGY NhËp chiÒu cao ch÷ (letter height): 0.3 Chän Bottom of arc NhËp ®é n©ng cña ch÷ (letter spacing): 0.05 NhËp b¸n kÝnh cung trßn (arc radius): 2.5 Chọn c¸c th«ng số xong kÝch chọn OK H×nh 2.88 - 72 -
  13. Bµi gi¶ng MasterCAM NhËp to¹ ®é t©m cung trßn: Hai chuçi ch÷ ®­îc t¹o ra nh­ h×nh vÏ 7.88 Step 4. Thay ®æi level thµnh 3 vµ color thµnh 13 Chän Level sau ®ã nhËp 3 Chän Color sau ®ã nhËp 13 Step 5. T¹o ra mét chuçi ch÷ theo ph«ng Arial trªn cung trßn Chän Create > Letters >True type(R) > font Arial (Regular) > OK NhËp ch÷ (letters): CAD CAM NhËp chiÒu cao ch÷ (letter height): 0.4 Chän top of arc NhËp ®é n©ng cña ch÷ (letter spacing): 0.1 NhËp b¸n kÝnh cung trßn (arc radius): 1.4 Chän c¸c th«ng sè xong kÝch chọn OK NhËp to¹ ®é t©m cung trßn: Chuçi ch÷ ®­îc t¹o ra nh­ h×nh vÏ 7.89 H×nh 2.89 Step 6. T¹o ra mét chuçi ch÷ CNC däc theo ®­êng th¼ng Chän Create > Letters >Truetype (R) > Arial Bold Italic > OK NhËp ch÷ (letters): CNC NhËp chiÒu cao ch÷ (letter height): 0.6 Chän Horizontal NhËp ®é n©ng cña ch÷ (letter spacing): 0.15 Chän c¸c th«ng sè xong kÝch chọn OK NhËp ®iÓm b¾t ®Çu cña chuçi: Chuçi ch÷ ®­îc t¹o ra nh­ h×nh vÏ 7.90 Hình 2.90 - 73 -
  14. Bµi gi¶ng MasterCAM Step 7. T¹o chuçi ch÷ YES d­íi ®¸y cung trßn Chän Create > Letters >Truetype (R) > Times New Roman > Regular > OK NhËp ch÷ (letters): YES NhËp chiÒu cao ch÷ (letter height): 0.6 Chän Bottom of arc NhËp ®é n©ng cña ch÷ (letter spacing): 0.2 NhËp b¸n kÝnh cung trßn (arc radius): 1.4 Chän c¸c th«ng sè xong kÝch chän OK NhËp to¹ ®é t©m cung trßn: H×nh 2.91 Hai chuçi ch÷ ®­îc t¹o ra nh­ h×nh vÏ 7.91 Step 8. L­u tÖp tin Chän File > Save NhËp tªn file ( file name): letter2 Project 6. Thay ®æi ch÷ CNC tõ level 3 vµ mÇu 13 thµnh level 4 vµ mÇu 14 Step 1. T×m l¹i file LETTER2.MC7 ®· ®­îc lµm tõ Project 5 Chän File > Open hoÆc kÝch chän H×nh 2.92 T×m ®­êng dÉn ®Õn file: Letter2.mc7 File sÏ xuÊt hiÖn nh­ trong h×nh 2.92 Step 2. Thay ®æi sù x¾p ®Æt thµnh level 4 vµ color 14 Chän Level sau ®ã nhËp 4 Chän Color sau ®ã nhËp 14 Chän Menu Analyze > Entity properties hoÆc kÝch chän biÓu t­îng Chän ®èi t­îng ®Ó thay ®æi (ch÷ CNC) sau ®ã Ên Enter XuÊt hiÖn b¶ng tïy chän, thay ®æi thµnh H×nh 2.93 - 74 -
  15. Bµi gi¶ng MasterCAM vµ kÝch chän Ch÷ CNC ®­îc thay ®æi thµnh color 14 2.14 luyªn tËp: 1. Dïng mét b¶n vÏ nµo ®è ®Ó thÓ hiÖn menu lÖnh ®· häc. T¹o lËp c¸c ®èi t­îng h×nh häc 2. Mét ®iÓm cã thÓ x¸c ®Þnh trong MasterCAM b»ng bao nhiªu c¸ch? 3. Cã bao nhiªu tuú chän ®Ó t¹o ra mét ®­êng th¼ng trong MasterCAM ? 4. M« t¶ nÐt ®Æc tr­ng khi t¹o ra c¸c ®­êng (line) liªn kÕt 5. M« t¶ sù kh¸c nhau gi÷a cung trßn vµ ®­êng trßn 6. Cã bao nhiªu tuú chän ®Ó t¹o ra cung trßn 7. Cã bao nhiªu tuú chän ®Ó t¹o ra ®­êng trßn ? 8. Ba tham sè fillet lµ g×? M« t¶ c¸ch sö dung c¸c tham sè ®ã trªn mét b¶n vÏ 9. Spline lµ g×? Sè ®iÓm tèi thiÓu ®Ó x¸c ®Þnh mét spline? 10. Hai c¸ch b×nh th­êng ®Ó t¹o ra ®­êng cong 2D trong MasterCAM lµ g× ? 11. Sö dông mét b¶n vÏ ®Ó thÓ hiÖn c¸ch t¹o ra mét h×nh ch÷ nhËt b»ng 1 ®iÓm vµ 2 ®iÓm 12. M« t¶ thñ tôc dïng trong MasterCAM ®Ó t¹o ra ph«ng ch÷ 13. T¹o m« h×nh 2.94 vµ m« h×nh 2.95 vµ ghi l¹i d­íi file d­íi tªn drill4. T¹o ra m« hinh (h×nh 2.96) vµ ghi l¹i d­íi file d­íi tªn comb2. H×nh 2.94 H×nh 2.95 - 75 -
ADSENSE
ADSENSE

CÓ THỂ BẠN MUỐN DOWNLOAD

 

Đồng bộ tài khoản
2=>2